Bug 371971 - Rpm install on ppc fails due to missing symbol (__clear_user)
Rpm install on ppc fails due to missing symbol (__clear_user)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
powerpc Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jon Masters
GFS Bugs
: ZStream
Depends On:
Blocks: 373591
  Show dependency treegraph
 
Reported: 2007-11-08 17:12 EST by Chris Feist
Modified: 2008-05-21 11:01 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:01:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Feist 2007-11-08 17:12:30 EST
Rpm install on ppc fails due to missing symbol (__clean_user)
Comment 1 Chris Feist 2007-11-08 17:13:33 EST
Settings ack for inclusion in 5.1.z stream.
Comment 2 Robert Peterson 2007-11-08 22:39:10 EST
Reassigning to Chris at his request.
Comment 3 Chris Feist 2007-11-09 14:13:11 EST
Updating to urgent to get z-stream ack.
Comment 6 Chris Feist 2007-11-20 16:21:01 EST
This needs to be fixed in the kernel rpm.

__clean_user needs to be added to the ppc kernel whitelist (as it is already on
the x86_64 & x86 whitelists).  We're currently working around the issue in 5.1,
but it should be in 5.2 if at all possible.
Comment 7 Chris Feist 2007-11-27 13:40:14 EST
The actual symbol is __clear_user (not __clean_user), I've updated the bug subject.
Comment 10 Don Zickus 2008-03-07 17:13:57 EST
in kernel-2.6.18-73.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 12 Mike Gahagan 2008-04-02 16:24:12 EDT
verified __clear_user is being exported on ppc and I could install the
2.6.18-88.el5 kernel rpm without issues.
Comment 14 errata-xmlrpc 2008-05-21 11:01:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.