Bug 372061 - Control key modifier not working correctly with Dvorak keyboard layout
Control key modifier not working correctly with Dvorak keyboard layout
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 21:48 EST by Derrick Moser
Modified: 2009-01-09 00:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:06:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete Dvorak keyboard mapping file with working Control keys, etc. (2.91 KB, text/plain)
2008-01-08 18:27 EST, Mark Harig
no flags Details
'diff -u' listing of differences between xmodmap.dvorak and a new version (1.80 KB, patch)
2008-01-08 18:31 EST, Mark Harig
no flags Details | Diff

  None (edit)
Description Derrick Moser 2007-11-08 21:48:57 EST
Description of problem:
Control key modifier not working correctly with Dvorak keyboard layout.

Version-Release number of selected component (if applicable):
gnome-applets-2.20.0-7.fc8

How reproducible:

Steps to Reproduce:
1. Open the keyboard preferences in System > Preferences > Hardware > Keyboard
2. From the "Layouts" tab, add the "U.S. English" "Dvorak" layout.
3. Note the location of keys like "C" and "V" in the preview.
4. Switch to using the Dvorak layout.
5. Try using ^C and ^V to copy-n-paste text from an application or ^C to
interrupt a process from a terminal remembering you are using the Dvorak layout
and the position of the keys are different from the QWERTY layout.

Actual results:
Pressing ^C and ^V does not copy-n-paste text in applications, nor does ^C
interrupt processes in the terminal.  However ^J ^K seem to copy-n-paste test
and ^J interrupts processes in the terminal (they correspond to the C and V keys
on the QWERTY layout).

Expected results:
Pressing ^C and ^V (using the position of these keys on the Dvorak layout)
should copy-n-paste text in applications, and ^C should interrupt processes in
the terminal.

Additional info:
This worked fine in Fedora 7 and all previous Fedora Core releases.
Comment 1 Mark Harig 2008-01-08 18:26:21 EST
1. In addition to the above, I also found that the 'src' RPM for gnome-applets at:

http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/source/SRPMS/

is version 2.20.0-7, while the available 'binary' RPM version is 2.20.0-8, which
is the version I have installed.

2. I downloaded the older version (i.e., the '-7' version) of the 'src' RPM and
installed it.  I then extracted the files in the compressed archive 
gnome-applets-2.20.0.tar.bz2.  This archive contains the file gnome-applets
-2.20.0/gkb-new/xmodmap/xmodmap.dvorak.

3. I inspected this file and found that appears to be lacking some 'add
MODIFIERNAME = ...' lines.  I am including a 'diff -u' listing that lists the
lines that I needed to add or change in order to get the Dvorak keyboard mapping
to work, including the left and right Control keys.

4. The following keys did not work for me when I added *only* the 'add
MODIFIERNAME = ...':

   - ^ (shifted 6 key)
   - ( (shifted 9 key)
   - ) (shifted 0 key)
   - , (comma key)
   - < (shifted comma key)
   - . (period key)
   - > (shifted period key)

  After the changes I made to the 'keycode' lines for the above keys, the keys
for those characters worked.  These additional lines may not be needed, but I
was unable to find enough information in the manual page for 'xmodmap' to
explain why the original keycode definitions were not working for me.

5. I am also including a complete copy of the modified xmodmap.dvorak file in
case it can be useful for anyone else to test it.  It can be installed with the
following command at a shell prompt: xmodmap xmodmap-new.dvorak

   Note that you may want to have a copy of your current xmodmap file BEFORE you
run the previous command so that you can restore your keyboard mapping.  For
example:

    $ xmodmap -pke > my.xmodmap  # preserve current keyboard mapping
    $ xmodmap xmodmap-new.dvorak # switch to Dvorak mapping
    $ # test keyboard mapping
    $ xmodmap my.xmodmap         # switch back to your original mapping

6. I have not tested these changes in a thorough manner, i.e., I have not
rebuilt the gnome-applets binary RPM and installed it.  Partly, this is because
I need some additional remappings of the locations of the Ctrl/Alt/Super keys
and so I expect not to use gnome-applets for my keyboard mapping switching.

7. Are there Dvorak keyboard mappings for non-US-English keyboards?  If so, then
perhaps 'xmodmap.dvorak' should be renamed to xmodmap.us-dvorak.
Comment 2 Mark Harig 2008-01-08 18:27:57 EST
Created attachment 291101 [details]
Complete Dvorak keyboard mapping file with working Control keys, etc.
Comment 3 Mark Harig 2008-01-08 18:31:42 EST
Created attachment 291102 [details]
'diff -u' listing of differences between xmodmap.dvorak and a new version
Comment 4 Bug Zapper 2008-11-26 03:15:02 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-01-09 00:06:58 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.