Bug 37254 - VMWare module build fails on stock 7.1 kernel header files
Summary: VMWare module build fails on stock 7.1 kernel header files
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 38135 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-23 19:46 UTC by Matt Biermann
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-23 19:46:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to vmware to make it work on 2.4 kernels (746 bytes, patch)
2001-04-25 08:17 UTC, Arjan van de Ven
no flags Details | Diff

Description Matt Biermann 2001-04-23 19:46:11 UTC
VMware module build for vmnet module (network access module) fails on 
compile using stock RH 7.1 2.4.2-2 header files

Extracting the sources of the vmnet module.
 
Building the vmnet module.
 
make: Entering directory `/tmp/vmware-config1/vmnet-only'
bridge.c: In function `VNetBridgeReceiveFromDev':
bridge.c:788: warning: implicit declaration of function `skb_datarefp'
make: Leaving directory `/tmp/vmware-config1/vmnet-only'
Unable to make a vmnet module that can be loaded in the running kernel:
/tmp/vmware-config1/vmnet.o: unresolved symbol skb_datarefp
There is probably a light difference of kernel configuration between the 
set of
C header files you specified and your running kernel. You may want to 
rebuild a
kernel based on that directory, or specify another directory.

Comment 1 Arjan van de Ven 2001-04-23 19:48:46 UTC
This is a bug in the VMware driver. Please contact their support team to get
the updated driver.


Comment 2 Arjan van de Ven 2001-04-25 08:16:53 UTC
http://www.vmware.com/support/ws2/doc/whatsnew_ws_linux.htm

but as they seem to take AGES to get the 5 line patch I'll attach it to this
bug for you.

Comment 3 Arjan van de Ven 2001-04-25 08:17:34 UTC
Created attachment 16345 [details]
Patch to vmware to make it work on 2.4 kernels

Comment 4 Arjan van de Ven 2001-04-28 08:06:40 UTC
*** Bug 38135 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.