Bug 38135 - VM ware's vmnet module fails to build
VM ware's vmnet module fails to build
Status: CLOSED DUPLICATE of bug 37254
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 19:22 EDT by Red Hat Bugzilla
Modified: 2008-03-13 15:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-27 19:22:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2001-04-27 19:22:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)


Vmware tries to build the vmnet module and exits with this message:

"make: Entering directory `/tmp/vmware-config1/vmnet-only'
bridge.c: In function `VNetBridgeReceiveFromDev':
bridge.c:788: warning: implicit declaration of function `skb_datarefp'
make: Leaving directory `/tmp/vmware-config1/vmnet-only'
Unable to make a vmnet module that can be loaded in the running kernel:
/tmp/vmware-config1/vmnet.o: unresolved symbol skb_datarefp
There is probably a light difference of kernel configuration between the
set of C header files you specified and your running kernel. You may want
to rebuild a kernel based on that directory, or specify another directory."

According to vmware's website, this is usually a problem with the
distribution packaging different headers in /lib/modules/<kernel
version>/build/include than the actual kernel it's running.  I am running
the
stock 2.4.2-2 kernel.

Reproducible: Always
Steps to Reproduce:
1.  Install VMWare-2.0.3-799
2.  run vmware-config.pl
3.  answer yes to their questions to get them to build vmnet module
Comment 1 Red Hat Bugzilla 2001-04-28 04:06:44 EDT
This is a bug in vmware where it can't cope with recent 2.4 kernels. And even
if it weren't, you should take it up with their support people, not us.

(see bug 37254 for more info and the bugfix for their code)

*** This bug has been marked as a duplicate of 37254 ***

Note You need to log in before you can comment on or make changes to this bug.