Bug 373761 - EXA causes Nautilus to use random colors instead of set preference if monochromatic
EXA causes Nautilus to use random colors instead of set preference if monochr...
Status: CLOSED DUPLICATE of bug 340471
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
http://thecodergeek.com/images/nautil...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 16:03 EST by Peter Gordon
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 23:23:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log with EXA enabled (120.01 KB, text/plain)
2007-11-09 16:03 EST, Peter Gordon
no flags Details
Xorg.0.log with XAA (44.13 KB, text/plain)
2007-11-09 16:09 EST, Peter Gordon
no flags Details

  None (edit)
Description Peter Gordon 2007-11-09 16:03:40 EST
Description of problem:
After enabling EXA via the AccelMethod xorg.conf option, Nautilus uses random
colors for its backgrounds, even for the desktop background (if I set an empty
wallpaper and choose "Solid Color"). 

However, if I choose to use a gradient, and both the "start" and "end" colors
are the same, this does not occur. (It then properly uses that color.)

This leads me to believe, at first glance, that it's something to do with how
EXA accelerates the solid-fill stuff. 

I'm quite certain that it is nothing else which might cause this, as merely
toggling EXA (via the AccelMethod option in my xorg.conf) then restarting X (via
a reboot or init 3 then init 5) creates this error with nothing else
intentionally modified or changed.


Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.1.1-7.fc8


How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora 8, using the "intel" video driver.
2. Change the AccelMethod option in /etc/X11/xorg.conf to "exa" instead of the
default "xaa."
3. Restart X somehow.
  
Actual results:
The random colors seen in the screenshot.

Expected results:
It should be using the proper colors set in my preferences.

Additional info:

My hardware is the built-in G965 graphics on a DG965WH desktop motherboard,
using an E6600 processor (x86_64).

00:00.0 Host bridge: Intel Corporation 82P965/G965 Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82G965 Integrated Graphics
Controller (rev 02)
00:02.1 Display controller: Intel Corporation 82G965 Integrated Graphics
Controller (rev 02)


If you need me to attach other logs or data, please don't hesitate to ask. :)
Comment 1 Peter Gordon 2007-11-09 16:03:40 EST
Created attachment 253491 [details]
Xorg.0.log with EXA enabled
Comment 2 Peter Gordon 2007-11-09 16:09:38 EST
Created attachment 253511 [details]
Xorg.0.log with XAA
Comment 3 Jon Nettleton 2007-11-09 18:01:26 EST
I believe that this problem is the same as
https://bugzilla.redhat.com/show_bug.cgi?id=340471

The difference being that I was using the greedy Heuristic.  

If not it would then be related to.

https://bugzilla.redhat.com/show_bug.cgi?id=340511

I definitely ran acrossed the bug in my testing and now have it resolved on my
laptop.
Comment 4 Peter Gordon 2007-11-09 23:23:03 EST
Yup, that's the same. Thanks, Jon! :]

*** This bug has been marked as a duplicate of 340471 ***

Note You need to log in before you can comment on or make changes to this bug.