Bug 373771 - freenx of Fedora 8 does not work with nxclient
freenx of Fedora 8 does not work with nxclient
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: freenx (Show other bugs)
8
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 16:03 EST by Reindl Harald
Modified: 2008-01-13 03:22 EST (History)
5 users (show)

See Also:
Fixed In Version: 0.7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-13 03:22:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Nxclient conf file (4.77 KB, application/nx-session)
2007-11-10 13:45 EST, Kurt Nielsen
no flags Details
nx/temp/2942/runlog (14.59 KB, application/octet-stream)
2007-11-10 13:46 EST, Kurt Nielsen
no flags Details
.nx/temp/2942/sshlog (2.36 KB, application/octet-stream)
2007-11-10 13:47 EST, Kurt Nielsen
no flags Details
.nx/temp/2942/svclog (190 bytes, application/octet-stream)
2007-11-10 13:47 EST, Kurt Nielsen
no flags Details
Server log (3.54 KB, text/plain)
2007-11-10 13:50 EST, Kurt Nielsen
no flags Details
Ptached /usr/libexec/nx/nxnode (34.39 KB, application/octet-stream)
2007-11-16 16:01 EST, Reindl Harald
no flags Details
Remote Session with "tunneld" other one after close-click on "tunneled" window (167.37 KB, image/png)
2007-11-20 10:03 EST, Reindl Harald
no flags Details

  None (edit)
Description Reindl Harald 2007-11-09 16:03:43 EST
Hi - I have seen the problem since f8-rawhide in a vmware-server with ssh
forwarded on port 223 of the host. At this time i installed the packages from
rawhide on a F7-machine (the host), there was no problem - So i thougt it seems
to be the vmware or port-forwarding.
__

But now after upgrade to fedora 8 i can also not connect with the
nomachine-client to my home server. Connection and SSH-Key is OK, hard-disk says
me that kde begins to start

The last you see is "established display connection" following by the whole
window with the no-machine-logo, then the window closes without error-message
and i dont find any logfile with more information.

Client is also a fedora 8, connection to servers with fedora 7 and freenx from
the same machine does work as before the upgrade of servers to f8.

__

Following packages are installed on both machines, nx-2.1.0-22.fc7 seems not to
be rebuilt for F8

[root@srv-rhsoft ~]# rpm -qa | grep nx
nxclient-3.0.0-84
nx-2.1.0-22.fc7
freenx-0.7.0-2.fc8

If you can give me locations of additional-logfiles i can post them...
Comment 1 Kurt Nielsen 2007-11-10 13:45:27 EST
Created attachment 254041 [details]
Nxclient conf file
Comment 2 Kurt Nielsen 2007-11-10 13:46:44 EST
Created attachment 254051 [details]
nx/temp/2942/runlog
Comment 3 Kurt Nielsen 2007-11-10 13:47:19 EST
Created attachment 254061 [details]
.nx/temp/2942/sshlog
Comment 4 Kurt Nielsen 2007-11-10 13:47:43 EST
Created attachment 254071 [details]
.nx/temp/2942/svclog
Comment 5 Kurt Nielsen 2007-11-10 13:50:52 EST
Created attachment 254081 [details]
Server log
Comment 6 Felix Kaechele 2007-11-12 15:53:17 EST
I can't connect to my FreeNX server on my fresh F8 install either.
Here is what I discovered:

[root@uranus etc]# ldd /usr/libexec/nx/nxagent
        linux-gate.so.1 =>  (0x00110000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x00a14000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x008bc000)
        libz.so.1 => /lib/libz.so.1 (0x00791000)
        libm.so.6 => /lib/libm.so.6 (0x00744000)
        libXpm.so.4 => /usr/lib/libXpm.so.4 (0x0548a000)
        libXcomp.so.2 => not found
        libXcompext.so.2 => not found
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00b9d000)
        libc.so.6 => /lib/libc.so.6 (0x005e9000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x009ba000)
        libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0x0087d000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00881000)
        libdl.so.2 => /lib/libdl.so.2 (0x0076f000)
        /lib/ld-linux.so.2 (0x005ca000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x009bf000)

When adding /usr/lib/nx to a conf file in /etc/ld.so.conf.d/ ldconfig gives me
errors that some files are not symlinks but then kinda works. The next problem
for me is that it would only display the screen in 1024x768 no matter what I set
in the client.

I use:
freenx-0.7.0-2.fc8
nx-2.1.0-22.fc7
Comment 7 Kurt Nielsen 2007-11-13 05:41:41 EST
Wow its working :)
Ldconfig gives me errors to.
Display is ok.
Comment 8 Kurt Nielsen 2007-11-13 06:41:17 EST
Wow its working :)
Ldconfig gives me errors to.
Display is ok.
Comment 9 JM 2007-11-16 15:20:22 EST
I think it's this http://readlist.com/lists/kde.org/freenx-knx/0/2331.html
problem, to replace all occurrences of "DISPLAY=unix:$display" in nxnode with
"DISPLAY=:$display" solved the problem for me.
Comment 10 Reindl Harald 2007-11-16 16:01:07 EST
Created attachment 261791 [details]
Ptached /usr/libexec/nx/nxnode

Yes, Replace all occurrences of "DISPLAY=unix:$display" in
/usr/libexec/nx/nxnode with "DISPLAY=:$display" fix it

I think its time for the maintainer to build an update und put it into repo :-)
Comment 11 Jack Tanner 2007-11-17 10:22:23 EST
The DISPLAY=unix:$display fix is already present in freenx-0.7.1, but it seems
we can't upgrade until bug 364751 is fixed.
Comment 12 Need Real Name 2007-11-17 21:53:15 EST
bug 364571 appears to be a non-bug (see bug comments).  Can you give this
package a rebuild, taking into account the 'nxclient' -> 'nxdialog' change?
Comment 13 Need Real Name 2007-11-17 21:55:07 EST
er, that last comment should refer to bug 364751.
Comment 14 Gwyn Ciesla 2007-11-19 06:06:28 EST
New build in rawhide addresses this, please test.  I will as well.
Comment 15 Reindl Harald 2007-11-19 11:39:43 EST
I have installed http://koji.fedoraproject.org/koji/packageinfo?packageID=1768
on a F8-Machine - Server now seems to work without troubles

BUT:
If you close the client
(http://koji.fedoraproject.org/koji/packageinfo?packageID=1768) instead of the
question to terminate the session or let it running you get the client-software
loaded if it is installed (connection-manager from no-machine)....

Whats going wrong here?
Comment 16 Gwyn Ciesla 2007-11-19 11:55:42 EST
I'm not sure I understand.  If I open a session, click the close X, I get a
dialog  saying suspend/terminate.  What do you expect to see?
Comment 17 Reindl Harald 2007-11-19 12:05:19 EST
I expect what you get :-)
But instead auf suspend/terminate i get on the client "/usr/NX/bin/nxclient"
started, so i can only close the session by logoff in kde but no suspend.

This is only on the fedora 8 server with
http://koji.fedoraproject.org/koji/packageinfo?packageID=1768 and
nxclient-3.0.0-84 installed.

note that nxclient starts in the nx-session on the 
server by clicking the close X 

this can i reproduce every time and with every user with this two packages
Comment 18 Gwyn Ciesla 2007-11-19 12:23:57 EST
The only difference in our setups is my server is F7.  I'll try again after I
upgrade.
Comment 19 Gwyn Ciesla 2007-11-20 08:47:17 EST
Upgraded server to F8, I still see the suspend/terminate.
Comment 20 Reindl Harald 2007-11-20 08:55:17 EST
Have you on the server installed the client from no-machine or only nx-server?

On my machine both is installed because this is the home-server and will be used
as normal workstation if notebook is not running.
Comment 21 Gwyn Ciesla 2007-11-20 09:45:35 EST
On the server, it's just nx and freenx, no nxclient.  On the client, I have nx,
freenx, the stock F7 versions, and nxclient, -84.

Are both server and client F8?
Comment 22 Reindl Harald 2007-11-20 10:02:30 EST
Yes, both fedora 8 and both have freenx and nxlcient installed
The nxclient will be started in the REMOTE SESSION on the server by closing the
window

This happens since the F9-Package from koji-build-server is installed

The nxclient must send any signal that is not correct interpreted on the server
Instead of showing in the remote-session the terminate/suspend question it will
start the nxclient there or if no connections for the user configured the
nx-session-manager from no-machine.

The signal must be sent because the question will also be showed in the
remote-session, there seems to start the wrong application now

I can redproduce this here from notebook or also on the server self with
tunnelded connections

* remote-session as my user
* in the remote-session nxclient started and connected on the same machine with
other user
* close the client-window from the other user starts nx-session-manager in his
session
Comment 23 Reindl Harald 2007-11-20 10:03:42 EST
Created attachment 264971 [details]
Remote Session with "tunneld" other one after close-click on "tunneled" window
Comment 24 Reindl Harald 2007-11-25 09:14:40 EST
Are there any news?
I remove the fc9-packge and installed "freenx.i386 0:0.7.0-2.fc8"
There is the "old" problem with "DISPLAY=unix:$display" in /usr/libexec/nx/nxnode
After replacing it works, and yes the suspend/terminate-problem starting
nxclient instead the question is away - so this seems only to be in the fc9-package
Comment 25 Jack Tanner 2007-12-02 18:39:20 EST
freenx-0.7.1-2.fc9 works for me on F8. I had to do chmod 1777 /tmp/.X11-unix for
it to work, otherwise I was getting errors of the sort
_XSERVTransSocketCreateListener: failed to bind listener
Comment 26 René Ribaud 2007-12-14 07:35:41 EST
Hi,

I use the following X86_64 package :
nx-2.1.0-22.fc7
freenx-0.7.1-3.fc8

I faced the libraries issues like above :

[ctb@uggla nx]$ ldd /usr/libexec/nx/nxagent
        linux-vdso.so.1 =>  (0x00007fff1effe000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x0000003bc2e00000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x0000003893a00000)
        libz.so.1 => /lib64/libz.so.1 (0x0000003819c00000)
        libm.so.6 => /lib64/libm.so.6 (0x0000003819000000)
        libXpm.so.4 => /usr/lib64/libXpm.so.4 (0x0000003bc6800000)
        libXcomp.so.2 => not found
        libXcompext.so.2 => not found
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x0000003bc2a00000)
        libc.so.6 => /lib64/libc.so.6 (0x0000003818c00000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x000000381b400000)
        libxcb-xlib.so.0 => /usr/lib64/libxcb-xlib.so.0 (0x0000003893e00000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x0000003893600000)
        libdl.so.2 => /lib64/libdl.so.2 (0x0000003819400000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003817a00000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x000000381b800000)

So to fix I added /usr/lib64/nx to a conf file in /etc/ld.so.conf.d/ ldconfig. I
also got the errors that some files are not symlinks.

However then I faced issues with xorg and keyboard.
All keys were not working.

xorgs complained about keysym missing.

As soon as I removed my file in /etc/ld.so.conf.d/ xorg works fine again.

Looking at /usr/lib64/nx
[ctb@uggla nx]$ ll /usr/lib64/nx
total 4324
-rwxr-xr-x 1 root root  899408 jun  1  2007 libX11.so.6
-rwxr-xr-x 1 root root  896880 jun  1  2007 libX11.so.6.2
-rwxr-xr-x 1 root root   89296 jun  1  2007 libXcompext.so.2
-rwxr-xr-x 1 root root   86744 jun  1  2007 libXcompext.so.2.1.0
-rwxr-xr-x 1 root root 1099520 jun  1  2007 libXcomp.so.2
-rwxr-xr-x 1 root root 1097000 jun  1  2007 libXcomp.so.2.1.0
-rwxr-xr-x 1 root root   72520 jun  1  2007 libXext.so.6
-rwxr-xr-x 1 root root   69968 jun  1  2007 libXext.so.6.4
-rwxr-xr-x 1 root root   35312 jun  1  2007 libXrender.so.1
-rwxr-xr-x 1 root root   32720 jun  1  2007 libXrender.so.1.2

I found that some libraries like libX11.so.6.2 were duplicated and not the same.
[ctb@uggla nx]$ locate libX11.so.6.2
/usr/lib/libX11.so.6.2.0
/usr/lib64/libX11.so.6.2.0
/usr/lib64/nx/libX11.so.6.2

[ctb@uggla nx]$ diff /usr/lib64/libX11.so.6.2.0 /usr/lib64/nx/libX11.so.6.2
Les fichiers binaires /usr/lib64/libX11.so.6.2.0 et /usr/lib64/nx/libX11.so.6.2
sont différents.

I think the issue came from xorg not using the good set of libraries.

So for me it appears that nx-2.1.0-22.fc7 package needs to be reviewed for F8.
I think that the X11 libraries into this package should be the same as the X11
libraries provided by F8. (maybe i'm wrong).

I hope it will help.

Best regards
René
Comment 27 Axel Thimm 2007-12-28 19:57:53 EST
(In reply to comment #25)
> freenx-0.7.1-2.fc9 works for me on F8. I had to do chmod 1777 /tmp/.X11-unix for
> it to work, otherwise I was getting errors of the sort
> _XSERVTransSocketCreateListener: failed to bind listener

0.7.1 has moved to F8 updates. Has anyone upgraded to that package and tested
this? It looks like this is fixed or not?

> I faced the libraries issues like above :
> [ctb@uggla nx]$ ldd /usr/libexec/nx/nxagent

That's not a bug, just don't do that. There is a reason these binaries are in
%{_libexecdir} and not under some bindir. The binaries in the bindirs invoke
these with proper dynamic library configuration tuned in. This is required due
to nx's own modified X11 libs which unfortunately share the same sonames as the
X11 libs proper. But bottom line is that ldd on a libexecdir binary is not helpful.
Comment 28 Reindl Harald 2008-01-12 21:20:39 EST
I think this bug could be closed
NX works on f8 and rawhide this time with newer packages that are released

Comment 29 Axel Thimm 2008-01-13 03:22:21 EST
OK, thanks for feedback & report!

Note You need to log in before you can comment on or make changes to this bug.