This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 373961 - Broadcom wireless device does not show up in system-config-network on Dell Inspiron 1520
Broadcom wireless device does not show up in system-config-network on Dell In...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
http://forum.notebookreview.com/showt...
:
Depends On: 244029 328451
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 17:28 EST by Răzvan Sandu
Modified: 2008-05-04 12:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-04 12:27:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2007-11-09 17:28:56 EST
Description of problem:

Hello,

Description of problem:

The wireless device on the Dell Inspiron 1520 works (from the kernel point of
view) - please see bug #32845 and bug #336981.

Hardware is an integrated Dell WLAN 1390 Mini Card (Broadcom):

0c:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)
Subsystem: Dell Unknown device 0007
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping-
SERR+ FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- SERR-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 17
Region 0: Memory at f9ffc000 (32-bit, non-prefetchable) [size=16K]
Capabilities: [40] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=2 PME-
Capabilities: [58] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
Address: 00000000 Data: 0000
Capabilities: [d0] Express Legacy Endpoint IRQ 0
Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
Device: Latency L0s <4us, L1 unlimited
Device: AtnBtn- AtnInd- PwrInd-
Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s, Port 0
Link: Latency L0s <4us, L1 <64us
Link: ASPM L0s Enabled RCB 64 bytes CommClk+ ExtSynch-
Link: Speed 2.5Gb/s, Width x1
Capabilities: [100] Advanced Error Reporting
Capabilities: [13c] Virtual Channel


However, the wireless interface wlan0 doesn't show up in System ->
Administration -> Network, not even when the interface is up and actually
running. As a consequence, it cannot be controlled easily, set up for DHCP, etc.

It doesn't show up neither on the Hardware tab, nor on the Devices tab.

The correct firmware *is* installed, as shown in bug #336981, comment #4.


Version-Release number of selected component (if applicable):
system-config-network-1.4.3-1.fc8
NetworkManager-0.7.0-0.3.svn2970.fc8
wpa_supplicant-0.5.7-10.fc8


How reproducible:
Always.

Steps to Reproduce:
1. Install fresh F8 from official DVD.
2. Install firmware for wireless device (as in bug #336981, comment #4)
3. Reboot system.
4. Note that interface wlan0 is present in the output of "ifconfig -a", but
neither started at boot, nor taking IP address by DHCP.
5. Open System -> Administration -> Network
6. Note that wlan0 is not present neither on the Hardware tab, nor on the
Devices tab, so it cannot be configured and controlled. 
  
Actual results:
The wireless interface is not present in System -> Administration -> Network,
neither on the Hardware tab, nor on the Devices tab.

Expected results:
The wireless interface  should appear in System -> Administration -> Network, so
it can be set up, started at boot and controlled as any other interface.

Additional info:

Details about the hardware configuration of the Dell Inspiron 1520.
http://smolt.fedoraproject.org/show?UUID=28caf2c3-9766-4fe1-9e4c-d6b0ba8a0132
http://forum.notebookreview.com/showthread.php?t=152717
http://www.linlap.com/wiki/Dell+Inspiron+1520

Regards,
Răzvan
Comment 1 Răzvan Sandu 2007-11-09 17:43:32 EST
Here's the complete output of wlassistant, in a background terminal, when trying
to start the device wlan0 using it:

[root@mazarin ~]# wlassistant
kbuildsycoca running...
Reusing existing ksycoca
Loaded application options.
All interfaces: eth0, virbr0, wlan0, wmaster0
Wireless interface(s): wlan0
Permissions checked.
DHCP Client: dhclient
All executables found.
scan: /sbin/iwlist wlan0 scan
Networks found: 1
ACTION: CONNECT.
No DHCP client running.
No pre-connection command specified.
iwconfig_set: /sbin/iwconfig wlan0 mode managed channel 6 key off essid zando
iwconfig_ap: /sbin/iwconfig wlan0 ap 00:19:5B:0E:A6:27
==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or
directory
Using wpa_supplicant driver: wext
WPA client started. Waiting for status...
==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or
directory
CONNECTION FAILED.
disconnect: /sbin/iwconfig wlan0 mode managed key off ap off essid off
Application options saved.
Kernel socket closed.
Comment 2 Harald Hoyer 2007-11-12 02:58:56 EST
what is the output of:
# iwconfig
??
Comment 3 Ville Skyttä 2007-11-12 10:48:06 EST
Reproduced with "04:09.0 Network controller: Broadcom Corporation BCM4306
802.11b/g Wireless LAN Controller (rev 03)".  iwconfig looked ok (don't have the
output available any more, sorry).  What fixed it for me was manually adding
"alias wlan0 b43" to /etc/modprobe.conf.

Comment 4 Răzvan Sandu 2007-11-12 14:02:36 EST
Hello,

Here's the output of iwconfig, as Harald requested:

[root@mazarin ~]# iwconfig
lo        no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:""  
          Mode:Managed  Channel:0  Access Point: Not-Associated   
          Tx-Power=0 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

virbr0    no wireless extensions.


Thanks a lot,
Răzvan
Comment 5 Răzvan Sandu 2007-11-12 14:23:47 EST
I've followed advice in comment #3 and I've manually put "alias wlan0 b43" in
/etc/modprobe.conf, then rebooted.

Now wlan0 *does* show up in system-config-network's Hardware tab and one may
attempt configuring it on the Device tab.

I've tried to guess the proper settings; however, I get the error:

Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Invalid argument.


Regards,
Răzvan
Comment 6 Ville Skyttä 2007-11-12 15:09:33 EST
I got that too, apparently s-c-n creates some bogus (at least for these devices)
entries in the config file, maybe that's another bug.  I trimmed my
/etc/sysconfig/network-script/ifcfg-wlan0 to the following and it now works
without any error messages:

TYPE=Wireless
DEVICE=wlan0
HWADDR=...
BOOTPROTO=dhcp
DHCP_HOSTNAME=...
ONBOOT=yes
USERCTL=no
IPV6INIT=no
PEERDNS=yes
ESSID=...
Comment 7 Ville Skyttä 2007-11-12 15:10:37 EST
(In reply to comment #6)
> /etc/sysconfig/network-script/ifcfg-wlan0

I meant /etc/sysconfig/network-scripts/ifcfg-wlan0
Comment 8 Sergio Monteiro Basto 2007-11-12 15:45:59 EST
this is the same bug of #370971 ?
Comment 9 Răzvan Sandu 2007-11-12 17:55:47 EST
I was unable to connect just by following Ville's advice in comment #6.
I also added a CHANNEL=6 to it.

However, I *did* connect after logging in as root and manually starting
wlassistant. But until now I was unable to automatically regain connection after
restart.

BTW, where do we save/set the preshared key ? I am using WPA2 with preshared
key; access point is a DLink DWL-G700AP.

wpa_supplicant must be started at boot (checked in ntsysv) while we experiment
all these ?

I'll try rebooting again...


Regards,
Răzvan
Comment 10 Sergio Monteiro Basto 2007-11-13 00:03:34 EST
the thing at least with me , when I turn wifi on: 
 
Nov 13 04:19:30 localhost kernel: ipw2200: Failed to send SCAN_ABORT: Command
timed out.
Nov 13 04:19:31 localhost kernel: ipw2200: Failed to send CARD_DISABLE: Command
timed out.

and things like that I realize that is because: 
cat /etc/sysconfig/wpa_supplicant
# wlan0 and wifi0
# INTERFACES="-iwlan0 -iwifi0"
INTERFACES="-ieth1"
# ndiswrapper and prism
# DRIVERS="-Dndiswrapper -Dprism"
DRIVERS="-Dwext"

so here , after comment driver section (with #) and keep my interface I got
wireless working again.

see man wpa_supplicant to find your appropriate driver 



Comment 11 Răzvan Sandu 2007-11-13 01:29:41 EST
Hello,

There are some *very strange things* here...

1. The wlan0 interface doesn't go up at boot, independently of the fact that
wpa_supplicant is started automatically (marked in ntsysv) or not.

2. However, manually starting wlassistant as root and inserting the correct
parameters *does* bring up the interface (and then works normally, good
performance).

One must check the "ASCII" box near the WPA key field in wlassistant to get the
password working (I use an alphanumeric password).

3. The WiFi LED on the laptop stays out even when the interface wlan0 do work.

4. wpa_supplicant does not start at boot, even when it's checked in ntsysv.
However, if I (re)start it manually, it shows an error message about a missing
file, but it starts (writes OK in green).

IMHO, at boot, the radio connection (ESSID, key, etc.) must be set up *before*
system-config-network tries to wake up all the interfaces - please correct me if
I'm wrong... Where do we set up the wireless parameters for the whole system (at
boot), if we don't want to use wlassistant ?

Regards,
Răzvan

Comment 12 Harald Hoyer 2007-11-13 03:11:41 EST
> system-config-network tries to wake up all the interfaces

huh? when does it do that?
Comment 13 Răzvan Sandu 2007-11-13 05:25:45 EST
Sorry, I meant starting interfaces at boot (eth0, wlan0, etc.)

Răzvan
Comment 14 Răzvan Sandu 2007-11-15 02:01:02 EST
To summarize:


About the bug we are discussing here (#373961), I will consider it fixed if the
next update of system-config-network:

- automatically creates an entry for the wireless adapter on the Hardware tab
(see comment #3 above), provided that someone previously installed the correct
firmware, as presented in bug #336981, comment #4;

- allows for flawless configuration of it on the Devices tab, as for any other
network interface.


The rest of issues (authentication in the wireless network) seems to be
wpa_supplicant-related (please see bug #375721).

(Esentially, wpa_supplicant *fails at boot*, but succesfully allows for *manual*
restarting service later, after the system has been started. However, it throws
error messages in both cases).


Regards,
Răzvan
Comment 15 Răzvan Sandu 2007-11-15 02:04:07 EST
Sorry, I've meant "...as presented in bug #328451, comment #4" in the sentence
above.

Răzvan 
Comment 16 Harald Hoyer 2007-11-16 04:55:08 EST
s-c-network part fixed in git. will be in the next update. stay tuned.
Comment 17 Răzvan Sandu 2008-02-27 14:51:11 EST
Hello,

Here's some indirect feedback I have about the Dell Inspiron 1520 wireless from
another user - Franco, in Italy. I quote it for reference, even if I don't know
it's the exact same issue:

"hi, i'm in italy and i found your post very interesting, i do have an ispiron
1520 i installed fedora 8 and so far no majors problem only problem i do have is
the wireless, i have a broadcom corporation bcm4312 pt 802.11 a/b/g i did
install and has been reconized but as soon i do activation saysError for
wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Invalid argument.
SIOCSIFFLAGS: No such file or directory
can you help me? please?
ciao franco"

This refers to my post on:
http://forum.notebookreview.com/showthread.php?t=152717
Comment 18 Răzvan Sandu 2008-05-04 12:27:38 EDT
Seems to be solved - now wlan0 shows up in system-config-network.

system-config-network-1.5.7-1.fc9.noarch


Closing - many thanks.

Răzvan


Note You need to log in before you can comment on or make changes to this bug.