Bug 37442 - Installer hangs at Post install configuration...
Installer hangs at Post install configuration...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 43897 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-24 11:59 EDT by maynard_lag
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-25 13:22:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description maynard_lag 2001-04-24 11:59:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


After the installer completes installation of all packages, the machine 
locks and becomes unresponsive. This happens, everytime in text mode and 
graphical mode, workstation, server or custom install.

Reproducible: Always
Steps to Reproduce:
1. Install any variation of Redhat 7.1 in any mode (text, expert, 
graphical).
2.
3.
	

Actual Results:  Unable to install Red Hat 7.1

Expected Results:  I had expected Red Hat 7.1 to complete installation.

First attempt was with the graphical install, after all packages were 
installed and progress indicator/elapsed time matched the estimated time 
to complete, the computer became unresponsive.  See below for additional 
information.

For the graphical install, randomly clicking the mouse in frustration 
crashed the X server for graphical installer window and showed the 
following output:

...X server started successfully
Xlib: unexpected async reply (sequence 0x130a51)!

Gdk-WARNING**: GdkWindow 0x401564 unexpectedly destroyed

Gdk-WARNING**: GdkWindow 0x401563 unexpectedly destroyed

Gdk-ERROR**: Bad ID Choice
   serial 1247840 error_code 14 request_code 53 minor_code 0
install exited abnormally
sending term signals...done
sending kill signals...done
disabling swap...
   /tmp/swap/hda5
unmounting filesystems...
   /mnt/sysimage/boot
   /mnt/sysimage/proc
   /mnt/sysimage/umount failed ()
   /mnt/runtime
   /mnt/source
   /dev/pts
   /proc
you may safely reboot your system

During a text mode install, all packages are installed and the installer 
proceeds to the "Performing Post install configuration" screen, but the 
progress indicator stops at about 5-10% (same spot everytime).  Just to be 
certain I left the install running like this overnight, even though 
package copying etc. only took about 8 minutes or so.  Here's my computer 
specs:

Processor: Pentium Pro 233 Mz
RAM:       128MB (60ns)
Mboard:    ???? some generic P-PRO board umm.. 440FX chipset
CD-ROM:    NEC Multispin 6V
HDD:       Western Digital 2 GB (MDL #: WDAC22100-00H; P/N: 99-004219-00)
NIC #1:    3COM 3C595
NIC #2:    3COM 3C900

Some notes: 
1) You may notice the processor speed, yep it's overclocked, but it ran 
like that for nearly 2 years straight before I got a new box, and all 
previous versions of Redhat that I've tried (5.x, 6.x, 7.0) have installed 
fine.  Also, I've recompiled kernels without problems, so it's very stable 
at 233 Mz even though I bought it as a 180 way back when.

2) This is the first attempt at running a 2.4 kernel on this machine.

3) All 7.1 installation attempts have configured the firewall options with 
high security and custom ports for SSH and FTP. I have either assigned 
IP's, set both cards to DHCP, just set to activate on boot, or not set to 
activate on boot. Results are the same, although, I've not reproduced the 
X Server crash on a server install.
Comment 1 Brent Fox 2001-04-24 14:13:09 EDT
I have seen this behavior before in GUI mode, but never in text.  Also, the GUI
behavior was usually unreproducible.  The install would hang on me in the
post-install with the progress bar somewhere between 80-100%.  I would reboot
and do the exact same thing and the problem would not occur again.
Comment 2 Michael Fulbright 2001-04-24 14:45:00 EDT
Please look on VC3 and VC4 to see if there are additional messages.

The gtk+ related messages are just noise the gtk+ library is making.

It appears part of the post-install process is crashing.
Comment 3 maynard_lag 2001-04-24 15:49:26 EDT
I suppose I should be a little more clear on a couple of things. 

1)The X-Windows crash out in the graphical install only occurs during the 
Workstation install, I believe.  I've only had that happen, twice, and I 
believe it was during an X-Windows attempted install.  Graphical mode always 
locks after package copying/installation and I never receive a "Performing Post 
Installation Configuration" screen in graphical mode.  Actually, I guess I 
should say I never saw it, perhaps it was there, I've been switching between 
inputs on the monitor and may have missed it previously.  On my most recent 
install attempt, I did see it for a quick moment and it showed the same 
progress as indicated in text mode before it dissappeared.  Also, I have 
discovered the virtual terminals and here's what seems to be relevant towards 
the bottom of each virtual terminal:

<ctl>+<alt>+<F1>
...X server started successfully
Xlib: unexpected async reply (sequence 0xa3007)!

Gdk-WARNING**: GdkWindow 0x40080f unexpectedly destroyed
Gdk-WARNING**: GdkWindow 0x40080e unexpectedly destroyed

<ctl>+<alt>+<F2> I found the X.log file and typed "tail X.log" in /tmp
sh-2.04#tail X.log
(--) FBDev: MMIO regs: 0K @ (nil)
(--) FBDev: Type 0 type_aux 0 bits_per_pixel 16
(--) FBDev: Hardware accelerator: None
(--) FBDev: No driver support for hardware acceleration
bpp = 16, depth = 16, BitPerRGB = 6
(--) FBDev: Using cfb16 driver
error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
SetMouseSettings - type: 6 brate: 1200 srate: 0 chdmid: 0
                   em3but: 0 em3tim: 50 res: 0 flags: 0
SetMouseSettings - succeeded
sh-2.04#

<ctl>+<alt>+<F3>
*no IDE floppy devices found
*Detected 128M of memory
*Swap attempt of 128M of 256M
*Maximum cylinder is 25
*self.network.hostname = localhost.localdomain
*Error running ['/usr/sbin/authconfig', '--kickstart', '--nostart', '--
enableshadow', '--enablemd5', '--disablenis', '--disableldap', '--
disableldapauth', '--disableldaptls', '--disablekrb5', '--
disablehesiod']: /usr/sbin/authconfig can not be run

<ctl>+<alt>+<F4>
<4>hdc: ATAPI 6X CD-ROM drive, 128 kB cache, DMA
<6>Uniform CD-ROM driver Revision: 3.12
<6>SCSI subsystem driver Revision: 1.00
<7>ISO 9660 Extensions: RRIP_1991A
<4>Unable to identify CD-ROM format.
<6>raid0 personality registered as nr2
<6>raid1 personality registered as nr2
<6>raid5 measuring checksumming speed
<4>   8regs    :    367.200 MB/sec
<4>   32regs   :    212.000 MB/sec
<4>raid5:  using function: 8regs (367.200 MB/sec)
<6>raid5:  personality registered as nr 4
<6>Adding swap: 66488k swap-space (priority -1)
<7>ISO 9660 Extensions: RRIP_1991A


The above data was from a graphical server install without any NIC's.
Comment 4 maynard_lag 2001-04-25 11:26:17 EDT
When poking around in VC2, I found that /usr/sbin/authconfig does not exist, 
which may explain why it cannot be run.  I almost want to volunteer that 
perhaps the CD's that I burned from ISO's are bad, but If that were the case I 
would expect a failure during package copying/installation. I appended comments 
to bug #: 37592, as there seem to be similarities in system type and unexpected 
installer exits.
Comment 5 maynard_lag 2001-04-25 13:22:00 EDT
It would appear I have bad ISO's, I've just installed CygWin on my win2k box 
and performed an md5sum --check and disc-1 failed.  Disc-2 checked out ok.  I 
will redownload disc-1 and re-attempt an install. If I can, I'll change the 
status to NOTABUG, and reopen it if I have problems. I'm going to go beatup my 
ftp software now.  What's odd to me is that my disc-1.iso is the same size as 
what's on the servers, but I guess it's not quite right.  Sorry to have wasted 
your time.
Comment 6 Brent Fox 2001-04-25 14:37:50 EDT
It's ok.  This happens a lot.  I wish downloads were more reliable.  It's
amazing that the 'net works at all.
Comment 7 Brent Fox 2001-06-11 12:51:24 EDT
*** Bug 43897 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.