Bug 37473 - missing status & stop reports failure always in initscripts
missing status & stop reports failure always in initscripts
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: radiusd-cistron (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Tim Powers
:
: 40326 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-24 15:56 EDT by Zing
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-27 09:28:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
init script modifications - status & stop (925 bytes, patch)
2001-04-24 15:57 EDT, Zing
no flags Details | Diff
status -> rhstatus (368 bytes, patch)
2001-04-25 12:13 EDT, Zing
no flags Details | Diff
closing brace missing (280 bytes, patch)
2001-04-25 12:14 EDT, Zing
no flags Details | Diff

  None (edit)
Description Zing 2001-04-24 15:56:31 EDT
I'm attaching a minor patch that adds status support and, at least on my 
machine, correctly kills the running radiusd by just sending a kill to 
only radwatch; otherwise stopping radiusd would always report [FAILED].

thanks.
zing
Comment 1 Zing 2001-04-24 15:57:45 EDT
Created attachment 16287 [details]
init script modifications - status & stop
Comment 2 Tim Powers 2001-04-24 23:38:24 EDT
I merged your patch in with mine. I have pushed the updated package into

http://people.redhat.com/timp/RPMS/radiusd-cistron-1.6.4-4.i386.rpm

and

http://people.redhat.com/timp/SRPMS/radvd-0.6.2-7.src.rpm

Please take a look at these and let me know if they are OK, also let me know if
there are further issues.

Tim
Comment 3 Zing 2001-04-25 12:12:35 EDT
I think radvd was some other bug? :)

1. The status part of the patch didn't seem to fully apply.  It'll seg fault.  
New patch included.

2. New bug, the closing "fi" in the preun script is missing.  that'll cause 
upgrade failure.  patch included for spec file...

thanks
zing



Comment 4 Zing 2001-04-25 12:13:21 EDT
Created attachment 16405 [details]
status -> rhstatus
Comment 5 Zing 2001-04-25 12:14:03 EDT
Created attachment 16406 [details]
closing brace missing
Comment 6 Tim Powers 2001-04-25 12:37:59 EDT
Take a look at the poackage again, I uploaded the wrong build of it lakst night,
download it again.

Oh, and the status vs rhstatus thing can stay the same, I had to merge the patch
by hand, and since this is how status is used in mopst of mour other initscripts
that's how I put it in.

Download it again and tell me what you think.

Tim
Comment 7 Zing 2001-04-25 14:40:40 EDT
Nope, same problems... 

1.  we now have two functions called status()!  One's pulled in from the top of 
the init script ("./etc/init.d/functions") and the one you edited in... if you 
want to, just get rid of the status() function manually edited in and 
call "status radiusd"  from the case status switch at the bottom.

2. the missing "fi" is still missing from the spec file.

3. stopping and starting functions work :)

thanks
zing
Comment 8 Tim Powers 2001-04-25 15:48:51 EDT
OK. radiusd-cistron-1.6.4-5 has been uploaded to people.redhat.com/timp/RPMS.
That should do it.

Please note that since there is a typo in the %preun script in the package as
shipped in Powertools 7.1 you will have to do this to install the fixed package,
unfortuantely there is no other way around the problem:

 # /sbin/service radiusd stop
 # /sbin/chkconfig --del radiusd
 # rpm -e --noscripts radiusd-cistron
 # rpm -ivh radiusd-cistron-1.6.4-5.i386.rpm

Tim
Comment 9 Zing 2001-04-25 16:07:49 EDT
That did it!

thnks
zing
Comment 10 Tim Powers 2001-04-27 09:28:00 EDT
Resolving this as rawhide since that's where the package is now located.
Comment 11 Tim Powers 2001-05-12 11:41:57 EDT
*** Bug 40326 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.