This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 37474 - ksconfig parsing problem with /etc/sysconfig/clock
ksconfig parsing problem with /etc/sysconfig/clock
Status: CLOSED DUPLICATE of bug 37753
Product: Red Hat Linux
Classification: Retired
Component: ksconfig (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-24 16:07 EDT by Panic
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 16:07:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panic 2001-04-24 16:07:30 EDT
This was on an upgraded 7.0 machine.  The /etc/sysconfig/clock file on that
machine looked like this:

ZONE="EST"
UTC=false
ARC=false

We're not sure where this came from (some config tool in 7.0?), but
ksconfig died on this file like this:

Traceback (innermost last):
  File "/usr/share/ksconfig/ksconfig.py", line 387, in ?
    timeCombo.list.select_item(select)
NameError: select

Apparently because EST is not a valid time zone (??).  We don't know where
this ZONE entry came from, but something is not kosher.  On a clean 7.1
install, it works (ZONE="America/New_York") and after fixing the file on
the older machine, that works as well.  Thanks.
Comment 1 Brent Fox 2001-04-27 15:48:25 EDT

*** This bug has been marked as a duplicate of 37753 ***

Note You need to log in before you can comment on or make changes to this bug.