This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 37475 - Crash in GTK+ application when entering a non ascii char in some boxe
Crash in GTK+ application when entering a non ascii char in some boxe
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gtk+ (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
Depends On:
Blocks: 39229
  Show dependency treegraph
 
Reported: 2001-04-24 16:13 EDT by Gissehel, Arthibus
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 09:52:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gissehel, Arthibus 2001-04-24 16:13:45 EDT
GTK+ applications crash when you're inserting into fields some char like
"i" or "`" or "h". For non english speaking, it's very annoying bug.

  This seems to be related to
http://bugzilla.gnome.org/show_bug.cgi?id=51644 and the bug seems to
disapear by using gtk+ 1.2.10 

  If this is a real bug (not only on my system), Readhat7.1 should upgrade
to gtk+ 1.2.10
Comment 1 Gissehel, Arthibus 2001-04-24 16:19:47 EDT
Okay, my message was corrupted, so, the sentence was not 

... some char like "i" or "`" or "h". ...

but 

... some char like "eacute" or "agrave" or "egrave". ...

(like the ones in html ...)
(and probably any > 0x80 chars)
Comment 2 Carlos Rodrigues 2001-04-29 10:05:44 EDT
This only seems to happen if the LC_CTYPE environment variable is either not 
set or set to "C" or "POSIX", for instance I have it now set to "pt_PT" and 
the problem does not occur.
Comment 3 Owen Taylor 2001-07-10 17:40:46 EDT
Generally, you can't expect to use non-ASCII characters in C or POSIX
locales and expect that to work. How would the app know if they
were iso-8859-1, koi8-r, euc-jp, etc characters? If you want
English messages, you can use the en_US locale (what you get if
you install Red Hat in English), or simply set your LC_CTYPE
envariable to the language you want, while leaving LANG/LC_ALL
untouched.

However, of course, it shouldn't crash. The crash was fixed in 1.2.10, 
which has been in rawhide for a while.

Note You need to log in before you can comment on or make changes to this bug.