Bug 37513 - dvips core dumped
Summary: dvips core dumped
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-25 06:12 UTC by yamagata
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 10:23:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
LaTeX file including japanese text (74 bytes, patch)
2001-05-09 00:31 UTC, yamagata
no flags Details | Diff

Description yamagata 2001-04-25 06:12:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [ja/[Vine,RedHat]] (X11; U; Linux 2.4.2-2 i686)


When dvips converts a TeX DVI file including Japanese,
core dumped.

Reproducible: Always
Steps to Reproduce:
1.The file, foo.tex includes Japanese text.
2.platex foo.tex
3.dvips -o foo.ps foo.dvi
	

Actual Results:  dvips: Font rml not found,  using cmr10 instead.
Segmentation fault(core dumped)

rml must be defined in the file, /usr/share/texmf/dvips/config/psfonts.map.

Comment 1 Tim Waugh 2001-05-02 09:48:55 UTC
Please attach the file you are using so that I can test out a fix.  Thanks.



Comment 2 yamagata 2001-05-07 05:45:29 UTC
Please see the patch file, teTeX-1.0-japanese-psfonts.patch,
in tetex-1.0.7-15.src.rpm.

Comment 3 Tim Waugh 2001-05-07 17:33:05 UTC
What about it?  It is already applied.  Please attach a tex file that I can 
use to reproduce the problem locally.


Comment 4 yamagata 2001-05-08 01:46:03 UTC
The file, psfonts.map, does not include lines of japanese.map.

If we add the lines to psfonts.map, dvips works.

\documentstyle{jarticle}
\begin{document}
Japanese

F|K\8l
\end{document}


Comment 5 yamagata 2001-05-08 09:32:11 UTC
If we run the command, /usr/share/texmf/dvips/config/updmap,
the file, psfonts.map, is updated and the lines of the file, japanese.man, are
included.

Comment 6 Tim Waugh 2001-05-08 12:02:29 UTC
Please use the 'create a new attachment' link to attach the file you are 
using, since I can't reproduce the problem with that above fragment.  I'd like 
to test a fixed package.  Thanks.


Comment 7 yamagata 2001-05-09 00:31:55 UTC
Created attachment 17806 [details]
LaTeX file including japanese text

Comment 8 Tim Waugh 2001-05-18 13:30:23 UTC
This should be fixed in 1.0.7-17.  Thanks!


Comment 9 Tim Waugh 2001-05-25 12:55:15 UTC
Please confirm whether 1.0.7-17 makes things better or worse.


Comment 10 Tim Waugh 2001-05-25 20:30:18 UTC
1.0.7-19 has reverted the change that caused updmap to be run during the build 
stage.  I'm going to close this bug as WORKSFORME since I can't reproduce the 
original problem you were having.

If you have more information you can tell me, please reopen this bug report.

Thanks.


Comment 11 Rex Dieter 2001-06-20 17:33:32 UTC
I still consider this a bug, and the "fix" in 1.0.7-19 only masks the real 
problem.  

In my case, I would like to use type1 fonts in preference of metafont, so I 
edit the appropriate section of /usr/share/texmf/dvips/config/updmap to say:
###########################################################################
# Set to true to use postscript type1 versions for fonts with existing
# metafont versions.
###########################################################################
 
# type1_default=false
type1_default=true

and rerun updmap.  I now have a non-functioning dvips.  tetex-1.0.7-14 (as 
distributed with rh7.1) did not have this problem.  Undoing the following 
patch (which supposedly fixes bug 32134, though bugzilla won't let me see it) 
in the SRPM fixes this: 
teTeX-1.0-japanese-psfonts-fix.patch

IMO, The long-term fix should involve being able to fix japanese fonts in a 
way that doesn't break other things (like dvips).





Comment 12 Tim Waugh 2001-06-20 17:39:44 UTC
The trouble is that if you undo that patch, pdftex complains because those 
psfonts.map don't have enough words on the line any more. :-(

Yes, the correct solution would involve a psfonts.map that you could run 
updmap on and still have everything work.  I don't know what the correct 
solution is though at this point.

I _am_ deeply suspicious of the teTeX-1.0-japanese-psfonts-fix.patch patch, 
but I don't know what it should look like instead.


Comment 13 Rex Dieter 2001-06-20 22:57:49 UTC
I rebuild tetex without the jap-psfonts-fix.patch and all my problems are gone: 
dvips works, updmap works, pdflatex works, pdftex works ok except for a few 
warnings:  
Warning: pdftex (file pdftex.map): invalid line in map file: `gbm GothicBBB-Med
ium-H^^J'
Warning: pdftex (file pdftex.map): invalid line in map file: `gbmv GothicBBB-Me
dium-V^^J'
Warning: pdftex (file pdftex.map): invalid line in map file: `rml Ryumin-Light-
H^^J'
Warning: pdftex (file pdftex.map): invalid line in map file: `rmlv Ryumin-Light
-V^^J'
(Is this what you were talking about?)

Otherwise, I'm still of the opinion that the jap-psfonts-fix.patch in question 
is broke and should not be included.  Of course, until a better patch comes 
along, it's your call to decide which bug is more important to fix: this one or 
bug #32134.

Comment 14 Tim Waugh 2001-08-07 17:24:40 UTC
This should be fixed by 1.0.7-27.  We have two dvips binaries now: dvips 
(normal) and pdvips (ptex-enabled).



Note You need to log in before you can comment on or make changes to this bug.