Bug 37514 - pdftex compiled against wrong libpng version
pdftex compiled against wrong libpng version
Status: CLOSED DUPLICATE of bug 19107
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-25 02:40 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-25 02:40:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-25 02:40:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.18 i686)


The texi2pdf command which runs pdftext is built against the wrong version
of the libpng library. The error states 1.0.6 while the RPM is 1.0.8 and
libpng detects this a dies.
This is a standard 7.0 release with the one texinfo.tex upgrade which is a
rather nice upgrade (hint hint).

Reproducible: Always
Steps to Reproduce:
1. Get the lastest texinfo.tex from
    ftp://ftp.gnu.org/gnu/texinfo/texinfo.tex
   and replace in
    /usr/share/texmf/pdftex/texinfo/pdftexinfo.tex
2. Create a simple PNG image called test.png using gimp.
3. Create the texinfo as stated in the additional info section below.
4. Run `texi2pdf test.texinfo
	

Actual Results:  $ texi2pdf test.texinfo
This is pdfTeX, Version 3.14159-13d (Web2C 7.3.1)
(/home/auser/test.texinfo[/usr/share/texmf/pdftex/config/pdftex.cfg]
Babel <v3.6Z> and hyphenation patterns for american, french, german,
ngerman, i
talian, nohyphenation, loaded.
(/usr/share/texmf/pdftex/texinfo/texinfo.tex
(/usr/share/texmf/pdftex/texinfo/pdftexinfo.tex
Loading texinfo [version 2000-12-11.07]: Basics, pdf,
(/usr/share/texmf/pdftex/plain/misc/pdfcolor.tex) fonts, page headings,
tables, conditionals, indexing, sectioning, toc, environments, defuns,
macros,
cross references, (/usr/share/texmf/tex/plain/dvips/epsf.tex) localization,
and turning on texinfo input format.))libpng error: Application must be
recompiled; version 1.0.6 was incompatible

Error: pdftex (file ct-logo.png): png_create_read_struct() failed
/usr/bin/texi2dvi: pdftex exited with bad status, quitting.
/usr/bin/texi2dvi: see test.log for errors.

Expected Results:  A nice PDF with the image. RH 6.1 works well.

$ cat test.texinfo
\input texinfo   @c -*-texinfo-*-
@pdfimage{test.png}
Comment 1 Tim Waugh 2001-05-02 05:43:07 EDT

*** This bug has been marked as a duplicate of 19107 ***

Note You need to log in before you can comment on or make changes to this bug.