Bug 375591 - Will not boot with partition type 165 (BSD) on any installed drive
Will not boot with partition type 165 (BSD) on any installed drive
Status: CLOSED DUPLICATE of bug 374521
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 385361 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 02:16 EST by Paul Lipps
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 11:39:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Current dmesg output (19.95 KB, text/plain)
2007-11-11 02:16 EST, Paul Lipps
no flags Details
screenshot, system hang after install (473.46 KB, image/jpeg)
2007-11-13 00:44 EST, Jeronimo Martinez Sanchez
no flags Details

  None (edit)
Description Paul Lipps 2007-11-11 02:16:17 EST
Description of problem:

Fedora 8 will not boot with a partition type of 165 on the drive. Any partition
on the drive created by FreeBSD or PC-BSD will cause Fedora 8 to hang at boot.

Version-Release number of selected component (if applicable):

Kernel 2.6.23.1-49.fc8

How reproducible:

It happens every time.

Steps to Reproduce:
1. Format a drive with the standard F8 layout on the first half of the drive.
2. Install FreeBSD or PC-BSD on the second half of the drive, or third partition
in this case.
3. Attempt to boot F8
  
Actual results:

Fedora will hang at boot with the following message if you remove rhgb and quiet
from the boot options:

Trying to resume from /dev/VolGroup00/LogVol01

It also seems that CPU usage is maximum at that point judging from the noise my
thermal fan makes when it is hung.

Expected results:

Boot into F8 normally without issue.

Additional info:

I have a Shuttle motherboard that is ICH5 based. I have two 160GB SATA hard
disks. Disk 1 is where GRUB and Windows XP resides. Disk 2 is where I have
Fedora on the fist half of the disk and usually either FreeBSD or PC-BSD on the
second half of the disk.

I originally had FC6 and PC-BSD on the second disk working fine. I installed F8
and used the installed to remove the FC6 partitions and install F8 in it's
place. Then it wouldn't boot. I tried formatting the PC-BSD partition to NTFS,
F8 started booting.

I then thought maybe there was something wrong with the partition map, so I
wiped the drive by creating a new disklabel (msdos) with a GParted Live CD. I
made a two equal size partitions, the first one ext2 and the second ntfs. I
installed F8 again telling it to remove existing linux partitions. Ending up
with three partitions, one for /boot one LVM and one NTFS. After installation it
booted. I then installed PC-BSD where the NTFS partition resides, F8 would no
longer boot. I then reformatted the 3rd partition to NTFS using the GParted Live
CD again, and F8 will boot.

With FC6, I could wipe and reinstall in that third partition any *BSD I wanted
and it would not cause any trouble with booting Fedora.

I have also tried changing the mode of my SATA controller in the BIOS. I tried
'Auto' and 'Enhanced', both settings had the same result.

I am attaching my dmesg, please let me know if there is any other information I
can provide.
Comment 1 Paul Lipps 2007-11-11 02:16:17 EST
Created attachment 254271 [details]
Current dmesg output
Comment 2 Tyler Wake 2007-11-12 13:44:24 EST
I don't think it matters where the BSD partition is, if that is indeed the
problem. I have PC-BSD installed on my first partition, Ubuntu on my second,
Fedora 8 on my third, and swap on the fourth. Boot hangs on "Trying to resume
from LABEL=SWAP-sda4".
Comment 3 VnPenguin 2007-11-12 13:51:18 EST
I have same problem here. I have two swap partitions: /dev/sda5 & /dev/sdb2:

-------------------------------------------------------
# fdisk -l /dev/sda

Disk /dev/sda: 81.9 GB, 81964302336 bytes
16 heads, 63 sectors/track, 158816 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       40641    20482843+   7  HPFS/NTFS
/dev/sda2           40641       91450    25607610    7  HPFS/NTFS
/dev/sda3           91450       91753      152617+  83  Linux
/dev/sda4           91753      158802    33792727+   f  W95 Ext'd (LBA)
/dev/sda5           91753       92805      530113+  82  Linux swap / Solaris
/dev/sda6           92805      100933     4096543+  83  Linux
/dev/sda7          100933      109045     4088511   83  Linux
/dev/sda8          109045      117157     4088511   83  Linux
/dev/sda9          117157      125269     4088511   83  Linux
/dev/sda10         125269      158802    16900348+  83  Linux

------------------------------------------------------------------
# fdisk -l /dev/sdb
Disk /dev/sdb: 15.3 GB, 15367790592 bytes
16 heads, 63 sectors/track, 29777 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1        9922     5000687+  83  Linux
/dev/sdb2            9923       10915      500472   82  Linux swap / Solaris
/dev/sdb3   *       10916       22542     5860008   a5  FreeBSD
/dev/sdb4           22543       29777     3646440    5  Extended
/dev/sdb5           22543       29777     3646439+  83  Linux

There is alway the same error, whatever swap partition.
Comment 4 Chuck Ebbert 2007-11-12 14:51:49 EST
Does adding "noresume" to the kernel boot options allow the system to boot?
Comment 5 VnPenguin 2007-11-12 15:32:20 EST
Already added "noresume" but there is the same error.

On my 2nd disc (see abow), I have a swap partition /dev/sdb2 which has no label
(reported by blkid). When I try to give a label I see error:

# tune2fs -L SWAP-sdb2 /dev/sdb2
tune2fs 1.40.2 (12-Jul-2007)
tune2fs: Bad magic number in super-block while trying to open /dev/sdb2
Couldn't find valid filesystem superblock.

Ok, I can not make label for this partition. My Fedora 8 installation does not
any partition on my 2nd disc. So I try to disconnect it, and boot FC8 : Ola, it
works now !!!

IMHO, my 2nd disc maybe has problem, but FC7 works fine with it, I can even use
this swap partition (/dev/sdb2) under FC7. But why FC8 needs something on 2nd
disc ? I can not understand.




Comment 6 Chuck Ebbert 2007-11-12 15:51:13 EST
(In reply to comment #5)
> Already added "noresume" but there is the same error.

> When I try to give a label I see error:
> 
> # tune2fs -L SWAP-sdb2 /dev/sdb2
> tune2fs 1.40.2 (12-Jul-2007)
> tune2fs: Bad magic number in super-block while trying to open /dev/sdb2
> Couldn't find valid filesystem superblock.
> 

# swapoff /dev/sdb2
# mkswap -L SWAP-sdb2 /dev/sdb2
Comment 7 Jeronimo Martinez Sanchez 2007-11-13 00:44:12 EST
Created attachment 256371 [details]
screenshot, system hang after install

this happen with "noresume" option enable on kernel boot parameter, without the
noresume option system hang with the message: "Trying to resume from
/dev/VolGroup00/LogVol01"
Comment 8 Jeronimo Martinez Sanchez 2007-11-13 00:46:17 EST
I got the same error, but after use noresume the system hang with the message: 
"Creating root device"

Usign sata drive on the install chipset VIA VT8237, no raid, x86, i haved 
fedora 7 running witout problems before install Fedora 8
Comment 9 Tyler Wake 2007-11-13 01:12:45 EST
(In reply to comment #8)
> I got the same error, but after use noresume the system hang with the message: 
> "Creating root device"

I also get the same results with the "noresume" option. I however do not have
any logical partitions. I'm assuming you have type 165 partitions on your disk too?
Comment 10 Peter Dunning 2007-11-14 15:51:54 EST
I have had the same problem but with the FreeBSD partition on a separate drive,
which is not mentioned in fstab. The problem was solved by deleting the freeBSD
slice. I intend to reinstall FreeBSD when version 7 is released soon and I hope
we have a solution then.
Comment 11 Ben Lipton 2007-11-14 17:05:04 EST
I had the same issue. /dev/sda2 was a FreeBSD partition, and Fedora 8 was
installed with root partition (no LVM) on /dev/sda11. Booting halted with
"Creating root device." Before seeing this bug I tried copying over the latest
Fedora 7 kernel with its initrd and modules, which allowed me to boot, but I had
no success getting the .fc8 kernel to boot. Deleting the FreeBSD partition
allowed it to boot immediately, but hopefully at some point there will be a
solution to this so I can reinstall FreeBSD.
Comment 12 gnazio 2007-11-14 18:04:47 EST
This could be the same problem posted here
https://bugzilla.redhat.com/show_bug.cgi?id=374521

In fact I do have various FreeBSD partitions on all my other HDs even if there
is none in the same HD on which I've tried upgrading from F7 to F8.
Comment 13 Chuck Ebbert 2007-11-14 18:35:18 EST
Could people who are using the Fedora 7 kernel make sure that 2.6.23.1-28 still
works? It will be in the updates-testing repository soon.
Comment 14 Paul Lipps 2007-11-14 19:41:14 EST
Updated the title.
Comment 15 Jeronimo Martinez Sanchez 2007-11-14 21:30:05 EST
(In reply to comment #9)
> (In reply to comment #8)
> > I got the same error, but after use noresume the system hang with the message: 
> > "Creating root device"
> 
> I also get the same results with the "noresume" option. I however do not have
> any logical partitions. I'm assuming you have type 165 partitions on your disk
too?

yes i have FreeBSD 6.2 installed on other disk, fedora and freebsd are on
diferents disk.  
Comment 16 Tyler Wake 2007-11-15 02:13:15 EST
This might be of some help. mkinitrd bug?

https://fedoraproject.org/wiki/KernelCommonProblems#head-1879cb20fd3b729e938a6e8ac9da1c9cac8addd6
Comment 17 Jeronimo Martinez Sanchez 2007-11-15 09:55:46 EST
i have to remove the bsd partitions from my sistem, and reinstall fedora 8,
after the install the boot was normaly and succesfull, without bsd partitions on
the system the generation of initrd was good and fedora can boot normaly.  
Comment 18 Chuck Ebbert 2007-11-15 10:53:13 EST
Is the initrd different when there are no BSD partitons present?
Comment 19 Jeronimo Martinez Sanchez 2007-11-15 23:47:06 EST
(In reply to comment #18)
> Is the initrd different when there are no BSD partitons present?

yes the initrd without the bsd partitions was a few bytes smaller than the
initrd with the bsd partition.

3662702 2007-11-15 22:20 initrd-2.6.23.1-42.fc8.img.bad  (with bsd, no boot)
3660137 2007-11-15 22:20 initrd-2.6.23.1-42.fc8.img.good (without bsd, boot)



Comment 20 Tyler Wake 2007-11-16 11:33:29 EST
Can you open up the two initrd images and find the differences?

mkdir initrd
cd initrd/
gzip -dc /boot/initrd-2.6.23-42.fc8.img.good | cpio -id
Comment 21 gnazio 2007-11-17 06:49:19 EST
If I physically unplug the other 2 HDs, on which FreeBSD installations are
present, leaving only the one with Fedora (currently 7.92), I can boot Fedora
regularly!
Comment 22 Paul Lipps 2007-11-17 19:39:26 EST
Upgraded Severity to High. Devs please correct if not appropriate.
Comment 23 gnazio 2007-11-18 20:10:52 EST
Could you change also "Hardware" to "All"?
I'm having this problem with x86_64.
Comment 24 Paul Lipps 2007-11-18 20:13:11 EST
Done
Comment 25 gnazio 2007-11-19 03:44:11 EST
(In reply to comment #20)
> Can you open up the two initrd images and find the differences?
> 
> mkdir initrd
> cd initrd/
> gzip -dc /boot/initrd-2.6.23-42.fc8.img.good | cpio -id

If this could mean something, I've tried replacing nash and mkinitrd, on a
unbootable 7.92 (has trap divide error as shown on 8), with the ones shipped
with 7.90 (which boots fine on the same pc) and creating a new initrd. The
problem still persist.

If not the kernel, could it be in the move from util-linux (<= 7.90) to
util-linux-ng (>= 7.92) ???
Comment 26 Jeronimo Martinez Sanchez 2007-11-19 14:14:27 EST
(In reply to comment #20)
> Can you open up the two initrd images and find the differences?
> 
> mkdir initrd
> cd initrd/
> gzip -dc /boot/initrd-2.6.23-42.fc8.img.good | cpio -id

i open the 2 initrd images, and both files look the same, the diference was on a
line on ld config, i install mysql the first time, but not the second time and,
but this is not important, both images has the same files and content. 
Comment 27 g4g33 2007-11-19 15:47:56 EST
i installed fedora 4 , the same problem (trap divide error) FreeBsd 5 on hd2
Problem gone in Fedora 5
Fresh install Fedora 6, exactly the same problem.
Fedora 7 installed, everything OK.
Now Fedora 8 give me the same problem again.
Maybe fedora 9 should solve the problem.
Comment 28 Paul Lipps 2007-11-23 20:03:21 EST
Adding this link to a thread on Fedora Forums. There has been some more work on
tracking down this bug that has not been added here.

http://forums.fedoraforum.org/showthread.php?t=171223
Comment 29 gnazio 2007-11-23 23:37:37 EST
It seems that we have run out of ideas.
And the three bug reports here are still NEW

https://bugzilla.redhat.com/show_bug.cgi?id=374521
https://bugzilla.redhat.com/show_bug.cgi?id=375591
https://bugzilla.redhat.com/show_bug.cgi?id=385361

And I've found that the problem were known even before F8 release
http://www.redhat.com/archives/fedora-test-list/2007-October/msg01386.html
Comment 30 Chuck Ebbert 2007-11-26 10:48:22 EST
*** Bug 385361 has been marked as a duplicate of this bug. ***
Comment 31 Chuck Ebbert 2007-11-26 11:39:49 EST

*** This bug has been marked as a duplicate of 374521 ***

Note You need to log in before you can comment on or make changes to this bug.