Bug 385361 - F8 install problem on AMD 64-bit system
F8 install problem on AMD 64-bit system
Status: CLOSED DUPLICATE of bug 375591
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 14:36 EST by Tarek Allam
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 10:48:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output from installation of openSUSE 10.3 (36.57 KB, text/plain)
2007-11-15 14:36 EST, Tarek Allam
no flags Details

  None (edit)
Description Tarek Allam 2007-11-15 14:36:12 EST
Description of problem:
Checking the forums this problem is far from being a problem for a couple of
people. I did have the same problem trying to go from F7 to F8 on an HP Pavilion
a1610n 64-bit version. I had some issues with F7 but after including "noapic"
things were working fine.

Now with F8 I tried installing three times and reach the "nash" stage and the
system gives me a flashing cursor and stops.

I am writing this on the same system using openSUSE 10.3 64-bit. I didn't even
use "noapic" and everything works fine... so what's the story with F8?


Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. use DVD for F8 64-bit version
2. go through the whole install process (with no errors flagged)
3. reboot... stops after "nash"
  
Actual results:
system that doesn't boot into F8

Expected results:
working system

Additional info:
Comment 1 Tarek Allam 2007-11-15 14:36:12 EST
Created attachment 260301 [details]
dmesg output from installation of openSUSE 10.3
Comment 2 Jeremy Katz 2007-11-15 19:42:18 EST
Can you remove quiet from the boot parameters and provide the output of when it
hangs?
Comment 3 Tarek Allam 2007-11-16 11:09:53 EST
(In reply to comment #2)
> Can you remove quiet from the boot parameters and provide the output of when it
> hangs?

I will need to find s different HD to do the install on and revert.
Comment 4 Tarek Allam 2007-11-20 16:49:02 EST
(In reply to comment #3)
> (In reply to comment #2)
> > Can you remove quiet from the boot parameters and provide the output of when it
> > hangs?
> 
> I will need to find s different HD to do the install on and revert.
OK I found a spare HD. Here's the result of the reinstall:

when I removed "quiet" things scrolled by and then a line sinmilar to the
following kept on repeating:

init[1] trap divide error rip:2aaaab5638a4 rsp: 7fff93e0e4f0 error: 0

followed by:

printk: 7545621 message suppressed

(numbers change, otherwise message is the same)

This is where a loop condition happens.

I hope this helps.
Comment 5 gnazio 2007-11-21 19:05:04 EST
I have the same (init[1] trap divide) error after upgrading from f7 to f8 and
trying a fresh install. So I've tried some betas: 7.92 has the same problem
while 7.90 works.

Is it yet another duplicate of these bugs?
https://bugzilla.redhat.com/show_bug.cgi?id=374521
https://bugzilla.redhat.com/show_bug.cgi?id=375591

Comment 6 gnazio 2007-11-21 19:09:33 EST
It this could suggest something to who is reading this, as I wrote in one of the
bug reports posted above, I had F8 in one HD and my other 2 HD are completely
devoted to FreeBSD.
If I unplug the all the HDs with FreeBSD, F8 boots regularly.
Comment 7 gnazio 2007-11-22 19:02:59 EST
(In reply to comment #1)
> Created an attachment (id=260301) [edit]
> dmesg output from installation of openSUSE 10.3
> 

From your dmesg
sdb1: <bsd: sdb5 sdb6 sdb7 sdb8 sdb9 >

Ah Ahhhh...BSD partitions?
How dare you!?!
Comment 8 Tarek Allam 2007-11-23 09:01:07 EST
(In reply to comment #7)
> (In reply to comment #1)
> > Created an attachment (id=260301) [edit] [edit]
> > dmesg output from installation of openSUSE 10.3
> > 
> 
> From your dmesg
> sdb1: <bsd: sdb5 sdb6 sdb7 sdb8 sdb9 >
> 
> Ah Ahhhh...BSD partitions?
> How dare you!?!
> 

Buongiorno gnazio,

I guess to see how things are done on different OSes. The machine came with
WinXP, I added a HD to put Fedora (F7) on, then added another for FreeBSD.
Hence, each one is on a separate HD. This way there won't be a fight!

As you mentioned earlier I did disconnect everything and put in a "fresh" SATA
HD and the installation went OK. So the question is: what happens when the other
things (HDs and USB devices) are added to the mix? What trips the system and
makes it loop? Why is this happening with F8 and not openSUSE 10.3?

By the way, except for XP the other OSes are all of the 64-bit variety.
Comment 9 gnazio 2007-11-23 20:16:30 EST
(In reply to comment #8)
> (In reply to comment #7)
> > 
> > From your dmesg
> > sdb1: <bsd: sdb5 sdb6 sdb7 sdb8 sdb9 >
> > 
> > Ah Ahhhh...BSD partitions?
> > How dare you!?!
> > 
> 
> Buongiorno gnazio,

Hi, (am I right saying Salaam Tarek? :) I can't guess from you domain, just from
name)

> I guess to see how things are done on different OSes. The machine came with
> WinXP, I added a HD to put Fedora (F7) on, then added another for FreeBSD.
> Hence, each one is on a separate HD. This way there won't be a fight!

Obviously it was just ironic!
I was referring to one of the bug reports I've posted as link. Also on
fedoraforums there is a long thread about the problematic F8 coexistence with
BSD partitions.

> As you mentioned earlier I did disconnect everything and put in a "fresh" SATA
> HD and the installation went OK.
> So the question is: what happens when the other
> things (HDs and USB devices) are added to the mix? What trips the system and
> makes it loop? Why is this happening with F8 and not openSUSE 10.3?

What I've wrote were not meant to be a solution, it was just to add some info
about the problem: the installation process is fully working even if bsd
partitions are present, but, in this case, the boot process fails even if on
different hd.
What I can say about your question is that from what I've seen it will not boot
if you add an HD with BSD. You can try to plug in you BSD disk: in the worst
case it will no boot, but it will do no harm, so if you want to stay with F8,
just unplug the HD and it will work again.
Not sure about USB devices with BSD partitions but I'm prone to think that it
will work.
I'm pretty sure that there is no problem with windows based os, as, in such
case, there should be far more people complaining!

> By the way, except for XP the other OSes are all of the 64-bit variety.
> 

Just for the record, I'm running 2 32bit FreeBSD versions and I was/I'm (not)
running the 64bit F7/F8.
Anyway, on the other thread, people are reporting the same problem with the
32bit version.
About OpenSUSE I don't know, but I think that it is not as bleeding edge as
Fedora, so probably a really new version of $SOMETHING is b0rked.
Comment 10 Chuck Ebbert 2007-11-26 10:48:20 EST

*** This bug has been marked as a duplicate of 375591 ***

Note You need to log in before you can comment on or make changes to this bug.