Bug 375781 - Logwatch shows an error for logrotate
Logwatch shows an error for logrotate
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: logrotate (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On: 400661 400671
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 06:37 EST by Bernd Bartmann
Modified: 2008-01-30 03:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 03:24:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2007-11-11 06:37:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.8) Gecko/20071030 Fedora/2.0.0.8-2.fc8 Firefox/2.0.0.8

Description of problem:
I'm running F8. In the emails generated by cron.daily I get the following message every day:

/etc/cron.daily/logrotate:

error: syslog:1 duplicate log entry for /var/log/messages
error: found error in /var/log/messages /var/log/secure /var/log/maillog /var/log/spooler /var/log/boot.log /var/log/cron , skipping


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. just wait for the emails coming from cron.daily
2.
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Tomas Smetana 2007-11-12 03:21:01 EST
Can you please post your /etc/logrotate.d/syslog and contents of the
/etc/logrotate.d directory?  Thanks.
Comment 2 Bernd Bartmann 2007-11-12 10:21:54 EST
I did not touch any of the default files, anywhere here's /etc/logrotate.d/syslog:

/var/log/messages /var/log/secure /var/log/maillog /var/log/spooler
/var/log/boot.log /var/log/cro
n {
    sharedscripts
    postrotate
        /bin/kill -HUP `cat /var/run/syslogd.pid 2> /dev/null` 2> /dev/null || true
    endscript
}


And here's the contents of /etc/logrotate.d:

[root@beverly vdr]# ls -l /etc/logrotate.d/
insgesamt 208
-rw-r--r-- 1 root root  144 23. Okt 18:12 acpid
-rw-r--r-- 1 root root  338 22. Sep 14:26 BackupPC
-rw-r--r-- 1 root root  291 25. Mär 2007  bittorrent
-rw-r--r-- 1 root root   70 26. Jun 2001  boa
-rw-r--r-- 1 root root   73  3. Okt 15:13 dirmngr
-rw-r--r-- 1 root root  147 31. Aug 12:36 exim
-rw-r--r-- 1 root root  174 18. Nov 2004  httpd
-rw-r--r-- 1 root root  131 24. Aug 10:03 iptraf
-rwxr-xr-x 1 root root  106 30. Aug 21:06 jetty
-rw-r--r-- 1 root root   61 15. Feb 2006  kdm
-rw-r--r-- 1 root root  159  6. Nov 2006  lighttpd
-rw-r----- 1 root named 163 23. Okt 20:21 named
-rw-r--r-- 1 root root  136  1. Dez 2006  ppp
-rw-r--r-- 1 root root  329 29. Aug 02:38 psacct
-rw-r--r-- 1 root root   61 12. Okt 08:02 rpm
-rw-r--r-- 1 root root  236 10. Jul 18:27 rsyslog
-rw-r--r-- 1 root root  115 18. Okt 19:11 samba
-rw-r--r-- 1 root root   68 21. Aug 16:15 sa-update
-rw-r--r-- 1 root root  121  3. Okt 03:15 setroubleshoot
-rw-r--r-- 1 root root  154 16. Okt 12:52 snmpd
-rwxr-xr-x 1 root root  543 25. Sep 14:30 squid
-rw-r--r-- 1 root root  228 10. Mai 2005  syslog
-rw-r--r-- 1 root root  148  9. Nov 2004  thttpd
-rw-r--r-- 1 root root  103  9. Aug 22:53 tomcat5
-rw-r--r-- 1 root root   95 29. Aug 08:18 vsftpd.log
-rw-r--r-- 1 root root   89 12. Okt 22:21 yum

BTW: I'm seeing this problem on all of my F8 machines.
Comment 3 Tomas Smetana 2007-11-27 03:14:55 EST
Apparently both rsyslog and syslog-ng have the same logrotate configuration
files which causes the problem.  I'll have to consult the bug with rsyslog an
syslog-ng maintainers.
Comment 4 Tomas Smetana 2007-11-27 04:57:54 EST
Quick solution should be: rpm -e syslog-ng (it's been replaced by rsyslog) and
I'll report the bug for both the packages -- they must conflict.
Comment 5 Bernd Bartmann 2007-12-07 15:48:44 EST
So, now with the latest "yum update" I get:

Error: rsyslog conflicts with syslog-ng

Is this really intended? This breaks the automatic update process and requires
manual intervention. IMHO a total disaster for Joe User.
Comment 6 Tomas Smetana 2007-12-10 02:29:10 EST
This should have been done before the two packages got both into the default
distribution.  And yes, I think it's a disaster.  Not a big one though.
Comment 7 Tomas Smetana 2008-01-30 03:24:55 EST
Both the bugs in syslog-ng and rsyslog have been closed.  There's nothing else
to do from the logrotate's point of view.  Closing.

Note You need to log in before you can comment on or make changes to this bug.