Bug 400671 - The syslog-ng an rsyslog packages should conflict
The syslog-ng an rsyslog packages should conflict
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rsyslog (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On: 400661
Blocks: 375781
  Show dependency treegraph
 
Reported: 2007-11-27 05:16 EST by Tomas Smetana
Modified: 2015-07-21 09:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-29 07:58:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomas Smetana 2007-11-27 05:16:32 EST
+++ This bug was initially created as a clone of Bug #400661 +++

Description of problem:

Both the syslog-ng and rsyslog packages have the same logrotate configuration
file, which causes logrotate to find duplicties for the system logs and refuses
to rotate them.  This may lead to a disk space exhaustion.

Version-Release number of selected component (if applicable):

syslog-ng-2.0.5-1.fc8
rsyslog-1.19.6-3.fc8

How reproducible:
Always


Steps to Reproduce:
1. Install both the loggers and watch the emails sent by logwatch -- you'll see
something like this:

/etc/cron.daily/logrotate:

error: syslog:1 duplicate log entry for /var/log/messages
error: found error in /var/log/messages /var/log/secure /var/log/maillog
/var/log/spooler /var/log/boot.log /var/log/cron , skipping
  
Actual results:
Logs are not rotated due to duplicite configurations.

Expected results:
Logs are rotated.

Additional info:
Comment 1 Peter Vrabec 2007-11-27 06:14:06 EST
Jose, do you agree to use "conflict: syslog-ng/rsyslog"? I'm fine with this 
solution.
Comment 2 Peter Vrabec 2007-11-29 07:58:37 EST
fixed in rsyslog-1.19.11-1.fc8
Comment 3 Michal Jaegermann 2007-12-11 16:52:21 EST
Well, it should possibly add also obsoletes for syslog-ng.
Otherwise if both packages are installed then an update to
rsyslog-1.19.11-1.fc8 fails.
Comment 4 Michal Jaegermann 2007-12-11 16:56:15 EST
Oh, and this "conflict" makes syslog-ng package practically useless.
Tons of packages depends on rsyslog so removing it is not feasible.
It appear that a better coordination between these packages would
be needed.

Note You need to log in before you can comment on or make changes to this bug.