Bug 376051 - Nouveau driver doesn't start at boot time
Nouveau driver doesn't start at boot time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 10:33 EST by Fdor
Modified: 2008-01-22 14:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 14:47:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fdor 2007-11-11 10:33:37 EST
Description of problem:
-----------------------

The nouveau driver doesn's start in boot time (after kernel boot, and while
services are being loaded), so the boot process is shown completely in text mode. 

Anyway, after the boot is completed, the graphical login screen (which uses the
nouveau driver) starts normally, and after login, the Desktop is started
normally. So it's probably some problem at boot time.

If I change the drive to "nv" (xorg.conf) and reboot, then everything works
normally (graphical boot included).

Version-Release number of selected component (if applicable):
-------------------------------------------------------------

xorg-x11-drv-nouveau-2.1.5-2.fc8


How reproducible:
-----------------

Always


Steps to Reproduce:
-------------------

1. Change the "Driver" to "nouveau" in /etc/X11/xorg.conf.
2. Reboot the computer
  
Actual results:

Boot process is shown in text mode.

Expected results:

Boot process should be shown in graphical mode.

Additional info:

# lspci | grep VGA
00:05.0 VGA compatible controller: nVidia Corporation C51G [GeForce 6100] (rev a2)
Comment 1 Fdor 2007-11-11 14:11:17 EST
I've added a comment to the invisible cursor bug report ( Bug 182517 #58 ).

The cursor is invisible both with "nv" and "nouveau" drivers. As a workaround,
you can add:

    Option            "HWCursor" "off"

to xorg.conf. But the bug should be fixed, since the cursor should be rendered
by hardware.
Comment 2 Matěj Cepl 2007-11-12 11:25:31 EST
Sorry, I don't get whether after adding that to /etc/X11/xorg.conf the computer
was booted in the graphical mode.
Comment 3 Fdor 2007-11-12 17:30:37 EST
I've just tried again, and got same results:

- "nouveau" driver: boot (loading of services) in text mode.
- "nv" driver: boot in graphical mode.

As aditional information, with the nouveau driver, I can see that it tries to
launch the graphical mode (screen goes into black for 1-2 seconds), but then it
returns to text mode, and continues loading services in text mode. When all
services have been loaded, the graphical mode does start to show the login
screen (gdm) and then everything is normal.

Desktop with nouveau driver seems to be as stable as with nv driver. I hope
direct rendering to be added soon to nouveau in order to support compiz,
avoiding the need of installing privative drivers.
Comment 4 Adam Jackson 2008-01-22 14:47:41 EST
I think this is actually an rhgb bug.  We used to start rhgb's X server with DRI
disabled because it would steal DRI away from the gdm X server.  However, rhgb
now waits until the X server is completely exited before itself exiting, so we
should be able to hand off to gdm just fine.

rhgb-0.17.7-4.fc9 will enable DRI, so this shouldn't happen anymore.  Please
reopen if it does.

Note You need to log in before you can comment on or make changes to this bug.