Bug 37635 - Upgrade system failure
Summary: Upgrade system failure
Status: CLOSED DUPLICATE of bug 18019
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-25 16:34 UTC by Volodymyr Kruglov
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-25 18:17:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump, produced during unsuccessful upgrade (9.79 KB, text/plain)
2001-04-25 16:37 UTC, Volodymyr Kruglov
no flags Details

Description Volodymyr Kruglov 2001-04-25 16:34:44 UTC
I have tried to upgrade my system from 7.0 to 7.1 level. Upgrade has failed I system proposed me put diskette for the diagnostic dump.
I did it, please see its header (full dupm available on request):

Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
    rc = apply (step[1](), args)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/textw/upgrade_text.py", line 33, in __call__
    todo.upgradeFindPackages ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1277, in upgradeFindPackages
    self.hdList[package[rpm.RPMTAG_NAME]].select()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/comps.py", line 116, in __getitem__
    return self.packages[item]
KeyError: kernel-enterprise

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 8256108>
item: kernel-enterprise

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'

Comment 1 Volodymyr Kruglov 2001-04-25 16:37:22 UTC
Created attachment 16408 [details]
Dump, produced during unsuccessful upgrade

Comment 2 Brent Fox 2001-04-25 18:17:02 UTC
Either something is corrupted with your install image or your cd is bad.  I
suggest redownloading and trying again.  Thanks for your report.

*** This bug has been marked as a duplicate of 18019 ***


Note You need to log in before you can comment on or make changes to this bug.