Bug 376641 - hpmudext libraries causes many lines to be printed to stdout
hpmudext libraries causes many lines to be printed to stdout
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-11-11 17:53 EST by Bernard Johnson
Modified: 2013-01-16 07:45 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.7.12-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-16 07:45:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernard Johnson 2007-11-11 17:53:20 EST
Description of problem:
hpmudext library causes many lines to be printed to stdout.  When running the
command below, the call to hpmudext.make_net_uri(param, port) creates a lot of
error output.

Can be reproduced with this simple python program:
import hpmudext
hpmudext.make_net_uri('a', 0)

Version-Release number of selected component (if applicable):
hplip-2.7.7-6.fc8

How reproducible:
Always

Steps to Reproduce:
1. hp-setup -i <ip-addr>
2.
3.
  
Actual results:
# hp-setup -i 192.168.1.11

HP Linux Imaging and Printing System (ver. 2.7.7)
Printer/Fax Setup Utility ver. 4.5

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

No log handling enabled - turning on stderr logging
Cannot find module (HOST-RESOURCES-MIB): At line 0 in (none)
Cannot find module (HOST-RESOURCES-TYPES): At line 0 in (none)
Cannot find module (UCD-DISKIO-MIB): At line 0 in (none)
Cannot find module (TCP-MIB): At line 0 in (none)
Cannot find module (UDP-MIB): At line 0 in (none)
Cannot find module (MTA-MIB): At line 0 in (none)
Cannot find module (NETWORK-SERVICES-MIB): At line 0 in (none)
Cannot find module (LM-SENSORS-MIB): At line 0 in (none)
Cannot find module (IP-MIB): At line 0 in (none)
Cannot find module (IF-MIB): At line 0 in (none)
Cannot find module (SNMPv2-MIB): At line 0 in (none)
Cannot find module (SNMPv2-SMI): At line 0 in (none)
Cannot find module (NOTIFICATION-LOG-MIB): At line 0 in (none)
Cannot find module (DISMAN-EVENT-MIB): At line 0 in (none)
Cannot find module (DISMAN-SCHEDULE-MIB): At line 0 in (none)
Cannot find module (UCD-SNMP-MIB): At line 0 in (none)
Cannot find module (UCD-DEMO-MIB): At line 0 in (none)
Cannot find module (SNMP-TARGET-MIB): At line 0 in (none)
Cannot find module (NET-SNMP-AGENT-MIB): At line 0 in (none)
Cannot find module (SNMP-FRAMEWORK-MIB): At line 0 in (none)
Cannot find module (SNMP-MPD-MIB): At line 0 in (none)
Cannot find module (SNMP-USER-BASED-SM-MIB): At line 0 in (none)
Cannot find module (SNMP-VIEW-BASED-ACM-MIB): At line 0 in (none)
Cannot find module (SNMP-COMMUNITY-MIB): At line 0 in (none)
Cannot find module (IPV6-ICMP-MIB): At line 0 in (none)
Cannot find module (IPV6-MIB): At line 0 in (none)
Cannot find module (IPV6-TCP-MIB): At line 0 in (none)
Cannot find module (IPV6-UDP-MIB): At line 0 in (none)
Cannot find module (IP-FORWARD-MIB): At line 0 in (none)
Cannot find module (NET-SNMP-EXTEND-MIB): At line 0 in (none)
Cannot find module (UCD-DLMOD-MIB): At line 0 in (none)
Cannot find module (SNMP-NOTIFICATION-MIB): At line 0 in (none)
Cannot find module (SNMPv2-TM): At line 0 in (none)
Cannot find module (NET-SNMP-VACM-MIB): At line 0 in (none)

Setting up device: hp:/net/HP_Color_LaserJet_2840?ip=192.168.1.11
<snip>

Expected results:
No error output

Additional info:
I marked this as medium severity because it affects other applications.  For
example, gscan2pdf catches this output when scanning and because it's not part
of the known expected errors, it displays a dialog box for each line of stderr.
Comment 1 Bernard Johnson 2007-11-18 03:54:09 EST
Putting a Requires: on net-snmp will fix this.
Comment 2 Fedora Update System 2008-01-22 10:47:59 EST
hplip-2.7.12-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'
Comment 3 Tim Waugh 2008-01-23 10:50:41 EST
Requirement is now there.
Comment 4 Fedora Update System 2008-01-27 02:11:15 EST
hplip-2.7.12-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/F8/FEDORA-2008-0820
Comment 5 Fedora Update System 2008-01-29 00:14:04 EST
hplip-2.7.12-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Jiri Popelka 2013-01-16 05:31:21 EST
I've been checking (due to bug #895643) why hpijs depends on net-snmp and not just net-snmp-libs, but haven't found anything.

I made a testing hpijs package without the net-snmp requirement, removed net-snmp and tried the reproducers from description of this bug and haven't spotted any problems so I'd like to remove the 'Requires: net-snmp' again.
Comment 7 Tim Waugh 2013-01-16 07:04:46 EST
IIRC what was missing before were the actual mibs, and they seem to be part of net-snmp-libs.  Yes, the net-snmp requirement can go now.
Comment 8 Jiri Popelka 2013-01-16 07:45:30 EST
OK, will be fixed as bug #895643.

Note You need to log in before you can comment on or make changes to this bug.