Bug 895643 - hpijs depends on net-snmp
hpijs depends on net-snmp
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 963816 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-15 12:36 EST by Tom Lane
Modified: 2013-07-02 23:48 EDT (History)
7 users (show)

See Also:
Fixed In Version: hplip-3.13.4-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-07 18:59:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Lane 2013-01-15 12:36:50 EST
Description of problem:
Would it be possible to rearrange things or add a new subpackage so that the base net-snmp package doesn't depend on mysql?

My motivation for asking is mostly selfish: as mysql maintainer, I frequently have to remove/reinstall libmysqlclient.  It's annoying to find that in F18, that causes the entire hplip stack to go away.  Surely printing does not require access to a database.  However, even without my personal problems, I think this dependency is surprising --- there is nothing in the description of the package that suggests it includes database-related functionality.

Version-Release number of selected component (if applicable):
net-snmp-5.7.2-4.fc18
Comment 1 Jan Safranek 2013-01-16 07:31:03 EST
net-snmp contains daemons and one of the two daemons is snmptraopd, which optionally saves traps to mysql database, so there is good reason to have net-snmp dependent on mysql. However, hplip should not depend on net-snmp but net-snmp-libs.
Comment 2 Jiri Popelka 2013-01-16 07:34:50 EST
See bug #376641.
Comment 3 Fedora Update System 2013-02-19 08:04:46 EST
hplip-3.13.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/hplip-3.13.2-1.fc18
Comment 4 Fedora Update System 2013-02-21 00:43:39 EST
Package hplip-3.13.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.13.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2791/hplip-3.13.2-1.fc18
then log in and leave karma (feedback).
Comment 5 Vasilis Keramidas 2013-02-25 15:37:32 EST
hplip-3.13.2-1.fc18 not longer depends on net-snmp
I left positive feedback at https://admin.fedoraproject.org/updates/F18/FEDORA-2013-2791
Comment 6 Fedora Update System 2013-03-07 18:59:37 EST
hplip-3.13.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Jiri Popelka 2013-05-20 03:57:35 EDT
*** Bug 963816 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2013-05-20 03:59:03 EDT
hplip-3.13.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/hplip-3.13.4-1.fc17
Comment 9 Fedora Update System 2013-06-24 23:28:58 EDT
hplip-3.13.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.