This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 376691 - F8: New Install - Default Keyring locked with unknown password
F8: New Install - Default Keyring locked with unknown password
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 18:54 EST by Jase Whipp
Modified: 2015-03-03 17:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:09:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jase Whipp 2007-11-11 18:54:02 EST
Description of problem:

After a new installation, the default keyring is locked with an unknown password
(password is never set by the user). As a result, the user isn't able to store
authentication creds (e.g. WPA passwords).

This was reproduced 3 times on three different machines. 

Steps to Reproduce:
1. Log in with a new user
2. Access the keyring manager
3. Alternatively, try to authenticate with a wireless (WPA protected access
point) which causes Network Manager to try to store the password in th keyring
  

Expected results:

If the key ring hasn't been used before, the user should be prompted to enter a
new password.  This is the behavior on F7 and previous releases.
Comment 1 Simone Marchioni 2007-11-13 05:20:02 EST
Same problem here.

Installed Fedora 8 from the i386 DVD (clean install), and updated the system.
After reboot I configured a pop account in Evolution and it worked well.

The next day after the gnome login launched Evolution and it continue asking for
the keyring password I never initialized. Tried to type my user password and
leave the password empty but it didn't worked.
Comment 2 Joachim Selke 2007-11-13 07:58:18 EST
I have exactly the same problem on two different machines. In both cases, I did
a fresh install of Fedora 8 and simply copied my old user home directory back to
the new system.
Comment 3 Joachim Selke 2007-11-13 08:01:08 EST
The fix mentioned in bug 344611 works for me:

echo -n default > ~/.gnome2/keyrings/default
Comment 4 Christopher Beland 2007-12-28 11:48:18 EST
When sending mail from Evolution, I am prompted for the password for my SMTP
account, and then I get a dialog box, which says something like (I cannot
copy-and-paste the window, and I cannot get any other window to have keyboard
focus while it is displayed, so I cannot transcribe it exactly):

 "The application Evolution (/usr/bin/evolution) wants access to the default
keyring, but it is locked."

When I enter my password and click "OK", I simply get the same dialog box again
and again, until I give up and click "Deny".

I see the following in /var/log/messages:
 Dec 28 11:13:01 localhost gnome-keyring-daemon[2335]: Credentials byte was not nul

This dialog worked fine for me in Fedora 7, but after I upgraded to Fedora 8
using the "yum" method, I started having this problem.  I am supplying the same
password I used in Fedora 7; I don't know why it isn't being accepted.

1.) One problem is that if I intentionally type a bad password, there is no
indication when the dialog box reappears that the problem was that the password
was incorrect.  It looks like it is merely asking the same question again.  It
would be helpful to print some sort of error message asking the user to check
their spelling or letting them know they are using the wrong password.

2.) The fix mentioned in Comment #3 fixed this problem.  I guess this just needs
to be fixed so that this is done automatically by the installation or upgrade
process.
Comment 5 Bug Zapper 2008-11-26 03:19:48 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Christopher Beland 2008-12-17 15:16:50 EST
I tested the Evolution scenario on rawhide with gnome-keyring-2.25.2-2.fc11.x86_64.  It seems to be using the file ~/.gnome2/keyrings/login.keyring now, and I had no trouble when saving an SMTP password to the keyring - there were no dialog boxes asking for the keyring password or complaining it was locked.  This is with a new user account.  So it seems this is either fixed or at least changed so that the previously reported workaround will no longer work.
Comment 7 Bug Zapper 2009-01-09 00:09:43 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.