Bug 376721 - Move %{_libdir}/libpulsedsp.so from pulseaudio-utils to pulseaudio-libs
Move %{_libdir}/libpulsedsp.so from pulseaudio-utils to pulseaudio-libs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
Fedora Extras Quality Assurance
:
: 426882 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 19:17 EST by Michel Alexandre Salim
Modified: 2015-01-07 19:16 EST (History)
6 users (show)

See Also:
Fixed In Version: 0.9.10-1.fc9.
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-29 10:59:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch spec file to move libpulsedsp.so (999 bytes, patch)
2007-11-11 19:30 EST, Michel Alexandre Salim
no flags Details | Diff

  None (edit)
Description Michel Alexandre Salim 2007-11-11 19:17:20 EST
Description of problem:
libpulsedsp.so is needed to run OSS applications in compatibility mode. As such,
to run 32-bit OSS apps the 32-bit libpulsedsp.so is needed.

Currently libpulsedsp.so is packaged with pulseaudio-utils, which contains
binary executables, and thus 32-bit and 64-bit versions cannot be installed in
parallel. Moving this to pulseaudio-lib (which is installed multilib by default)
would allow apps such as Real Player to work, which I've tested by extracting
the .so file and putting it in /usr/lib

Version-Release number of selected component (if applicable):
pulseaudio-0.9.7-0.17.svn20071017.fc8

How reproducible:
Always


Steps to Reproduce:
1. On an x86_64 system, try and run RealPlayer (unstable version needed) when
the sound device is in use by PulseAudio
2. Now set Real Player's output device to OSS, and start RealPlayer using 'padsp
realplay'
3. Extract libpulsedsp.so from the 32-bit pulseaudio-utils and drop it in
/usr/lib, and repeat (2)
  
Actual results:
(1) would fail, (2) would also fail as the 32-bit lib is not present. (3) works.

Expected results:
(2) should work out-of-the-box if libpulsedsp.so is moved to pulseaudio-lib

Additional info:
Comment 1 Michel Alexandre Salim 2007-11-11 19:30:21 EST
Created attachment 254851 [details]
Patch spec file to move libpulsedsp.so
Comment 2 Thomas Moschny 2007-11-22 07:03:22 EST
+1 for additionally providing a 32bit version of libpulsedsp.so on x86_64 
systems.
Comment 3 Lennart Poettering 2007-11-29 20:18:12 EST
But it doesn't belong in pulseaudio-lib. It is not a client library anyone
should link to. It belongs to the padsp script and nothing else. And padsp is
part of pulseaudio-utils.

multilib is our downfall.

I guess this whole multilib mess leaves me with no other option than to add yet
another package "pulseaudio-utils-lib" to our already large package farm. 
Comment 4 drago01 2008-01-09 16:35:44 EST
*** Bug 426882 has been marked as a duplicate of this bug. ***
Comment 5 drago01 2008-01-09 16:37:57 EST
(In reply to comment #3)
> But it doesn't belong in pulseaudio-lib. It is not a client library anyone
> should link to. It belongs to the padsp script and nothing else. And padsp is
> part of pulseaudio-utils.
> 
> multilib is our downfall.
> 
> I guess this whole multilib mess leaves me with no other option than to add yet
> another package "pulseaudio-utils-lib" to our already large package farm. 

well its ugly but its worse than non working sound for i386 oss aps.
Comment 6 Andreas Bierfert 2008-01-09 16:54:01 EST
Actually also to run i386 alsa programs over a pulseaudio alsa device the i386
version of libasound_module_pcm_pulse.so is needed in multilib which it
currently is not (alsa-plugins-pulseaudio package).
Comment 7 Michel Alexandre Salim 2008-01-11 18:18:49 EST
#6 addresses a separate bug -- Andreas, could you file that bug?
Comment 8 drago01 2008-01-13 05:18:37 EST
(In reply to comment #3)
> But it doesn't belong in pulseaudio-lib. It is not a client library anyone
> should link to. It belongs to the padsp script and nothing else. And padsp is
> part of pulseaudio-utils.
> 
> multilib is our downfall.
> 
> I guess this whole multilib mess leaves me with no other option than to add yet
> another package "pulseaudio-utils-lib" to our already large package farm. 

I could also be fixed by adding pulseaudio-utils to the multilib whitelist.
Comment 9 Michel Alexandre Salim 2008-01-13 08:36:10 EST
No, because pulseaudio-utils contains platform-specific binaries. The solution
would be to split the libraries out of pulseaudio-utils 
Comment 10 drago01 2008-01-13 08:57:15 EST
(In reply to comment #9)
> No, because pulseaudio-utils contains platform-specific binaries. The solution
> would be to split the libraries out of pulseaudio-utils 

that should not be a problem rpm should take care of this (on x86_64 the x86_64
binaries would be preferred). 
Comment 11 Michel Alexandre Salim 2008-04-03 10:50:31 EDT
What's the status on this? The following two packages need to be added to the
whitelist, at least:

pulseaudio-esound-compat-0.9.10-1.fc9.i386
pulseaudio-utils-0.9.10-1.fc9.i386
Comment 13 Michel Alexandre Salim 2008-05-29 10:59:12 EDT
pulseaudio-utils has been whitelisted

Note You need to log in before you can comment on or make changes to this bug.