Bug 37681 - installation fdisk does not handle many drives
installation fdisk does not handle many drives
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 40074 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-25 16:30 EDT by Eric Delaney
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 12:23:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Delaney 2001-04-25 16:30:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


While attempting to network install a new machine with 72 disks connected. 
(2 IDE, 70 scsi on a qlogic's controller).  I got the message stating that 
fdisk could not handle the number of machine installed.  It then exits the 
install.

Reproducible: Always
Steps to Reproduce:
1.install a machine with a small fabric of attached disks 
2.It may be necessary to manually partition the root disk.
3.
	

Actual Results:  It quit the install.

Expected Results:  It should be able to handle a larger/infinite number of 
drives.  Even it its here is a list of disks, let me pick a subset to work 
from.

All and all this is a really small set of disks.  In the fabric's of the 
future this number will probably seem quite small comparetively.
Comment 1 Brent Fox 2001-04-25 16:35:26 EDT
Does this message appear in a dialog box?  Are you using GUI or text install?
Comment 2 Eric Delaney 2001-04-25 18:20:06 EDT
GUI based. A dialog box appears stating that I have "too many disks" for fdisk 
and that I should contact red hat customer support (or something to that 
effect).
Comment 3 Brent Fox 2001-04-26 14:52:14 EDT
This is related to msw's work on partitioning.
Comment 4 Michael Fulbright 2001-04-27 11:37:42 EDT
I would recommend disconnecting some drives and trying the install again.
This is the first time anyone has hit the internal limit...

We are planning to rework the way partitioning is handled so this should not be
an issue in the future.
Comment 5 Eric Delaney 2001-04-27 11:46:57 EDT
Already done.  I had the machine installed before I filed the bug.
Comment 6 Brent Fox 2001-05-04 12:23:36 EDT
Resolving this as rawhide as this issue will be addressed in future releases.
Comment 7 Brent Fox 2001-05-14 15:36:46 EDT
*** Bug 40074 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.