Bug 377201 - conduit removes symlinks
conduit removes symlinks
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: conduit (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Bernard Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 02:17 EST by Renich Bon Ciric
Modified: 2009-01-09 02:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:24:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshots that you guys asked (1.79 MB, application/x-bzip)
2007-11-16 23:19 EST, Renich Bon Ciric
no flags Details

  None (edit)
Description Renich Bon Ciric 2007-11-12 02:17:13 EST
Description of problem:
Every time I try to sync my Pictures and Documents folders, which are symlinked
to some other HDD's folder, conduit removes the symlink and it turnes them into
a text file containing the folder name.

Version-Release number of selected component (if applicable):
0.3.3-5

How reproducible:
Install counduit and configure a sync of a symlink that points to a folder
containing images to flickr and picassa and, also, a symlinked folder that
contains documents (OOo & txt) to a Box.net account.

Steps to Reproduce:
1. register a Box.net account
2. register a flickr account
3. rgister a picassa account
4. install conduit: su -c 'yum install conduit'
5. make sure you don't have a "documents" and "pictures" folder on your home
directory and create the symlinks to documents and pictures folder: ln -s
/path/to/pictures  ~/pictures && ln -s /path/to/documents ~/documents
6. launch condutil: application>Accesories>Condutil
7. configure it to sync your symlinked pictures folder, at your home directory,
to flickr and picassa
8. configure condutil to sync your symlinked documents folder, at your home
directory, to Box.net
9. start syncronization
  
Actual results:
Your symlinked folders, at your home directory, turn into text files containing
the folder name

Expected results:
Your symlinked folders should be synced with the services appointed.

Additional info:
Comment 1 Bernard Johnson 2007-11-12 09:40:38 EST
Thanks for the detailed bug report.  If you have time, please test with the
latest conduit due to be released into Fedora in a few days.

You can do this with:

su -c "yum --enablerepo=updates-testing update conduit"
Comment 2 Renich Bon Ciric 2007-11-12 19:38:44 EST
I will. I'll report back then.
Comment 3 Renich Bon Ciric 2007-11-13 12:33:55 EST
Ok, confirmed, even on the update, this happens... And, also, it fails to
refresh after a sync... but that's another bug ;=s
Comment 4 Bernard Johnson 2007-11-16 11:27:16 EST
I talked briefly with John Carr and these were his comments:

<Jc2k> we've refactored the file stuff a lot in 0.3.5 so i dont know if im just
failing at recreating it or if its gone..
Jc2k> hmm
<Jc2k> can you recreate it with a folder to folder sync?
<Jc2k> also, it sounds like the config code is implicated.
<Jc2k> ... could you ask him to post a screenshot of how he configured the
folder dataprovider, and if it happens if you do symlinked folder to symlinked
folder

He is on the CC: list now so he'll get your comments directly.
Comment 5 Renich Bon Ciric 2007-11-16 22:54:35 EST
Ok, first of all, I must say, I unninstalled it after my last post.

I installed the test version, which is not 0.3.5, but 0.3.4-2...

Couldn't reproduce it with a local folder to local folder setup. In fact, it
didn't happened.

When I tried syncing the symlinked folder to flickr, it didn't remove the
symlink anymore, but it never finished the sync. It got to:
1st try: 1%
2nd try: 6%
3rd try: 4%

With a "Error Synchronizing" message in both items.

Tried to do it, also, with Facebook, but it didn't even give me configuration
options and, when trying to sync or refresh, it froze.
Comment 6 Renich Bon Ciric 2007-11-16 23:19:05 EST
Created attachment 262121 [details]
screenshots that you guys asked

This contains screenshots of the config windows you asked and the screenshot of
a ls -l and cat done to the former symlink dir
Comment 7 Renich Bon Ciric 2007-11-16 23:24:53 EST
Ok, something strange happened. After I restarted my computer (note that I
reinstalled conduit and it's auto-starting) my Pictures folder truned into a
file. I will post the screenshots in a tar.bz2 file.
Comment 8 Bernard Johnson 2008-07-10 21:47:56 EDT
Are you still seeing this with the latest release 0.3.11.1-1?
Comment 9 Renich Bon Ciric 2008-07-12 06:07:30 EDT
conduit-0.3.8-1.fc9.noarch

This is the version I have... I'll just wait until it gets updated.
Comment 10 Renich Bon Ciric 2008-07-12 06:18:15 EDT
Ok, sorry, I installed the testing version. Everything goes well until the
"Conduit Login Manager" starts. It shows nothing... blank page...

and the sync status shows as "OK" on the folder but "error refreshing" on the
destination... 

I tried using flickr and facebook
Comment 11 Bug Zapper 2008-11-26 03:20:20 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2009-01-09 02:24:06 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.