Bug 37726 - Printtool cant configure smb printer correctly
Printtool cant configure smb printer correctly
Status: CLOSED DUPLICATE of bug 43905
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-26 00:57 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-18 17:47:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-26 00:57:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


 When i try to configure an smb printer with printtool (HP890C), the 
syntax of the field "share" is worng. When i put the correct information, 
ex: \\servername\HP890C , its simply dont print and the smbclient show an 
error saying that the number of slashs is insuficient, so i have to put 
one more slash to get it working. Its only work if i use 
\\\servername\HP890C . Anything else dont Work.

Reproducible: Always
Steps to Reproduce:
1. Configure an smb printer using printtool, on the field share, put 
\\servername\printer
2. Try to print, and it doesn't work.
3. change the \\servername\printer to \\\servername\printer and try to 
print again, now it works.
	

Actual Results:  Only prints if the share field has 3 slashs.

Expected Results:  It must work with the correct parameter, 
\\servername\printer , instead of \\\servername\printer .


  Its happens on all RH 7.1 machines that I try to install.
Comment 1 Alain D D Williams 2001-04-30 10:44:42 EDT
Another way of fixing it is to use forward slashes rather than back slashes.
This is more Linux friendly anyway. The point is that samba has accepted these
for a couple of years.

So:
    //servername/printer
This is less likely to break when red hat fixes the orginal problem.
Comment 2 Janne Simonen 2001-05-09 06:21:14 EDT
Actually you should trust the documentation. It clearly states that the proper 
format for the sharename is "//machinename/sharename", ie. do not use 
backslashes, use slashes!

Anyways, there is a bug in this: after upgrading from RH 7.0 to 7.1 printing 
to an SMB printer stopped working for me. When I checked the sharename, it was 
in the backslash format. After changing the backslashes to slashes, printing 
worked perfectly again. However, updating to RH 7.1 should automatically do 
this, shouldn't it? Besides that error is almost impossible to notice! 
Comment 3 Paul Johnson 2001-06-04 18:00:17 EDT
I am smb-printing through a WinNT system to a HP6L printer.  After making the
change described above, I can ASCII print, but postscript printing does not
work. In stead of postacript, I get hundreds of pages of random characters and
tons of trash.

I have tried it with the "translate \n=>\r\n"option checked and unchecked, I
can't see any difference. 

In the driver options, there are buttons for ReRender postscript and Send EOT,
but they won't stay checked.
Comment 4 Tim Waugh 2002-01-10 08:53:06 EST

*** This bug has been marked as a duplicate of 43905 ***

Note You need to log in before you can comment on or make changes to this bug.