Bug 377711 - iproute-2.6.23-1.fc9 is incompatible with kernel-xen
iproute-2.6.23-1.fc9 is incompatible with kernel-xen
Status: CLOSED DUPLICATE of bug 431179
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
Depends On:
  Show dependency treegraph
Reported: 2007-11-12 08:28 EST by Adam Tkac
Modified: 2013-04-30 19:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-19 07:11:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Tkac 2007-11-12 08:28:12 EST
Description of problem:
it looks that kernel 2.6.23 contains some new features related to network
control and iproute-2.6.23-1.fc9 needs it so network start script fails with

Version-Release number of selected component (if applicable):
2.6.21-2950.fc8xen #1 SMP Tue Oct 23 12:24:34 EDT 2007 i686 i686 i386 GNU/Linux

How reproducible:

Steps to Reproduce:
1. install latest rawhide (newest kernel-xen can't be installed due some
conflicts - Error: Missing Dependency: xen-hypervisor-abi = 3.1 is needed by
package xen)
2. try % service network start (or restart)
3. see errors

Actual results:
"RTNETLINK answers: Invalid argument" message during every device start and
network has to be configured manualy with ifconfig and route utilities

Expected results:
succesful network start

Additional info:
downgrade to iproute-2.6.22-5.fc9 fixes the problem. Assigning to kernel-xen to
make decision if it has all needed features compiled-in or this is primarily
iproute package problem
Comment 1 Michal Schmidt 2008-02-19 07:11:25 EST

*** This bug has been marked as a duplicate of 431179 ***

Note You need to log in before you can comment on or make changes to this bug.