Bug 431179 - iproute does not work with the XEN kernel or kernel < 2.6.23
iproute does not work with the XEN kernel or kernel < 2.6.23
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iproute (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
: 377711 (view as bug list)
Depends On: 431182
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-01 05:40 EST by Harald Hoyer
Modified: 2011-08-16 16:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-06 10:10:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2008-02-01 05:40:57 EST
iproute is missing a
Conflicts: kernel < 2.6.23

otherwise you end up with a non-functional system, because even the lo interface
cannot be brought up.
Comment 1 Marcela Mašláňová 2008-02-01 06:24:34 EST
Thank you for your report. The build of iproute is at the moment dependent on
the rhbz#431182. I hope that I'll build it soon with updated spec file.
Comment 2 Marcela Mašláňová 2008-02-06 08:05:46 EST
Now I fix the building problem in rawhide, but add conflicts into spec isn't
solution.
Testcase on my computer:
rpm -q iproute kernel
iproute-2.6.22-4.fc9
kernel-2.6.23.14-107.fc8

but I have reported problems in KVM with
kernel-2.6.21 and iproute-2.6.23

Iproute should be backward compatible. Could you tell me more about versions,
which were tested and aren't working?
rpm -q kernel kernel-xen iproute
uname -a
Comment 3 Harald Hoyer 2008-02-06 08:36:06 EST
just take rawhide:

iproute-2.6.23-1
kernel-xen-2.6.21.7*

this is x86_64

note, that rawhide's iproute is newer than your 
iproute-2.6.22-4.fc9
Comment 4 Michal Schmidt 2008-02-06 09:18:13 EST
I've hit the bug in current Rawhide in Xen.
It is fixed in upstream iproute already. I tested the patch and it helped. (I
had to comment out the generation of documentation in the specfile to workaround
the TeX problem).

commit 66e529f579f45351828fc82d6ba2629cc6eb3ddd
Author: Patrick McHardy <kaber@trash.net>
Date:   Thu Oct 25 19:46:29 2007 +0200

    iproute 2.6.23 incompatibility
    
    Arkadiusz Miskiewicz wrote:
    > People are reporting that
    >> ip link set multicast on dev eth0 (Invalid argument)
    >> no longer works when using iproute 2.6.23 on kernel 2.6.21.
    >>
    >> On my testing machine it also fails:
    >> # ./ip link set eth0 multicast on
    >> RTNETLINK answers: Invalid argument
    
    It seems it fails to properly detect that your kernel is missing
    RTM_NEWLINK support. Apparently the reason is that the kernels
    I tested with return a different error in this situation.
    
    
    Signed-off-by: Patrick McHardy <kaber@trash.net>
    Signed-off-by: Stephen Hemminger <shemminger@linux-foundation.org>

diff --git a/ip/iplink.c b/ip/iplink.c
index 8e0ed2a..f28f91c 100644
--- a/ip/iplink.c
+++ b/ip/iplink.c
@@ -107,7 +107,8 @@ static int accept_msg(const struct sockaddr_nl *who,
 {
        struct nlmsgerr *err = (struct nlmsgerr *)NLMSG_DATA(n);
 
-       if (n->nlmsg_type == NLMSG_ERROR && err->error == -EOPNOTSUPP)
+       if (n->nlmsg_type == NLMSG_ERROR &&
+           (err->error == -EOPNOTSUPP || err->error == -EINVAL))
                have_rtnl_newlink = 0;
        else
                have_rtnl_newlink = 1;
Comment 5 Marcela Mašláňová 2008-02-06 10:10:56 EST
Thanks for patch.

Ok, I push the new version of iproute into rawhide.
Happy testing.
Comment 6 Michal Schmidt 2008-02-19 07:11:26 EST
*** Bug 377711 has been marked as a duplicate of this bug. ***
Comment 7 Patrick Connelly 2011-08-16 16:34:35 EDT
*** Bug 731180 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.