Bug 378041 - unable to mount removable/ntfs
unable to mount removable/ntfs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
All Linux
high Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
: 373061 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 10:56 EST by Florian Sievert
Modified: 2008-04-09 01:16 EDT (History)
8 users (show)

See Also:
Fixed In Version: 3.5.9-7.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 01:16:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 152732 None None None Never

  None (edit)
Description Florian Sievert 2007-11-12 10:56:26 EST
Description of problem:
It looks like users of kde engage a problem when they try to mount any usb media
 device. If the device is pluged in or they click on the device icon on the
desktop an error message is displayed: "TODO: have to rethink extra options".

Version-Release number of selected component (if applicable):
kdebase-3.5.8-5.fc8

How reproducible:
Always

Steps to Reproduce:
1. Start a KDE Session
2. Plug in a external hard disk or usb media
3. If KDE asks what to do choose "Open in new window"
  
Actual results:
media://sdf1 is not accessable and the following error dialog appears: "TODO:
have to rethink extra options"

Expected results:
The disk is mounted and accessable. Works in F7 like a charm

Additional info:
It looks like it is possible to fix this problem, if you choose in the
properties of the device and unselect the option "mount as user" under the tab
"mounting". However, mounting as user is the default option and might irritate
users without much knowledge about the system.

The problem was also reported by another user in the german fedora forum. My
test device has a ntfs filesystem, but I guess other file systems might be
affected as well, because it looks like a permission problem.
Comment 1 Rex Dieter 2007-11-12 11:04:55 EST
My USB stick works, but mine is vfat (not ntfs).

To be clear, removable/ntfs worked on F-7?  
Do you have the ntfs support installed (ntfs-3g)?
Comment 2 Florian Sievert 2007-11-12 15:29:23 EST
Yes, the device worked without any problem on F-7 two days ago. Ntfs-3g is
installed. The problem is definitly the "mount as user" option that is set by
default. When deselecting this option it works like a charm (also via KDE).

However, I managed to format the disk to vfat also and I cannot confirm there a
problem either. Looks like it is really related to ntfs. I will try to confirm
this problem with different devices tomorrow at university.
Comment 3 Florian Sievert 2007-11-13 03:42:51 EST
Okay. The problem seems clearly to be with ntfs on removable devices. vfat usb
sticks seems to work without a problem.

The root of this problems seems that ntfs cannot be mount as user, but vfat can.
I am not sure for the reasons and also read that some people reports that they
cannot reproduce it under gnome. I am not 100% sure, but under F-7 I think a
NTFS device wasn't mounted as user. Any possibility to teach kde to mount all
file systems excluding ntfs as user?
Comment 4 Sebastian Vahl 2007-11-13 14:28:08 EST
This problem seems to be introduced by hal-0.5.10.
I've search around the web and found problems on several distros with this, 
eg:
Arch Linux: http://bbs.archlinux.org/viewtopic.php?pid=297389
Sidux (Debian Sid) (german): http://sidux.com/PNphpBB2-viewtopic-t-6590.html

So I've forced a downgrade to hal-0.5.9 from F7. With this version the 
mounting of external ntfs partitions is working normal.

But I'm not sure if this is an issue introduced by a change in hal or an 
incompability by kde for the newest hal version.
Comment 5 Rex Dieter 2007-11-13 14:34:55 EST
Reassigning -> hal
Comment 6 David Zeuthen 2007-11-13 14:53:54 EST
(In reply to comment #5)
> Reassigning -> hal

Why? This stuff works fine with gnome-mount. In the future please don't reassign
bugs without justifying.
Comment 7 Rex Dieter 2007-11-13 15:11:36 EST
Sorry, seemed like a regression on the surface, hal-0.5.9 works here, hal-0.5.10
does not. ??
Comment 8 Rex Dieter 2007-11-23 12:23:02 EST
Is this possibly related to bug #373061 ?
Comment 9 Sebastian Vahl 2007-11-27 06:50:17 EST
(In reply to comment #8)
> Is this possibly related to bug #373061 ?

Sounds like the the same behavior. 

I have no ability to understand the code lines here, but I've grepped the source
of hal-0.5.10 for this message and it seems to come from hal-storage-mount.c:

        if (pol_is_fixed) {
                if (pol_change_uid) {
                        action = NULL; /*
"hal-storage-mount-fixed-extra-options"; TODO: rethink */
                } else {
                        action = "org.freedesktop.hal.storage.mount-fixed";
                }
        } else {
                if (pol_change_uid) {
                        action = NULL; /*
"hal-storage-mount-removable-extra-options"; TODO: rethink "extra-options" */
                } else {
                        action = "org.freedesktop.hal.storage.mount-removable";
                }
        }
        if (action == NULL) {
                unknown_error ("TODO: have to rethink extra options");
        }


Comment 10 Rex Dieter 2007-11-27 07:52:41 EST
David, comment?
Comment 11 Kevin Kofler 2007-11-27 11:32:33 EST
Comment #9 shows that this is clearly a HAL regression (which GNOME happens not 
to trigger because it doesn't use the pol_change_uid feature), the error 
message comes from HAL and as per comment #7 it used to work.
Comment 12 Kevin Kofler 2007-11-27 11:33:21 EST
*** Bug 373061 has been marked as a duplicate of this bug. ***
Comment 13 Sebastian Vahl 2007-12-11 11:53:05 EST
any progress here?
Comment 14 Florian Sievert 2008-01-10 18:22:23 EST
Any news on the current state? This problem is really a showstopper for
non-technical users and it actually looks like the display messaged is caused by
the code of HAL that was posted in #9.
Comment 15 Kevin Kofler 2008-01-10 18:32:15 EST
I agree, we really need a solution for this problem, well, yesterday.
Comment 16 Sebastian Vahl 2008-01-18 17:29:56 EST
Ubuntu seems to have patched kdebase to fix this:
https://bugs.launchpad.net/ubuntu/+source/kdebase/+bug/178351

Would this be doable also with our packages? Or is it fixed in the wrong 
package (kdebase and not hal)?
Comment 17 Kevin Kofler 2008-01-19 00:57:30 EST
Looks like that might work, let's apply it then.
I still think HAL shouldn't be erroring out with a TODO message, but the 
kdebase fix should make it work.
Comment 18 Kevin Kofler 2008-01-19 01:49:34 EST
We'll have to look at KDE 4 too, a port of that patch might be needed there.
Comment 19 Kevin Kofler 2008-01-19 01:53:00 EST
Here's the patch Kubuntu is using, which also contains a workaround for bug 
428212:
http://patches.ubuntu.com/k/kdebase/extracted/kubuntu_9915_userdiskmount.diff
Comment 20 Kevin Kofler 2008-03-18 05:49:03 EDT
Looking at the HAL code, the Kubuntu patch is incomplete: "uid=" is banned for 
all file systems except vfat, iso9660, hfs and udf, not just for ntfs. The 
reason is that those file systems can carry native uids, so overriding the uid 
has security implications and the policy checks for that simply aren't 
implemented, so HAL just thrown an unhelpful "unknown error". IMHO this really 
ought to be fixed long term in HAL, but we have to patch KDE for now.
Comment 21 Kevin Kofler 2008-03-18 06:05:11 EDT
I've rolled a KDE 4 version of this workaround into the patch for bug 428212.
Comment 22 Kevin Kofler 2008-03-28 15:56:04 EDT
kdebase-3.5.9-7.fc8, which should fix this issue, has been pushed to the Fedora 
8 testing repository.  If problems still persist, please make note of it in 
this bug report.

If you want to test the update, you can install it with 
su -c 'yum --enablerepo=updates-testing update kdebase'.  You can provide 
feedback for this update here: 
http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2797
Comment 23 Kevin Kofler 2008-04-02 04:06:45 EDT
Has anybody tested this update yet?
Comment 24 Kevin Kofler 2008-04-02 23:43:23 EDT
Confirmed fixed, pushing to stable.
Comment 25 Fedora Update System 2008-04-09 01:16:20 EDT
kdebase-3.5.9-7.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.