Bug 37931 - rhn_register uses snack functions that dont exist in 6.2
Summary: rhn_register uses snack functions that dont exist in 6.2
Status: CLOSED DUPLICATE of bug 37913
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-26 21:58 UTC by Adrian Likins
Modified: 2015-01-07 23:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-26 21:58:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adrian Likins 2001-04-26 21:58:04 UTC
in the 1.3.2 version of rhn_register, tui.py makes use of
a construct like:

>>> foo = snack.Checkbox("boooo")
>>> foo.setValue("*")

around lines 420-440 or so...

snack.Checkbox.setValue however, doesnt exist in the snack
thats included with 6.2.

so it throws a tracbeack like:

[root@www /root]# rhn_register
Traceback (innermost last):
  File "/usr/sbin/rhn_register", line 119, in ?
    main()
  File "/usr/sbin/rhn_register", line 100, in main
    tui.main()
  File "/usr/share/rhn/register/tui.py", line 1033, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 982, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 422, in __init__
    self.emailContactButton.setValue("*")
AttributeError: setValue

Comment 1 Bill Nottingham 2001-04-27 01:20:21 UTC

*** This bug has been marked as a duplicate of 37913 ***


Note You need to log in before you can comment on or make changes to this bug.