Bug 37913 - rhn_register uses snack functions that dont exist in 6.2
Summary: rhn_register uses snack functions that dont exist in 6.2
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
: 37931 40932 42131 44457 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-26 21:04 UTC by Adrian Likins
Modified: 2015-01-07 23:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 21:36:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adrian Likins 2001-04-26 21:04:59 UTC
in the 1.3.2 version of rhn_register, tui.py makes use of
a construct like:

>>> foo = snack.Checkbox("boooo")
>>> foo.setValue("*")

around lines 420-440 or so...

snack.Checkbox.setValue however, doesnt exist in the snack
thats included with 6.2.

so it throws a tracbeack like:

[root@www /root]# rhn_register
Traceback (innermost last):
  File "/usr/sbin/rhn_register", line 119, in ?
    main()
  File "/usr/sbin/rhn_register", line 100, in main
    tui.main()
  File "/usr/share/rhn/register/tui.py", line 1033, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 982, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 422, in __init__
    self.emailContactButton.setValue("*")
AttributeError: setValue

Comment 1 Bill Nottingham 2001-04-27 01:20:16 UTC
*** Bug 37931 has been marked as a duplicate of this bug. ***

Comment 2 David M. Cook 2001-05-24 18:54:09 UTC
*** Bug 42131 has been marked as a duplicate of this bug. ***

Comment 3 Need Real Name 2001-05-24 23:42:48 UTC
upgrading to newt-0.50.22-2.i386.rpm from RedHat 7.1 gets me to the next screen, after pressing next again it fails with:

Traceback (innermost last):
  File "/usr/sbin/rhn_register", line 119, in ?
    main()
  File "/usr/sbin/rhn_register", line 100, in main
    tui.main()
  File "/usr/share/rhn/register/tui.py", line 1033, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 982, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 590, in __init__
    self.versionLabel2 = snack.Label(rhnreg.getVersion())
  File "/usr/share/rhn/register/rhnreg.py", line 121, in getVersion
    index = db.findbyprovides("redhat-release")[0]
IndexError: list index out of range

Comment 4 Adrian Likins 2001-07-06 04:04:06 UTC
The last error is caused by some rpm db transition issues. the correct fix
is to run:

		rpm --rebuilddb

And it should work fine

Comment 5 Adrian Likins 2001-07-06 04:05:17 UTC
*** Bug 44457 has been marked as a duplicate of this bug. ***

Comment 6 Adrian Likins 2001-07-06 04:07:29 UTC
*** Bug 40932 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.