This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 379421 - Java doesn't work in any web browser on FC8 with x86_64
Java doesn't work in any web browser on FC8 with x86_64
Status: CLOSED DUPLICATE of bug 334311
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
8
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 00:57 EST by sean.mcguffee
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 11:23:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
someone asked for /root/install.log (61.09 KB, text/plain)
2007-11-15 18:27 EST, sean.mcguffee
no flags Details

  None (edit)
Description sean.mcguffee 2007-11-13 00:57:15 EST
Description of problem:

There is no way to get java to open in web browsers. The best I could do was get
it to crash when it was supposed to open.

Version-Release number of selected component (if applicable):


How reproducible:

every time with every possible way of installing java.

Steps to Reproduce:
1. install java plugins any way possible
2. test java on webpage 
3.
  
Actual results:

crash (all web browser windows dissapear)

Expected results:

java to run

Additional info:

This is some peice of &$*#! that it doesn't even work as well as FC7. PATHETIC!
Comment 1 Bill C. Riemers 2007-11-15 11:17:31 EST
Try the following as root:

yum install java-1.7.0-icedtea-plugin
mozilla-plugin-config

Then restart your web browser.  This worked for me.

Obviously, the plugin package should be modified to run mozilla-plugin-config...


Comment 2 Bill C. Riemers 2007-11-15 11:21:57 EST
*** Bug 384641 has been marked as a duplicate of this bug. ***
Comment 3 petrosyan 2007-11-15 11:37:57 EST
Running "mozilla-plugin-config" fixed my problem but we should keep this bug
open until the plugin package is fixed.
Comment 4 Thomas Fitzsimmons 2007-11-15 12:50:13 EST
Please post /root/install.log.
Comment 5 petrosyan 2007-11-15 17:03:41 EST
I don't have /root/install.log
# ls /root/
anaconda-ks.cfg

So only 'anaconda-ks.cfg' file is available but no 'install.log'
Comment 6 sean.mcguffee 2007-11-15 18:22:12 EST
Hi,
I just tried 
yum install java-1.7.0-icedtea-plugin
mozilla-plugin-config
and then restarting my browser.
That didn't help me get java to work on either firefox or netscape.
By the way, my google toolbar still doesn't work for netscape.
I tried to install a recent update package for firefox and it wouldn't install.
I wonder if the reason it won't install is part of my problem?
This is the info about the update that won't work:
FEDORA-2007-2943
        Type  bugfix
      Status  stable
      Issued  2007-11-15 03:34:11
     Updated  
I get the following error message:
Missing Dependency: gecko-libs = 1.8.1.8 is needed by package yelp

Anyway, I'm still unable to use java on any browser in FC8 on my machine.

Comment 7 sean.mcguffee 2007-11-15 18:27:26 EST
Created attachment 260571 [details]
someone asked for /root/install.log

By the way, if anyone else wants to do this, they might need to run netscape
navigator as root. I couldn't send this as my usual screen name, as usual,
which is why I see no reason for non-root accounts, which is a whole other
issue.
Comment 8 petrosyan 2007-11-15 18:39:21 EST
I feel like bug 384641 was not a duplicate of this bug. In my case running
'mozilla-plugin-config' fixed the problem. Should bug 384641 be reopened as a
separate bug?
Comment 9 sean.mcguffee 2007-11-15 19:02:27 EST
Yeah, runing moxilla-plugin-config did not help my problem at all. By the way,
the updater finally worked, but I still have all the same problems with java and
the google toolbar's bookmarks not working. 
Comment 10 Zoltán Magyar 2007-11-18 12:37:14 EST
(In reply to comment #8)
> I feel like bug 384641 was not a duplicate of this bug. In my case running
> 'mozilla-plugin-config' fixed the problem. Should bug 384641 be reopened as a
> separate bug?

I reopened bug 384641
Comment 11 Lillian Angel 2007-11-19 15:54:52 EST
I have tested this on a clean F8-final install on x86_64.

- java-1.7.0-icedtea.x86_64 is installed by default
- java-1.7.0-icedtea-plugin.x86_64 is installed by default
- firefox.x86_64 and firefox.i386 are both installed by default
- running firefox.x86_64 -> about:plugins shows the gcjwebplugin installed
- testing various Java applets works as expected

I did not run any updates etc or /usr/bin/mozilla-plugin-config. The IcedTea
browser plugin worked out of the box. 

Can you give me detailed steps to reproduce the problem you are seeing? Were you
attempting to install Sun's Java plugin?
Comment 12 Lillian Angel 2007-11-20 13:23:42 EST
I tested this with the F8-Live installation. This is only a problem when F8 is
installed Live on x86_64. By default, the plugin is only linked to
/usr/lib64/mozilla/plugins, whereas it should be linked in
/usr/lib64/mozilla/plugins-wrapped as well. This is why running
mozilla-plugin-config fixes the problem.

I will fix this in rawhide.
Comment 13 Lillian Angel 2007-11-21 11:23:24 EST

*** This bug has been marked as a duplicate of 334311 ***

Note You need to log in before you can comment on or make changes to this bug.