Bug 384641 - Java plugin does not work
Java plugin does not work
Status: CLOSED DUPLICATE of bug 334311
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 09:27 EST by petrosyan
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 11:23:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petrosyan 2007-11-15 09:27:17 EST
Description of problem:
This is a freshly installed Fedora 8 with all updates installed.
java-1.7.0-icedtea-plugin and its dependencies.

typing about:plugins in Firefox does not show any Java plugins.

Version-Release number of selected component (if applicable):
java-1.7.0-icedtea-plugin-1.7.0.0-0.19.b21.snapshot.fc8

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 8, x86_64 and all its updates
2. Install java-1.7.0-icedtea-plugin
3. Start Firefox and type "about:plugins"
  
Actual results:
Java plugin is not found.

Expected results:
Java plugin should be found.
Comment 1 Bill C. Riemers 2007-11-15 11:21:56 EST

*** This bug has been marked as a duplicate of 379421 ***
Comment 2 Zoltán Magyar 2007-11-18 12:38:31 EST
Running 'mozilla-plugin-config' solved the problem.
Comment 3 Lillian Angel 2007-11-19 15:54:55 EST
I have tested this on a clean F8-final install on x86_64.

- java-1.7.0-icedtea.x86_64 is installed by default
- java-1.7.0-icedtea-plugin.x86_64 is installed by default
- firefox.x86_64 and firefox.i386 are both installed by default
- running firefox.x86_64 -> about:plugins shows the gcjwebplugin installed
- testing various Java applets works as expected

I did not run any updates etc or /usr/bin/mozilla-plugin-config. The IcedTea
browser plugin worked out of the box. 

Can you give me detailed steps to reproduce the problem you are seeing? Were you
attempting to install Sun's Java plugin?
Comment 4 petrosyan 2007-11-19 16:15:52 EST
Many people use LiveCD, LiveDVD or LiveUSB to install Fedora 8. So here are the
steps.

1. Install Fedora 8 for x86_64 from a LiveDVD on x86_64.
2. In case of any "Live" installation you cannot select or deselect any
packages. Java by default is NOT installed.
3. Install java-1.7.0-icedtea-plugin manually (yum install
java-1.7.0-icedtea-plugin).
4. Start Firefox. -> about:plugins shows NO Java plugins
5. close Firefox. run 'mozilla-plugin-config' and start Firefox again.
6. about:plugins shows the gcjwebplugin installed

PS.
Firefox fails to install java plugin or at least give a hint about how to
install it from a repository. Shouldn't this be a bug? Why is Firefox failing
and then sending you to Sun's website, when there is a working java plugin in
Fedora repositories?
Comment 5 Thomas Fitzsimmons 2007-11-19 16:23:39 EST
Try this instead:

yum install java-1.7.0-icedtea-plugin.x86_64
Comment 6 Thomas Fitzsimmons 2007-11-19 16:28:56 EST
I should explain: "yum install java-1.7.0-icedtea-plugin" installs the i386
version of java-1.7.0-icedtea-plugin (/usr/lib/mozilla/plugins/gcjwebplugin.so).
 mozilla-plugin-config wraps /usr/lib/mozilla/plugins/gcjwebplugin.so and makes
it available in /usr/lib64/mozilla/plugins/.

On x86_64, firefox.i386 and firefox.x86_64 are both installed, so
/usr/bin/firefox runs the 64-bit firefox binary, which reads from
/usr/lib64/mozilla/plugins/.  Meaning that, in order for /usr/bin/firefox to
find the plugin, either the mozilla-plugin-config-wrapped gcjwebplugin.so needs
to be there, or the java-1.7.0-icedtea-plugin.x86_64-provided gcjwebplugin.so
needs to be there.

This probably represents a bug in mash, since java-1.7.0-icedtea*.i386 shouldn't
be available to yum on an x86_64 installation.
Comment 7 Thomas Fitzsimmons 2007-11-19 16:31:18 EST
(In reply to comment #4)

> PS.
> Firefox fails to install java plugin or at least give a hint about how to
> install it from a repository. Shouldn't this be a bug? Why is Firefox failing
> and then sending you to Sun's website, when there is a working java plugin in
> Fedora repositories?

Good point, Firefox plugin finder/yum integration would be nice to have.  Can
you file that as a separate enhancement request under the Firefox component?
Comment 8 petrosyan 2007-11-19 18:53:25 EST
(In reply to comment #5)
> Try this instead:
> 
> yum install java-1.7.0-icedtea-plugin.x86_64
> 

yum install java-1.7.0-icedtea-plugin
actually installs java-1.7.0-icedtea-plugin.x86_64, and that's what I have been
using all along.
Comment 9 Lillian Angel 2007-11-20 10:10:47 EST
I have tested this after a full "yum update" and still everything works. 

I will need to test this with a liveCD installation.
Comment 10 Lillian Angel 2007-11-20 13:23:51 EST
I tested this with the F8-Live installation. This is only a problem when F8 is
installed Live on x86_64. By default, the plugin is only linked to
/usr/lib64/mozilla/plugins, whereas it should be linked in
/usr/lib64/mozilla/plugins-wrapped as well. This is why running
mozilla-plugin-config fixes the problem.

I will fix this in rawhide.
Comment 11 Lillian Angel 2007-11-21 11:23:14 EST

*** This bug has been marked as a duplicate of 334311 ***

Note You need to log in before you can comment on or make changes to this bug.