Bug 37954 - System crashes hard on Gnome X logoff
Summary: System crashes hard on Gnome X logoff
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-27 02:37 UTC by mmoneta
Modified: 2007-04-18 16:32 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-04-30 08:47:20 UTC


Attachments (Terms of Use)

Description mmoneta 2001-04-27 02:37:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win98; U)


Frequently (about 50% of the time) when I log out of my X session, the entire system crashes hard (no message, no keyboard response, 
remote access down).  No messages in logs.  Using XFree86-I128.  Manual fsck needed frequently to recover.

Reproducible: Sometimes
Steps to Reproduce:
1.Login
2.Logout
3.There is no step 3... :-)
	

Actual Results:  Logoff appears to proceed normally, screen goes blank, never recovers.  Hard reset required.

Expected Results:  Login window redisplayed.

Tried updating XFree86 to latest version 4.0.3-9, no change.  X was working perfectly in 7.0 with bug 18372 changes.  Also have latest Ximian 
Gnome installed.

Comment 1 mmoneta 2001-04-28 22:10:21 UTC
I gave up and switched to an ATI All-In-Wonder Rage 128/32MB card.  Problem solved.

Comment 2 Mike A. Harris 2001-04-30 08:47:15 UTC
XFree86-I128 is XFree86 3.3.6 - you should run XFree86 4.0.3 by invoking
Xconfigurator --preferxf4 and it should work ok.  The XFree86-I128 server
from 3.3.6 shouldn't even be in the distro anymore because 4.x works better
on these cards.

Can you try the i128 card with 4.0.3 with the above Xconfigurator invocation
and let me know if it works for you now?


Note You need to log in before you can comment on or make changes to this bug.