Bug 379821 - Pakcage Manager - Pirut can't to be opened - ERROR MSG
Pakcage Manager - Pirut can't to be opened - ERROR MSG
Status: CLOSED DUPLICATE of bug 381551
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 07:40 EST by Eduardo Cerqueira
Modified: 2007-12-08 11:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 11:18:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error message by Pirut on retriving update process (1.36 KB, application/octet-stream)
2007-11-13 07:40 EST, Eduardo Cerqueira
no flags Details

  None (edit)
Description Eduardo Cerqueira 2007-11-13 07:40:49 EST
Description of problem:
Package Manager can't to be opened, after the retrieving Updates message box I
got a ERROR msg box, details and the message error are in attached file.


Version-Release number of selected component (if applicable):


How reproducible: on KDE click on KMenu - System - Add/Remove Software


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Eduardo Cerqueira 2007-11-13 07:40:49 EST
Created attachment 256801 [details]
Error message by Pirut on retriving update process
Comment 2 Jeremy Katz 2007-11-13 08:48:39 EST
What's the output of rpm -q yum and rpm -V yum?
Comment 3 enterbug 2007-11-17 04:57:19 EST
Got the same problem when, after a fresh install of Fedora 8, I tried the 
package manager in applications menu in Gnome.

"yum update" works ok.
I had to hand-install, among others, kde: no mean feat for an amateur, with rpm 
and the help of http://fr2.rpmfind.net/linux/RPM/ (I wouldn't know of any other 
way to find not-installed packages which provide the necessary dependencies; 
tip anyone?).

I don't know how I missed installing kde during the installation. If it was 
meant to be that way by anaconda, or whatever, to not give the opportunity to 
have kde instead of that terrible gnome desktop (sorry, again confirmed this 
time), I am shocked, dear Fedora/Red Hat. Apart from the several great gnome 
programs I happily use. And all the rest, of course, great fun the last 9 years 
with Red Hat/Fedora.

And then in kde the same as above with "add/remove software", with exactly the 
same debug-file I had in gnome.

Output rpm -q yum: yum-3.2.7-1.fc8

Output rpm -V yum: S.5....T c /etc/yum.conf (consciously changed)

I did "yum clean all" somewhere along the way

Debug file:
Component: pirut
Summary: TBd43f5314 misc.py:306:newestInList:AttributeError: 'tuple' object has 
no attribute 'EVR'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 476, in <module>
    main()
  File "/usr/sbin/pirut", line 472, in main
    pm.run()
  File "/usr/sbin/pirut", line 405, in run
    self._showBrowse()
  File "/usr/sbin/pirut", line 317, in _showBrowse
    grpsel.doRefresh()
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 514, in 
doRefresh
    self._setupCatchallCategory()
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 491, in 
_setupCatchallCategory
    if g.user_visible and _groupHasPackages(g, self.ayum):
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 140, in 
_groupHasPackages
    pkgs = ayum.rpmdb.returnNewestByName(p)
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 196, in 
returnNewestByName
    return misc.newestInList(allpkg)
  File "/usr/lib/python2.5/site-packages/yum/misc.py", line 306, in newestInList
    if pkg.EVR > newest.EVR:
AttributeError: 'tuple' object has no attribute 'EVR'

Local variables in innermost frame:
newest: ('ghostscript', 'i386', '0', '8.60', '5.fc8')
pkg: ('ghostscript', 'x86_64', '0', '8.60', '5.fc8')
ret: [('ghostscript', 'i386', '0', '8.60', '5.fc8')]
pkgs: [('ghostscript', 'x86_64', '0', '8.60', '5.fc8')]

(Apart my frustration whenever I encounter the gnome-desktop, many thanks to 
all of you with "Fedora/Red Hat" for the now 9 years of great fun.)
Comment 4 Jeremy Katz 2007-11-19 11:18:31 EST

*** This bug has been marked as a duplicate of 381551 ***
Comment 5 enterbug 2007-12-08 11:13:22 EST
After a yum update today of (amongst many others) pirut to pirut -
1.3.28-1.fc8.noarch, I tried the package manager with success.
At least, pirut refrained from protesting. ;-)

Thanks,
Jan Schabbink



Note You need to log in before you can comment on or make changes to this bug.