Bug 380121 - Eclipse help broken on Developer spin.
Eclipse help broken on Developer spin.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
: 395331 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 10:13 EST by Mark Wielaard
Modified: 2008-02-18 22:12 EST (History)
6 users (show)

See Also:
Fixed In Version: 3.3.0-31.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 22:12:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Wielaard 2007-11-13 10:13:04 EST
Description of problem:

The eclipse help system is broken on the Fedora 8 Developer LiveCD (but seems to
work fine in the actual Fedora 8 release).

Version-Release number of selected component (if applicable):

eclipse-platform-3.3.0-30.fc8

How reproducible:

Always.

Steps to Reproduce:
1. Boot Developer spin.
2. Start eclipse
2. Click on overview
3. Click on Workbench basics
  
Actual results:

Error screen saying:

HTTP ERROR: 500

Class org.apache.jasper.servlet.JspServlet does not implement the requested
interface javax.servlet.Servlet

RequestURI=/help/index.jsp

Expected results:

The help screen.

Additional info:

Running with -consoleLog -verbose -debug gives:

[INFO] HttpServer - Version Jetty/5.1.x
[INFO] Container - Started org.mortbay.jetty.servlet.ServletHandler@13dff89
[INFO] Container - Started HttpContext[/help,/help]
[INFO] SocketListener - Started SocketListener on 0.0.0.0:59213
[INFO] Container - Started org.mortbay.http.HttpServer@6d70fc
[WARN] ServletHandler - Error for
/help/index.jsp?topic=%2Forg.eclipse.platform.doc.user%2FgettingStarted%2Fintro%2Foverview.htm
<java.lang.IncompatibleClassChangeError: Class
org.apache.jasper.servlet.JspServlet does not implement the requested interface
javax.servlet.Servlet>java.lang.IncompatibleClassChangeError: Class
org.apache.jasper.servlet.JspServlet does not implement the requested interface
javax.servlet.Servlet
        at org.eclipse.equinox.jsp.jasper.JspServlet.init(JspServlet.java:81)
        at
org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.initializeDelegate(ServletManager.java:195)
        at
org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.service(ServletManager.java:179)
        at
org.eclipse.equinox.http.servlet.internal.ServletRegistration.handleRequest(ServletRegistration.java:90)
        at
org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:109)
        at
org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:75)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at
org.eclipse.equinox.http.jetty.internal.HttpServerManager$InternalHttpServiceServlet.service(HttpServerManager.java:280)
        at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:428)
        at
org.mortbay.jetty.servlet.ServletHandler.dispatch(ServletHandler.java:677)
        at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:568)
        at org.mortbay.http.HttpContext.handle(HttpContext.java:1530)
        at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)
        at org.mortbay.http.HttpServer.service(HttpServer.java:909)
        at org.mortbay.http.HttpConnection.service(HttpConnection.java:820)
        at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:986)
        at org.mortbay.http.HttpConnection.handle(HttpConnection.java:837)
        at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:245)
        at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:357)
        at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)
Comment 1 Kahlil Hodgson 2007-11-20 16:06:12 EST
I'm getting what looks like the same problem on both an upgrade and a fresh
install of fedora 8.  Perhaps related to jetty bug #393071.
Comment 2 Andrew Overholt 2007-11-20 16:33:55 EST
I'm actually pretty confident that I've tracked this down to an issue with the
tomcat plugin.  I've got it working locally but I'm trying to get ppc64 to build
and now am running into other issues there.  I hope to be finished with it soon.
Comment 3 Andrew Overholt 2007-11-22 13:10:03 EST
*** Bug 395331 has been marked as a duplicate of this bug. ***
Comment 4 Geert Jansen 2007-11-24 04:00:10 EST
I am experiencing the same problem on the Fedora 8 release as well (not the
developer live CD). My system has a clean fedora 8 install, freshly installed
from the release DVD. The way to reproduce and the error is exactly the same as
the original reporter.
Comment 5 Mario Torre 2007-12-04 10:25:50 EST
I'm also having some problem in using the help feature.

When trying to access the API (All Topics->Programmer's guide->Reference->API
Reference) this is what I get:

------ cut ------

An error occured while processing the requested document:

org.xml.sax.SAXParseException: The element type "br" must be terminated by the
matching end-tag "</br>".
	at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.java:239)
	at
com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(DocumentBuilderImpl.java:283)
	at org.eclipse.help.internal.dynamic.DocumentReader.read(DocumentReader.java:56)
	at org.eclipse.help.internal.dynamic.XMLProcessor.process(XMLProcessor.java:49)
	at
org.eclipse.help.internal.xhtml.DynamicXHTMLProcessor.process(DynamicXHTMLProcessor.java:66)
	at
org.eclipse.help.internal.webapp.servlet.DynamicXHTMLFilter$1.close(DynamicXHTMLFilter.java:79)
	at java.io.FilterOutputStream.close(FilterOutputStream.java:143)
	at
org.eclipse.help.internal.webapp.servlet.FilterHTMLHeadAndBodyOutputStream.close(FilterHTMLHeadAndBodyOutputStream.java:290)
	at
org.eclipse.help.internal.webapp.servlet.EclipseConnector.transfer(EclipseConnector.java:150)
	at
org.eclipse.help.internal.webapp.servlet.ContentServlet.doGet(ContentServlet.java:42)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
	at
org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.service(ServletManager.java:180)
	at
org.eclipse.equinox.http.servlet.internal.ServletRegistration.handleRequest(ServletRegistration.java:90)
	at
org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:109)
	at
org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:67)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
	at
org.eclipse.equinox.http.jetty.internal.HttpServerManager$InternalHttpServiceServlet.service(HttpServerManager.java:280)
	at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:428)
	at org.mortbay.jetty.servlet.ServletHandler.dispatch(ServletHandler.java:677)
	at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:568)
	at org.mortbay.http.HttpContext.handle(HttpContext.java:1530)
	at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)
	at org.mortbay.http.HttpServer.service(HttpServer.java:909)
	at org.mortbay.http.HttpConnection.service(HttpConnection.java:820)
	at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:986)
	at org.mortbay.http.HttpConnection.handle(HttpConnection.java:837)
	at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:245)
	at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:357)
	at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

--------- cut ---------

I don't know if it's related or I should file a new bug report?

Thanks,
Mario
Comment 6 Andrew Overholt 2007-12-04 10:33:33 EST
(In reply to comment #5)
> I don't know if it's related or I should file a new bug report?

Please file a new bug.  Thanks.
Comment 7 Fedora Update System 2007-12-07 16:31:29 EST
icu4j-3.6.1-1jpp.5.fc8, eclipse-3.3.1.1-13.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update icu4j eclipse'
Comment 8 Geert Jansen 2007-12-09 03:55:20 EST
I have tested version 3.3.1.1-13.fc8 and the help system works now. Two comments:

 - I had to update "eclipse-platform" not "eclipse" because the latter package
did not exist.
 - I now get a NullPointerException when I start up Eclipse. I think this is
related to the update, but I am not sure. In the mean time I also installed Sun
Java, and while i believe Eclipse is not using that, i cannot guarantee there
are no interactions. I get a back trace in the "Task List" window, which is:

ava.lang.NullPointerException
	at
org.eclipse.mylyn.internal.tasks.ui.views.AbstractFilteredTree.textChanged(AbstractFilteredTree.java:175)
	at org.eclipse.ui.dialogs.FilteredTree.setInitialText(FilteredTree.java:705)
	at
org.eclipse.mylyn.internal.tasks.ui.views.AbstractFilteredTree.<init>(AbstractFilteredTree.java:66)
	at
org.eclipse.mylyn.internal.tasks.ui.views.TaskListFilteredTree.<init>(TaskListFilteredTree.java:96)
	at
org.eclipse.mylyn.internal.tasks.ui.views.TaskListView.createPartControl(TaskListView.java:751)
	at org.eclipse.ui.internal.ViewReference.createPartHelper(ViewReference.java:370)
	at org.eclipse.ui.internal.ViewReference.createPart(ViewReference.java:227)
	at
org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:592)
	at
org.eclipse.ui.internal.WorkbenchPage$ActivationList.setActive(WorkbenchPage.java:4080)
	at
org.eclipse.ui.internal.WorkbenchPage$17.runWithException(WorkbenchPage.java:3145)
	at
org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)
	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3296)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2974)
	at
org.eclipse.ui.application.WorkbenchAdvisor.openWindows(WorkbenchAdvisor.java:801)
	at org.eclipse.ui.internal.Workbench$23.runWithException(Workbench.java:1342)
	at
org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)
	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3296)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2974)
	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2309)
	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2219)
	at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:466)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:289)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:461)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
	at
org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:106)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)
	at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:106)
	at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:76)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:363)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:623)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1173)

Please let me know if you want me to file another bug.
Comment 9 Kahlil Hodgson 2007-12-10 15:19:18 EST
(In reply to comment #7)
> icu4j-3.6.1-1jpp.5.fc8, eclipse-3.3.1.1-13.fc8 has been pushed to the Fedora 8
testing repository.  If problems still persist, please make note of it in this
bug report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update icu4j eclipse'

Installed the following from updates-testing this morning:

icu4j - 3.6.1-1jpp.5.fc8.i386
icu4j-eclipse - 3.6.1-1jpp.5.fc8.i386
libswt3-gtk2 - 1:3.3.1.1-13.fc8.i386
eclipse-rcp - 1:3.3.1.1-13.fc8.i386
eclipse-cvs-client - 1:3.3.1.1-13.fc8.i386
eclipse-platform - 1:3.3.1.1-13.fc8.i386
eclipse-pde-runtime - 1:3.3.1.1-13.fc8.i386
eclipse-ecj - 1:3.3.1.1-13.fc8.i386
eclipse-jdt - 1:3.3.1.1-13.fc8.i386
eclipse-pde - 1:3.3.1.1-13.fc8.i386

(148M later) This fixes the problem for me :-)
Comment 10 Fedora Update System 2007-12-21 16:08:12 EST
eclipse-3.3.0-31.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eclipse'
Comment 11 Ricky Ng-Adam 2007-12-28 14:34:04 EST
[rngadam@localhost ~]$ su -c 'yum --enablerepo=updates-testing update eclipse'
Password: 
Loading "priorities" plugin
124 packages excluded due to repository priority protections
Setting up Update Process
Could not find update match for eclipse
No Packages marked for Update
Comment 12 Andrew Overholt 2007-12-30 16:16:21 EST
eclipse isn't the binary rpm name.  Try eclipse-platform or eclipse-jdt.
Comment 13 Ricky Ng-Adam 2007-12-31 00:50:29 EST
Ah, sorry, I was just blindly trying comment #10...

[rngadam@localhost ~]$ su -c 'yum --enablerepo=updates-testing update eclipse-jdt'
[...]
Updating:
 eclipse-cvs-client      i386       1:3.3.0-31.fc8   updates-testing   3.4 M
 eclipse-ecj             i386       1:3.3.0-31.fc8   updates-testing   7.4 M
 eclipse-jdt             i386       1:3.3.0-31.fc8   updates-testing    26 M
 eclipse-pde-runtime     i386       1:3.3.0-31.fc8   updates-testing   237 k
 eclipse-platform        i386       1:3.3.0-31.fc8   updates-testing    29 M
 eclipse-rcp             i386       1:3.3.0-31.fc8   updates-testing    11 M
 libswt3-gtk2            i386       1:3.3.0-31.fc8   updates-testing   3.3 M
Updating for dependencies:
 eclipse-pde             i386       1:3.3.0-31.fc8   updates-testing    56 M

...help works! I can click on all help option and I do not get the error.

Comment 14 Andrew Overholt 2008-01-02 10:14:21 EST
(In reply to comment #13)
> ...help works! I can click on all help option and I do not get the error.

Great!  If you did not find any problems with the update (and didn't have to run
with -clean or move your .eclipse directory out of the way), can you add +1 to
the karma of the update?

Anyone else having success with this potential update?
Comment 15 Ricky Ng-Adam 2008-01-02 14:14:37 EST
Ah, didn't know we had an updates rating system now... But why doesn't the
"Fedora Update System" update the bug with a link to the rating form? 

Had to search for it:

https://admin.fedoraproject.org/updates/F8/FEDORA-2007-4684

Cool idea!
Comment 16 Fedora Update System 2008-02-18 22:12:32 EST
eclipse-3.3.0-31.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.