Bug 395331 - Can't view docs via Overview page
Can't view docs via Overview page
Status: CLOSED DUPLICATE of bug 380121
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 03:16 EST by Kahlil Hodgson
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-22 13:10:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kahlil Hodgson 2007-11-22 03:16:17 EST
Description of problem:

Attempting to view docs via Overview returns a (jetty) error page using both
internal and external viewers.  I've google an others have had similar 
problems but no solutions have been presented.

Version-Release number of selected component (if applicable):

eclipse-cdt-4.0.1-1.fc8.i386
eclipse-changelog-2.5.1-2.fc8.i386
eclipse-cvs-client-3.3.0-30.fc8.i386
eclipse-ecj-3.3.0-30.fc8.i386
eclipse-jdt-3.3.0-30.fc8.i386
eclipse-mylyn-2.0.0-9.fc8.i386
eclipse-mylyn-bugzilla-2.0.0-9.fc8.i386
eclipse-mylyn-ide-2.0.0-9.fc8.i386
eclipse-mylyn-java-2.0.0-9.fc8.i386
eclipse-pde-3.3.0-30.fc8.i386
eclipse-pde-runtime-3.3.0-30.fc8.i386
eclipse-platform-3.3.0-30.fc8.i386
eclipse-pydev-1.3.9-1.fc8.i386
eclipse-rcp-3.3.0-30.fc8.i386
eclipse-rpm-editor-0.1.0-10.fc8.i386
eclipse-subclipse-1.2.4-5.fc8.i386
icu4j-eclipse-3.6.1-1jpp.3.fc8.i386
tomcat5-jasper-eclipse-5.5.25-1jpp.1.fc8.i386
jetty-5.1.12-1jpp.8.fc8.i386 (minor bugfix from updates-testing)

How reproducible:

Try to use the documentation from the welcome page :-(

Steps to Reproduce:
1. Start eclipse for the first time as a new user
2. When the welcome page is presented, select 'Workbench Basics' 
  
Actual results:

I get a pop up window with the following error:

HTTP ERROR: 500
Internal Server Error
RequestURI=/help/index.jsp
Powered by Jetty://

Expected results:

The Workbench Basics page that is presented on the eclipse website.

Additional info:

I've never used eclipse before an I thought I'd give it a spin with F8.
Despite the above problem, I have been sufficiently motivated to learn how to
use it via the website, and I think it could prove to be a very useful for my
development team (great stuff guys!).  Okay more info:

I initially did an upgrade to F8 and experienced this problem.  Upgrades are not
supported so I did some mucking around with LVM and got a dual boot going with a
fresh F8 install.  Still no dice.  Tried creating a new user and running eclipse
(I think I may have had a ~/.eclipse dir lying around from F7).  Still no dice.
No correlation with anything in _all_ log file. I _am_ running SELinux but have
had no indications from logs or SE Troubleshooter  that this a problem.

Don't really know where to go from here, but am prepared to do more digging with
further advice.

Cheers!

Kal
Comment 1 Kahlil Hodgson 2007-11-22 04:15:15 EST
Also console give:

<kal@antubis:~> eclipse 
[INFO] HttpServer - Version Jetty/5.1.x
[INFO] Container - Started org.mortbay.jetty.servlet.ServletHandler@59dbd
[INFO] Container - Started HttpContext[/help,/help]
[INFO] SocketListener - Started SocketListener on 0.0.0.0:62841
[INFO] Container - Started org.mortbay.http.HttpServer@1c8c58
[WARN] ServletHandler - Error for
/help/index.jsp?topic=%2Forg.eclipse.platform.doc.user%2FgettingStarted%2Fintro%2Foverview.htm
<java.lang.IncompatibleClassChangeError>java.lang.IncompatibleClassChangeError
        at org.eclipse.equinox.jsp.jasper.JspServlet.init(JspServlet.java:81)
        at
org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.initializeDelegate(ServletManager.java:195)
        at
org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.service(ServletManager.java:179)
        at
org.eclipse.equinox.http.servlet.internal.ServletRegistration.handleRequest(ServletRegistration.java:90)
        at
org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:109)
        at
org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:75)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at
org.eclipse.equinox.http.jetty.internal.HttpServerManager$InternalHttpServiceServlet.service(HttpServerManager.java:280)
        at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:428)
        at
org.mortbay.jetty.servlet.ServletHandler.dispatch(ServletHandler.java:677)
        at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:568)
        at org.mortbay.http.HttpContext.handle(HttpContext.java:1530)
        at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)
        at org.mortbay.http.HttpServer.service(HttpServer.java:909)
        at org.mortbay.http.HttpConnection.service(HttpConnection.java:820)
        at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:986)
        at org.mortbay.http.HttpConnection.handle(HttpConnection.java:837)
        at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:245)
        at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:357)
        at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)



Comment 2 Andrew Overholt 2007-11-22 09:19:39 EST
This is the same as the other "Help is broken on the developer live image" bug.
 I've fixed it (the tomcat patches needed updating) and it will come up with the
forthcoming 3.3.1.1 update (as soon as I get ppc64 straightened out).
Comment 3 Andrew Overholt 2007-11-22 13:10:02 EST

*** This bug has been marked as a duplicate of 380121 ***

Note You need to log in before you can comment on or make changes to this bug.