Bug 380871 - Review Request: libgnomedbmm - C++ interface for libgnomedb
Review Request: libgnomedbmm - C++ interface for libgnomedb
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 15:11 EST by Denis Leroy
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 12:02:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Denis Leroy 2007-11-13 15:11:26 EST
Spec URL: http://www.poolshark.org/src/libgnomedbmm.spec
SRPM URL: http://www.poolshark.org/src/libgnomedbmm-2.9.5-1.fc8.src.rpm

Description: 

This package provides a C++ interface for libgnomedb. It is a
subpackage of the gtkmm project.
Comment 1 Parag AN(पराग) 2007-11-14 01:52:17 EST
missing
- MUST: Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig' (for
directory ownership and usability).
Comment 2 Parag AN(पराग) 2007-11-14 01:57:49 EST
also,
2) We don't provide static libraries so remove
%{?_with_static: %{_libdir}/*.a}
and also change Description of -devel removing static word.
 check
http://fedoraproject.org/wiki/Packaging/Guidelines#head-2302ec1e1f44202c9cc4bcce24cb711266557ad7

3)If you really need them then follow
- MUST: Static libraries must be in a -static
package.http://fedoraproject.org/wiki/Packaging/Guidelines#head-ed9c4b45be77361033ccbc199bb3d49d02283ba9


Comment 3 Denis Leroy 2007-11-14 11:32:23 EST
http://www.poolshark.org/src/libgnomedbmm.spec
http://www.poolshark.org/src/libgnomedbmm-2.9.5-2.fc8.src.rpm

Fixed the pkgconfig R, thanks. I'm aware of the guidelines, the spec file
doesn't ship the static library by default. To add it, one would have to compile
with 'rpmbuild --with static'. The reason the option exists in the gtkmm spec
files is simply because over times I've received numerous requests from C++
developers for that option, so that those who wish can recompile the .src.rpm
with it. That's all.
Comment 4 Parag AN(पराग) 2007-11-14 23:07:58 EST
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM and for RPM.
+ source files match upstream url
26b43d48b872f250e96ee6937bdee5a1  libgnomedbmm-2.9.5.tar.bz2
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ BuildRequires are proper.
+ Compiler flags used correctly.
+ defattr usage is correct.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no static libraries.
+ libgnomedbmm-3.0.pcfile present.
+ -devel subpackage exists.
+ no .la files.
+ no translations are available.
+ Does owns the directories it creates.
+ ldconfig scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Package libgnomedbmm-2.9.5-2.fc9 ->
  Provides: libgnomedbmm-3.0.so.1
  Requires: libart_lgpl_2.so.2 libatk-1.0.so.0 libatkmm-1.6.so.1 libc.so.6
libc.so.6(GLIBC_2.1.3) libcairo.so.2 libcairomm-1.0.so.1 libdl.so.2
libgcc_s.so.1 libgcc_s.so.1(GCC_3.0) libgda-3.0.so.3 libgda-report-3.0.so.3
libgdamm-3.0.so.8 libgdasql-3.0.so.3 libgdk-x11-2.0.so.0 libgdk_pixbuf-2.0.so.0
libgdkmm-2.4.so.1 libglade-2.0.so.0 libglib-2.0.so.0 libglibmm-2.4.so.1
libgmodule-2.0.so.0 libgnomecanvas-2.so.0 libgnomedb-3.0.so.4
libgnomedb_extra-3.0.so.4 libgnomedb_graph-3.0.so.4 libgnomedbmm-3.0.so.1
libgobject-2.0.so.0 libgthread-2.0.so.0 libgtk-x11-2.0.so.0 libgtkmm-2.4.so.1
libm.so.6 libpango-1.0.so.0 libpangocairo-1.0.so.0 libpangomm-1.4.so.1
librt.so.1 libsigc-2.0.so.0 libstdc++.so.6 libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(GLIBCXX_3.4) libxml2.so.2 rtld(GNU_HASH)
+ Package libgnomedbmm-devel-2.9.5-2.fc9 ->
  Requires: gtkmm24-devel libgdamm-devel libgnomedb-devel libgnomedbmm =
2.9.5-2.fc9 libgnomedbmm-3.0.so.1 pkgconfig
+ Not a GUI App.
APPROVED.
Comment 5 Denis Leroy 2007-11-19 06:04:43 EST
New Package CVS Request
=======================
Package Name: libgnomedbmm
Short Description: C++ interface for libgnomedb
Owners: denis
Branches: F-8
InitialCC: 
Cvsextras Commits: yes
Comment 6 Kevin Fenzi 2007-11-19 11:37:02 EST
cvs done.
Comment 7 Denis Leroy 2007-11-21 12:02:28 EST
Thanks for the review.

Note You need to log in before you can comment on or make changes to this bug.