Bug 38095 - db2html creates extra TOC entries
db2html creates extra TOC entries
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: docbook-style-dsssl (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
: 35033 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 11:06 EDT by Tammy Fox
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-21 05:57:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tammy Fox 2001-04-27 11:06:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-7.0.1 i686)


If a variablelist, itemizedlist, or orderedlist is not declared
with a set of para tags, db2html thinks it is a section and tries to
add it to the TOC. It does not have a title, so it adds a number that 
consists of the chapter number followed by a 1 for the first instance of
this, 2 for the second instance, etc.

Reproducible: Always
Steps to Reproduce:
1.Create a SGML file that contains a variablelist, orderedlist, or itemized
list outside of any para tags.
2.Run db2html on it.
3.Look at the TOC.
	

Actual Results:  There are extra entries in the TOC that are just numbers.

Expected Results:  Lists should not be seen as sections.
Comment 1 Tim Waugh 2001-05-01 16:28:03 EDT
*** Bug 35033 has been marked as a duplicate of this bug. ***
Comment 2 Tim Waugh 2001-05-02 08:10:29 EDT
Fixed in docbook-style-dsssl-1.64-1.

Note You need to log in before you can comment on or make changes to this bug.