Bug 381011 - /etc/init.d/kadmin: line 35: [: too many arguments
/etc/init.d/kadmin: line 35: [: too many arguments
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: krb5 (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
: 373011 (view as bug list)
Depends On: 252322
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 16:26 EST by Brad Hinson
Modified: 2016-01-22 12:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0381
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:28:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brad Hinson 2007-11-13 16:26:42 EST
+++ This bug was initially created as a clone of Bug #252322 +++

Description of problem:
I tried started kadmin and script prints
/etc/init.d/kadmin: line 35: [: too many arguments

Version-Release number of selected component (if applicable):
rpm -q krb5-server
krb5-server-1.6.1-2.1.fc7

How reproducible:
always

Steps to Reproduce:
1. delete /var/kerberos/krb5kdc/principal file
2. try start kadmin
  
Actual results:
script failure

Expected results:
script prints why kadmin can't start

-- Additional comment from atkac@redhat.com on 2007-08-15 08:32 EST --
Created an attachment (id=161349)
simple patch
Comment 1 RHEL Product and Program Management 2007-11-13 16:34:49 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Nalin Dahyabhai 2007-11-13 16:40:41 EST
*** Bug 373011 has been marked as a duplicate of this bug. ***
Comment 5 Issue Tracker 2007-12-13 09:00:41 EST
----- Additional Comments From nasastry@in.ibm.com  2007-12-12 23:00 EDT
-------
Installed the packages from krb5.tar.gz and I am not seeing the error
"too many
arguments". Please find the test results.

[root@india3 krb5]# service kadmin start
Error. Default principal database does not exist.
* I didn't change the default configuration file so above error
expected.

# rpm -qa | grep ^krb5
krb5-debuginfo-1.6.1-19.el5
krb5-libs-1.6.1-19.el5
krb5-workstation-1.6.1-19.el5
krb5-devel-1.6.1-19.el5
krb5-auth-dialog-0.7-1
krb5-server-1.6.1-19.el5

Thanks!! 


This event sent from IssueTracker by jkachuck 
 issue 137987
Comment 8 errata-xmlrpc 2008-05-21 11:28:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0381.html

Note You need to log in before you can comment on or make changes to this bug.