Bug 38192 - TypeError: cannot marshal recursive data structures
Summary: TypeError: cannot marshal recursive data structures
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
: 38268 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-28 10:34 UTC by Arjan van de Ven
Modified: 2015-01-07 23:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-11 21:16:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arjan van de Ven 2001-04-28 10:34:43 UTC
#rpm -qa | grep up2date
up2date-2.5.4-1
up2date-gnome-2.5.4-1

#up2date exim

Testing package set / solving RPM inter-dependencies...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 831, in ?
    main()
  File "/usr/sbin/up2date", line 806, in main
    sys.exit(batchRun(onlyList, pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 534, in batchRun
    (depPackages, conflicts) = up2date.dryRun(selPkgList, printCallback,
percentCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 2085, in dryRun
    ret = depsolve.solvedep()
  File "/usr/share/rhn/up2date/up2date.py", line 2051, in solvedep
    ret = self.process_deps(deps)
  File "/usr/share/rhn/up2date/up2date.py", line 2021, in process_deps
    changed = changed + self.__conflicts(conflicts)
  File "/usr/share/rhn/up2date/up2date.py", line 1973, in __conflicts
    added = self.__add(solved, check = 1)
  File "/usr/share/rhn/up2date/up2date.py", line 1885, in __add
    h_list = getHeaders(plist, refreshCallback = self.refreshCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 832, in getHeaders
    ret = s.up2date.header(getSystemId(), listToFetch)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 608, in
__call__
    return self.__send(self.__name, args)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 644, in
__request
    request = dumps(params, methodname)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 482, in dumps
    data = m.dumps(params)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 251, in dumps
    self.__dump(v)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 264, in __dump
    f(self, value)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 290, in
dump_array
    self.__dump(v)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 264, in __dump
    f(self, value)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 286, in
dump_array
    self.container(value)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 282, in
container
    raise TypeError, "cannot marshal recursive data structures"
TypeError: cannot marshal recursive data structures

Comment 1 Need Real Name 2001-10-24 17:36:34 UTC
Me too!!!

Comment 2 Adrian Likins 2002-02-11 21:15:59 UTC
Should be fixed in current versions. 

A bug in xmlrpclib combined with some server side issues.

Comment 3 David M. Cook 2002-03-11 18:42:46 UTC
*** Bug 38268 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.