Bug 381951 - start-order for services makes me crazy
start-order for services makes me crazy
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
: 381981 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 04:30 EST by Reindl Harald
Modified: 2014-03-16 23:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 12:04:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reindl Harald 2007-11-14 04:30:11 EST
Hi

Since F8 some services arte started in the wrong order!
Channgin the chkconfig-Lines in the initscripts and disable/enable them does not
solve becaue for messagebus in the initscripts is the order "22", but the
symlink unter "/etc/rc5.d/S30messagebus" in this case is strange.

The follwoing services must be in this order and no other 
because of dependencies 

why "named" in F8 does not forwarding requests if he is stared after network is
another problem, but it comes with the order-problem - yesterday i renamed the
fucking symlink to S33named, today it has S30named again, no one has stared
"systen-config-services" between this change...

messagebus
network
wpa_supplicant
named

If you use WPA-WLAN and BIND no other start-order will work without restarting
named or wpa_supplicant manually after login!

Please fix this
Comment 1 Bill Nottingham 2007-11-14 12:04:10 EST
network provides $network. It starts at 10.

netfs provides $local_fs and $remote_fs. It starts at 25.
rsyslog provides $syslog, and requires $remote_fs, $local_fs. It would then
start at 26.

messagebus requires $syslog and $local_fs. It then must start at 27 or later.
named requires $local_fs, $network, and $syslog. It then must start at 27 or later.

I'm not seeing anything specifically wrong here. If there are additional
dependencies, they need to be encoded in the specific init scripts, or the LSB
statements removed and a specific priority hardcoded.
Comment 2 Reindl Harald 2007-11-15 11:09:32 EST
So you can tell me why after i disable "network", "named", "wpa_supplicant" and
"messagebus" over "system-config-services" and enable them again for all
runlevels my "/etc/rc5.d" looks like followed?

The order is not correct because network and wpa_supplicant starts long before
messagebus! So this is not "notabug"

[root@nb ~]# ls -l /etc/rc5.d/
insgesamt 96
lrwxrwxrwx 1 root root 24  8. Nov 22:24 K02NetworkManager ->
../init.d/NetworkManager
lrwxrwxrwx 1 root root 34  8. Nov 22:24 K02NetworkManagerDispatcher ->
../init.d/NetworkManagerDispatcher
lrwxrwxrwx 1 root root 16 12. Nov 17:55 K02puppet -> ../init.d/puppet
lrwxrwxrwx 1 root root 22  9. Nov 01:02 K03yum-updatesd -> ../init.d/yum-updatesd
lrwxrwxrwx 1 root root 15  9. Nov 22:54 K05jexec -> ../init.d/jexec
lrwxrwxrwx 1 root root 19  9. Sep 2006  K05saslauthd -> ../init.d/saslauthd
lrwxrwxrwx 1 root root 16 15. Nov 17:05 K08vmware -> ../init.d/vmware
lrwxrwxrwx 1 root root 19  9. Sep 2006  K10dc_server -> ../init.d/dc_server
lrwxrwxrwx 1 root root 16  9. Sep 2006  K10psacct -> ../init.d/psacct
lrwxrwxrwx 1 root root 14  9. Nov 23:08 K10wine -> ../init.d/wine
lrwxrwxrwx 1 root root 19  9. Sep 2006  K12dc_client -> ../init.d/dc_client
lrwxrwxrwx 1 root root 13  7. Jun 16:52 K15gpm -> ../init.d/gpm
lrwxrwxrwx 1 root root 17  8. Nov 22:26 K20tomcat5 -> ../init.d/tomcat5
lrwxrwxrwx 1 root root 13  8. Okt 2006  K28amd -> ../init.d/amd
lrwxrwxrwx 1 root root 17  8. Nov 22:07 K30postfix -> ../init.d/postfix
lrwxrwxrwx 1 root root 13  1. Jun 01:49 K35nmb -> ../init.d/nmb
lrwxrwxrwx 1 root root 19 11. Sep 2006  K35vncserver -> ../init.d/vncserver
lrwxrwxrwx 1 root root 17  9. Sep 2006  K35winbind -> ../init.d/winbind
lrwxrwxrwx 1 root root 14  9. Sep 2006  K36lisa -> ../init.d/lisa
lrwxrwxrwx 1 root root 17 28. Apr 2007  K36mysql41 -> ../init.d/mysql41
lrwxrwxrwx 1 root root 20  8. Feb 2007  K36postgresql -> ../init.d/postgresql
lrwxrwxrwx 1 root root 18  8. Nov 22:10 K45arpwatch -> ../init.d/arpwatch
lrwxrwxrwx 1 root root 20  1. Jun 01:47 K50netconsole -> ../init.d/netconsole
lrwxrwxrwx 1 root root 15  1. Mai 2007  K50snmpd -> ../init.d/snmpd
lrwxrwxrwx 1 root root 19  2. Apr 2007  K50snmptrapd -> ../init.d/snmptrapd
lrwxrwxrwx 1 root root 14  8. Nov 22:04 K71lirc -> ../init.d/lirc
lrwxrwxrwx 1 root root 16  8. Okt 2006  K72autofs -> ../init.d/autofs
lrwxrwxrwx 1 root root 16  9. Sep 2006  K73ypbind -> ../init.d/ypbind
lrwxrwxrwx 1 root root 14  9. Jun 22:58 K74apmd -> ../init.d/apmd
lrwxrwxrwx 1 root root 14  8. Nov 22:08 K74nscd -> ../init.d/nscd
lrwxrwxrwx 1 root root 14  8. Nov 22:08 K74ntpd -> ../init.d/ntpd
lrwxrwxrwx 1 root root 25 15. Nov 17:05 K74readahead_early ->
../init.d/readahead_early
lrwxrwxrwx 1 root root 25 15. Nov 17:05 K74readahead_later ->
../init.d/readahead_later
lrwxrwxrwx 1 root root 15  8. Nov 22:04 K75netfs -> ../init.d/netfs
lrwxrwxrwx 1 root root 15  8. Nov 22:12 K80kdump -> ../init.d/kdump
lrwxrwxrwx 1 root root 16 29. Sep 20:01 K84btseed -> ../init.d/btseed
lrwxrwxrwx 1 root root 17 29. Sep 20:01 K84bttrack -> ../init.d/bttrack
lrwxrwxrwx 1 root root 19 16. Sep 2006  K85mdmonitor -> ../init.d/mdmonitor
lrwxrwxrwx 1 root root 18 13. Nov 2006  K87mcstrans -> ../init.d/mcstrans
lrwxrwxrwx 1 root root 17  1. Jun 15:28 K87rpcbind -> ../init.d/rpcbind
lrwxrwxrwx 1 root root 14 13. Nov 10:40 K88nasd -> ../init.d/nasd
lrwxrwxrwx 1 root root 18  9. Sep 2006  K89netplugd -> ../init.d/netplugd
lrwxrwxrwx 1 root root 15  8. Nov 21:59 K89rdisc -> ../init.d/rdisc
lrwxrwxrwx 1 root root 21 13. Nov 2006  K90restorecond -> ../init.d/restorecond
lrwxrwxrwx 1 root root 22 21. Aug 11:23 K90serverstatus -> ../init.d/serverstatus
lrwxrwxrwx 1 root root 22 16. Sep 2006  K92arptables_jf -> ../init.d/arptables_jf
lrwxrwxrwx 1 root root 19 12. Nov 15:37 K92ip6tables -> ../init.d/ip6tables
lrwxrwxrwx 1 root root 19  9. Dez 2006  K95firstboot -> ../init.d/firstboot
lrwxrwxrwx 1 root root 17  6. Apr 2007  K96courier -> ../init.d/courier
lrwxrwxrwx 1 root root 23  2. Mai 2007  K99microcode_ctl -> ../init.d/microcode_ctl
lrwxrwxrwx 1 root root 15  9. Sep 2006  S05kudzu -> ../init.d/kudzu
lrwxrwxrwx 1 root root 18  9. Sep 2006  S06cpuspeed -> ../init.d/cpuspeed
lrwxrwxrwx 1 root root 18 12. Nov 15:37 S08iptables -> ../init.d/iptables
lrwxrwxrwx 1 root root 16 10. Nov 16:58 S08nvidia -> ../init.d/nvidia
lrwxrwxrwx 1 root root 17 15. Nov 17:04 S10network -> ../init.d/network
lrwxrwxrwx 1 root root 24 15. Nov 17:04 S12wpa_supplicant ->
../init.d/wpa_supplicant
lrwxrwxrwx 1 root root 20  8. Nov 22:11 S13irqbalance -> ../init.d/irqbalance
lrwxrwxrwx 1 root root 20  2. Apr 2007  S26lm_sensors -> ../init.d/lm_sensors
lrwxrwxrwx 1 root root 17 15. Nov 17:05 S26rsyslog -> ../init.d/rsyslog
lrwxrwxrwx 1 root root 20 15. Nov 17:05 S27messagebus -> ../init.d/messagebus
lrwxrwxrwx 1 root root 15 15. Nov 17:05 S27named -> ../init.d/named
lrwxrwxrwx 1 root root 15  8. Nov 22:00 S44acpid -> ../init.d/acpid
lrwxrwxrwx 1 root root 14 11. Sep 2006  S55cups -> ../init.d/cups
lrwxrwxrwx 1 root root 14 21. Aug 10:52 S55sshd -> ../init.d/sshd
lrwxrwxrwx 1 root root 16 11. Nov 2006  S56xinetd -> ../init.d/xinetd
lrwxrwxrwx 1 root root 16  5. Feb 2007  S84mysqld -> ../init.d/mysqld
lrwxrwxrwx 1 root root 15  8. Nov 22:15 S85httpd -> ../init.d/httpd
lrwxrwxrwx 1 root root 19 14. Dez 2006  S85pure-ftpd -> ../init.d/pure-ftpd
lrwxrwxrwx 1 root root 20  8. Nov 22:05 S90ConsoleKit -> ../init.d/ConsoleKit
lrwxrwxrwx 1 root root 15  9. Sep 2006  S90crond -> ../init.d/crond
lrwxrwxrwx 1 root root 13  9. Sep 2006  S90xfs -> ../init.d/xfs
lrwxrwxrwx 1 root root 13 10. Sep 2006  S91smb -> ../init.d/smb
lrwxrwxrwx 1 root root 17  6. Apr 2007  S92courier -> ../init.d/courier
lrwxrwxrwx 1 root root 13  9. Sep 2006  S95atd -> ../init.d/atd
lrwxrwxrwx 1 root root 22 12. Nov 17:20 S96avahi-daemon -> ../init.d/avahi-daemon
lrwxrwxrwx 1 root root 19  9. Sep 2006  S98haldaemon -> ../init.d/haldaemon
lrwxrwxrwx 1 root root 17  8. Nov 22:11 S99anacron -> ../init.d/anacron
lrwxrwxrwx 1 root root 11  8. Nov 22:04 S99local -> ../rc.local
lrwxrwxrwx 1 root root 16 13. Nov 10:40 S99smartd -> ../init.d/smartd
Comment 3 Reindl Harald 2007-11-15 11:15:25 EST
To say it clear

One Problem is that wpa_supplicant have to start after messagebus because it do
not start on fedora 8 without - The other problem is that i have hardcoded the
order by renaming the symlinks in /etc/rc5.d/ so that named starts after
network, wlan and messagebus.

Next day the Symlink for named was renamed and has 30, i renamed it again, next
the same....

The system is an upgraded fedora 7, and before f8 wpa_supplicant did not need
messagebus so there were no troubles
Comment 4 Bill Nottingham 2007-11-15 13:55:51 EST
messagebus requires $local_fs (provided by /etc/init.d/netfs) which requires
$network (provided by /etc/init.d/network.) So the starting order would be
network -> netfs -> messagebus.

It is behaving as designed in that regard.

Are you running updates in the interim after manually changing symlinks that
call chkconfig?
Comment 5 Reindl Harald 2007-11-15 14:09:11 EST
If you make any change with system-config-services the order will change
This is needed after Kernel-Update often
Im not 100% sure, but it seems that named will placed also in other cases
directly after messagebus, both have the same number and so it is difficult to
play with the numbers.

Anyway - wpa_supplicant has to be started AFTER messagebus
named has to be started after network and wpa_supplicant

In other cases named will start without errors, but does not resolve
In F7 the was no problem if named started after network, now you must restart it
manually

My workaround this time is in /etc/rc.loal a "/sbin/service named restart",
because at this point all other services running clean.

But that is not as good as it could/should be

__

Now there comes some problems at one pint together

* wpa_supplicant does not start without runnign "messagebus" before
* named starts, but does not work without network/wlan is startet clean

BTW:
The dependency of "netfs" is not true, the service is not running on my machine,
because the is no need fpr smb/nfs and all things work perfect without, so i see
no reason to start a unused service
Comment 6 Bill Nottingham 2007-11-15 14:17:52 EST
If wpa_supplicant needs to be started after messagebus, please file a new bug
against it that it needs to depend on messagebus.

As for netfs, something needs to provide $local_fs, the guarantee that all
filesystems are mounted. That has to be after network filesystems are mounted,
so, the dependency goes in netfs. In your case above, messagebus is moved to 27
to be after syslog, anyway.
Comment 7 Adam Tkac 2007-11-19 07:00:29 EST
*** Bug 381981 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.