Bug 382031 - system-config-printer : Cups connecting problem
system-config-printer : Cups connecting problem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-11-14 05:21 EST by J.Jansen
Modified: 2008-01-29 00:17 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.7.74.10-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 00:15:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Requested log file (247.30 KB, application/x-bzip2)
2007-11-14 09:19 EST, J.Jansen
no flags Details
strace -s2048 2>log system-config-printer (782.32 KB, application/octet-stream)
2007-12-26 01:53 EST, Rick Richardson
no flags Details
screenshot - "system-config-printer --configure-printer zzz" (224.46 KB, image/png)
2007-12-26 02:02 EST, Rick Richardson
no flags Details

  None (edit)
Description J.Jansen 2007-11-14 05:21:08 EST
Description of problem:
On my "fresh" installed F8 system I get the following when I fire up
system-config-printer:
  "Printer configuration - localhost" window pops up with printers listed
  another window pops-up immidiately telling : ERROR there was a problem
connecting to the CUPS server
  Clicking on OK kills the whole application

cups is running and I could add a printer using the http://localhost:631 interface. 

Version-Release number of selected component (if applicable):
0.7.74.4-3.fc8

How reproducible:
Always

Steps to Reproduce:
1.start system-config-printer in F8
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2007-11-14 06:50:26 EST
What does 'lpstat -r' say?
Comment 2 J.Jansen 2007-11-14 07:19:45 EST
aaee-jj ) lpstat -r
scheduler is running
aaee-jj ) 

Comment 3 Tim Waugh 2007-11-14 07:31:04 EST
What does this command say?:

python -c 'import cups; c=cups.Connection()'
Comment 4 J.Jansen 2007-11-14 08:39:42 EST
Nothing!!!!!!!


aaee-jj ) python -c 'import cups; c=cups.Connection()'
aaee-jj ) 

Comment 5 Tim Waugh 2007-11-14 08:55:04 EST
Please run this command:

strace -s2048 2>log system-config-printer
bzip2 log

and send me the 'log.bz2' file you end up with after the error.  Thanks.
Comment 6 J.Jansen 2007-11-14 09:19:28 EST
Created attachment 258071 [details]
Requested log file
Comment 7 J.Jansen 2007-11-14 09:20:47 EST
Log file sent as attachment
Comment 8 Tim Waugh 2007-11-14 09:53:11 EST
Thanks.  I've identified the problem and fixed it upstream.  The fix is not to
terminate the program in that situation but allow other printers to be selected.

The default printer on your network is on a CUPS server that is unreachable. 
This could be because it has been remembered from a previous network, cached in
/var/cache/cups/remote.cache.  If you stop CUPS (/sbin/service cups stop), then
remove that cache file, and start CUPS again (/sbin/service cups start) you will
probably find that the error goes away.

If not, there is a mis-configured printer on your network.
Comment 9 J.Jansen 2007-11-14 10:42:35 EST
The problem did not go away. Cups tells me the "default" printer is my local
printer (hrem-printer), the one I added this morning.
All the other printers are remote printers. I do not have control over all of
them, since those are not my machines.
Seems that system-config-printer has an other "default" pinter (Epson) than
http://local:631 (hrem-printer).
Comment 10 Fedora Update System 2007-11-15 19:37:23 EST
system-config-printer-0.7.74.5-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 11 Fedora Update System 2007-11-15 19:39:13 EST
system-config-printer-0.7.74.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 12 Fedora Update System 2007-11-20 12:47:03 EST
system-config-printer-0.7.74.6-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 13 Fedora Update System 2007-11-20 13:07:26 EST
system-config-printer-0.7.74.6-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 14 Fedora Update System 2007-11-21 22:34:12 EST
system-config-printer-0.7.74.6-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 15 Fedora Update System 2007-11-21 22:34:38 EST
system-config-printer-0.7.74.6-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 16 Fedora Update System 2007-11-26 13:40:04 EST
system-config-printer-0.7.74.7-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 17 Fedora Update System 2007-11-26 13:58:17 EST
system-config-printer-0.7.74.7-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 18 Fedora Update System 2007-12-20 14:55:37 EST
system-config-printer-0.7.74.8-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 19 Rick Richardson 2007-12-26 01:45:25 EST
On my "fresh" installed F8 system I get the following when I fire up
system-config-printer:

  "Printer configuration - localhost" window pops up with printers listed
  another window pops-up immidiately telling : ERROR there was a problem
connecting to the CUPS server
  Clicking on OK kills the whole application

cups is running and I could add a printer using the http://localhost:631 interface. 

DITTO!!!

If I do:

$ system-config-printer --configure-printer zzz
and click "Show printers shared by other systems" to OFF, it works...



$ 
Comment 20 Rick Richardson 2007-12-26 01:53:49 EST
Created attachment 290395 [details]
strace -s2048 2>log system-config-printer
Comment 21 Rick Richardson 2007-12-26 02:02:18 EST
Created attachment 290397 [details]
screenshot - "system-config-printer --configure-printer zzz"
Comment 22 Rick Richardson 2007-12-29 01:35:05 EST
oh yeah...

$ su -c 'yum --enablerepo=updates-testing update system-config-printer'
Password: 
updates-testing           100% |=========================| 2.3 kB    00:00     
primary.sqlite.bz2        100% |=========================| 328 kB    00:01     
Setting up Update Process
Could not find update match for system-config-printer
No Packages marked for Update

but...

system-config-printer.i386               0.7.74.4-3.fc8

Comment 23 Tim Waugh 2008-01-02 08:15:33 EST
Rick: please wait until 0.7.74.8-1.fc8 appears in updates-testing.  It's
currently pending and should appear soon.
Comment 24 Fedora Update System 2008-01-15 18:06:20 EST
system-config-printer-0.7.74.8-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 25 Fedora Update System 2008-01-22 10:33:48 EST
system-config-printer-0.7.74.9-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 26 Fedora Update System 2008-01-22 10:46:35 EST
system-config-printer-0.7.74.9-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 27 Rick Richardson 2008-01-22 10:47:49 EST
$ uname -a
Linux dual.rkkda.org 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:59 EST 2007 i686
i686 i386 GNU/Linux

$ su -c 'yum --enablerepo=updates-testing update system-config-printer'
Password: 
Setting up Update Process
Could not find update match for system-config-printer
No Packages marked for Update
Comment 28 Tim Waugh 2008-01-23 12:37:52 EST
Be patient for your local mirror to catch up.
Comment 29 Rick Richardson 2008-01-23 13:42:53 EST
Updated: system-config-printer.i386 0:0.7.74.9-2.fc8
system-config-printer-libs.i386 0:0.7.74.9-2.fc8

OK.  Now I get:

CUPS Server Error
There was an error during the CUPS operation: 'server-error-service-unavailable'.

When I click on a remote printer.
Comment 30 Tim Waugh 2008-01-24 05:55:10 EST
Rick: but you can still continue to use the application, can't you?  I know that
there is an error connecting to the remote device, but this bug report is about
how system-config-printer behaves when there is such an error.  The fix is that
the application does not quit now, but allows you to choose another server etc.

If you think that you ought to be able to connect to that particular remote
server, and the reason you can't is some sort of system-config-printer bug,
please report a separate bug about that. (I would tend to think it is more
likely to be a problem on the remote side.)
Comment 31 Rick Richardson 2008-01-24 07:12:21 EST
Yes, I can continue.

If I "Goto to Sever" on amd.rkkda.org root/PASSWORD,  I get a list of all
printers on that server, with URI, etc. filled in.  So far, so good.

If I click on "2430" or "2430s" or "mc5430", all is well and see "Printer Options.
State is Enabled, Accepting Jobs, but NO Shared.

If I click on the others (about 20 printers), e.g. "hp2600", I get the
"server-error-server-unavilable", and NO "Printer Options" is displayed'.
State is Enabled, Accepting Jobs, and Shared.

What could be the problem?
Comment 32 Tim Waugh 2008-01-24 07:36:57 EST
Rick, I don't know -- some sort of problem on the remote end.  If you think that
you should be able to do this, please file a separate bug report concerning that.
Comment 33 Fedora Update System 2008-01-27 02:12:21 EST
system-config-printer-0.7.74.10-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/F8/FEDORA-2007-3416
Comment 34 Fedora Update System 2008-01-29 00:15:47 EST
system-config-printer-0.7.74.10-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 35 Fedora Update System 2008-01-29 00:17:42 EST
system-config-printer-0.7.74.10-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.