Bug 38221 - linuxconf-web is broken in RH 7.1
linuxconf-web is broken in RH 7.1
Status: CLOSED DUPLICATE of bug 23560
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-28 16:53 EDT by Tim
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-28 16:53:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim 2001-04-28 16:53:45 EDT
I have no problem accessing linuxconf via a shell, but cannot do so via a 
browser.

I have configured "/etc/xidentd.d/linuxconf-web" as such:

>  cat /etc/xinetd.d/linuxconf-web 
> # default: off
> # description: The Linuxconf system can also be accessed via a web \
> #              browser.  Enabling this service will allow
> connections to \
> #              Linuxconf running in web UI mode.
> service linuxconf
> {
>         socket_type     = stream
>         wait            = yes
>         user            = root
>         server          = /sbin/linuxconf
>         server_args     = --http
>         disable         = no
> }

and done a "/etc/rc.d/init.d/xinetd/restart", but attempting to 
access "linuxconf-web" on my local machine at the local machine results in 
nothing but:

> lynx http://localhost:98
> HTTP request sent; waiting for response.

and then it just sits there.

If I disable "linuxconf-web" via xinetd, then I get the following:

> Alert!: Unable to connect to remote host.
>
>
> Looking up localhost:98
> Making HTTP connection to localhost:98
> Alert!: Unable to connect to remote host.
> 
> lynx: Can't access startfile http://localhost:98/

I can access "linuxconf-web" if I start it via a "/sbin/linuxconf --http --
debug" and point my web browser to it at port 8000.

Linuxconf-web was broke (via xinetd) in RH 7.0 and I reported that.  
Anyone have a clue on how to get it to work properly in RH 7.1?

Reproducible: Always
Steps to Reproduce:
1.  Install linuxconf.
2.  Allow web access (aka "linuxconf-web") by modifying 
the "/etc/xinetd.d/linuxconf-web" file from "disable = yes" to "disable = 
no".
3.  Restart xinetd
4.  Attempt to access linuxconf on port 98 via the local network via the 
browser of your choice.
	

Actual Results:  Just sits there.

Expected Results:  The linuxconf-web interface should pop up in the 
browser window.
Comment 1 Trond Eivind Glomsrxd 2001-05-01 11:01:03 EDT

*** This bug has been marked as a duplicate of 23560 ***

Note You need to log in before you can comment on or make changes to this bug.