Bug 23560 - xinetd - linuxconf-web still not fixed
xinetd - linuxconf-web still not fixed
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
: 18221 38221 39189 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-07 19:13 EST by Sterling Ledet & Associates, Inc.
Modified: 2007-04-18 12:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-10 17:13:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Wait patch for xinetd, diff against xinetd-2.1.8.9pre14-6 from qa0404's SRPMS. (283 bytes, patch)
2001-04-10 16:39 EDT, Milan Kerslager
no flags Details | Diff

  None (edit)
Description Sterling Ledet & Associates, Inc. 2001-01-07 19:13:50 EST
Although this is marked as resolved in bugzilla, if there is an 
/etc/hosts.deny file active, linuxconf-web still does not work with xinetd 
even after the current errata are applied.
Comment 1 Trond Eivind Glomsrxd 2001-01-07 20:58:49 EST
You probably haven't enabled the linuxconf service, it isn't enabled by default.
Comment 2 Need Real Name 2001-02-07 11:51:10 EST
There still is a real bug in the xinetd source rpm (xinetd-2.1.8.9pre11 of 
October 2000): In the source, a patch was not correctly applied - look at 
the .rej file for connection.c. Result of this bug is that a tcp wait service 
(as e.g. linuxconf) never can be restarted once the daemon exits. The fix is 
obvious.
Comment 3 Trond Eivind Glomsrxd 2001-02-19 12:21:32 EST
There is no .rej files in the current version, and haven't been for some time
either... Still looking into the original problem.
Comment 4 Trond Eivind Glomsrxd 2001-04-09 13:30:59 EDT
*** Bug 18221 has been marked as a duplicate of this bug. ***
Comment 5 Milan Kerslager 2001-04-09 22:11:26 EDT
Still I wonder why this doesn't produce anything:

linuxconf --http
GET / HTTP/1.0

It seems that linuxconf hang somewhere in its code and waiting indefinitely. 
The same hang you can see if linuxconf is inoked by xinetd (with the same 
parameter).

Verified in qa0404, RH 7.0 has the same trouble (even upgrading xinetd & 
others).
Comment 6 Milan Kerslager 2001-04-09 22:20:21 EDT
Hmm, I tryed command line on RH 6.2 where WWW access via inetd works and 
linuxconf did not produxce any output too. So this seems that the bug may be 
inside xinetd as is written above. Sorry.
Comment 7 Milan Kerslager 2001-04-10 16:37:21 EDT
I tryed the wait patch from linuxconf guys. It makes linuconf work again. Here
it is:

--- xinetd-2.1.8.9pre14/xinetd/connection.c.orig	Mon Dec 11 00:57:11 2000
+++ xinetd-2.1.8.9pre14/xinetd/connection.c	Tue Apr 10 22:20:34 2001
@@ -86,8 +86,6 @@

	}
 #endif

-
	M_SET( cp->co_flags, COF_HAVE_ADDRESS ) ;
-
	M_SET( cp->co_flags, COF_NEW_DESCRIPTOR ) ;
 	}
 	else
 	{

The original of this patch can be found at:
ftp://ftp.solucorp.qc.ca/pub/misc/xinetd-wait.patch

Please, apply this patch if you can as this solve the problem with wait services
served by xinetd. I will attach this patch as an attachment to this bug.
Comment 8 Milan Kerslager 2001-04-10 16:39:44 EDT
Created attachment 15084 [details]
Wait patch for xinetd, diff against xinetd-2.1.8.9pre14-6 from qa0404's SRPMS.
Comment 9 Trond Eivind Glomsrxd 2001-04-10 17:13:01 EDT
I found this a couple of hours ago :)
Comment 10 Trond Eivind Glomsrxd 2001-04-10 18:21:52 EDT
The release with the fix is xinetd-2.1.8.9pre14-7, coming soon to Rawhide and
available now from http://people.redhat.com/teg/xinetd/
Comment 11 Trond Eivind Glomsrxd 2001-05-01 11:00:58 EDT
*** Bug 38221 has been marked as a duplicate of this bug. ***
Comment 12 Trond Eivind Glomsrxd 2001-05-07 17:11:53 EDT
*** Bug 39189 has been marked as a duplicate of this bug. ***
Comment 13 Trond Eivind Glomsrxd 2001-05-08 10:34:15 EDT
*** Bug 39189 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.