Bug 38227 - post-install script 'fonts.dir' bug
Summary: post-install script 'fonts.dir' bug
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ttfonts   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
: 33118 38874 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-29 02:37 UTC by Michael Schwendt
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-30 08:40:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against spec file (363 bytes, patch)
2001-04-29 02:44 UTC, Michael Schwendt
no flags Details | Diff

Description Michael Schwendt 2001-04-29 02:37:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.19 i686; en-US; rv:0.8.1+)
Gecko/20010425


The order of the commands in the rpm's post-install script is incorrect.

Reproducible: Always
Steps to Reproduce:
1. rpm -e ttfonts
2. rpm -ivvh ttfonts
3. ls -la /usr/share/fonts/default/TrueType/fonts.dir
	

Actual Results:  The 'fonts.dir' created by 'mkfontdir' in the rpm's
post-install script is empty (2 bytes).

Expected Results:  A valid 'fonts.dir'.

Comment 1 Michael Schwendt 2001-04-29 02:44:27 UTC
Created attachment 16765 [details]
patch against spec file

Comment 2 Mike A. Harris 2001-04-30 08:40:35 UTC
Bero, I just checked this, and it does seem to fix the problem.  I think this
might solve a lot of the Truetype font problems people have been having.
Please apply the patch and test on a clean system with no ttfonts and on
upgrade.

Thanks mschwendt@web.de for tracking this down.

Comment 3 Bernhard Rosenkraenzer 2001-04-30 13:55:17 UTC
Fixed in 1.0-4


Comment 4 Bernhard Rosenkraenzer 2001-05-03 09:15:33 UTC
*** Bug 38874 has been marked as a duplicate of this bug. ***

Comment 5 Bernhard Rosenkraenzer 2001-05-03 09:15:58 UTC
*** Bug 33118 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.