Bug 382271 - udev rules seem to disallow gphoto2 to detect and import pictures from camera connected to USB port
Summary: udev rules seem to disallow gphoto2 to detect and import pictures from camera...
Status: CLOSED DUPLICATE of bug 400491
Alias: None
Product: Fedora
Classification: Fedora
Component: hal   
(Show other bugs)
Version: 8
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-14 12:06 UTC by Sankarshan Mukhopadhyay
Modified: 2013-03-06 03:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 13:22:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of gphoto2 in debug mode if it is of any use (2.24 KB, text/plain)
2007-11-14 12:06 UTC, Sankarshan Mukhopadhyay
no flags Details
ls -ZR /dev/ in case it helps (22.35 KB, text/plain)
2007-11-15 08:03 UTC, Sankarshan Mukhopadhyay
no flags Details

Description Sankarshan Mukhopadhyay 2007-11-14 12:06:23 UTC
Description of problem:

Attaching a camera to the USB port and using gthumb/gphoto2 leads to the
following message:

An error occurred in the io-library (’Could not claim the USB device’): Could
not claim interface 0 (Operation not permitted). Make sure no other program or
kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have
read/write access to the device

Version-Release number of selected component (if applicable): udev-116-3.fc8


How reproducible:


Steps to Reproduce:
1. Fresh install Fedora 8
2. Attach camera to usb port
3. Use gphoto2/gthumb to import photos
  
Actual results:

An error occurred in the io-library (’Could not claim the USB device’): Could
not claim interface 0 (Operation not permitted). Make sure no other program or
kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have
read/write access to the device

Expected results:

Photos get imported.

Additional info:

I have been suggested the fix at (but not implemented) 
http://www.fedoraforum.org/forum/showpost.php?p=891711&postcount=5

Comment 1 Sankarshan Mukhopadhyay 2007-11-14 12:06:24 UTC
Created attachment 257951 [details]
output of gphoto2 in debug mode if it is of any use

Comment 2 Harald Hoyer 2007-11-15 07:42:42 UTC
Isn't the haldaemon supposed to set the ACL?
See also bug #362221 for a similar problem.

Comment 3 Sankarshan Mukhopadhyay 2007-11-15 08:03:48 UTC
Created attachment 259601 [details]
ls -ZR /dev/ in case it helps

Comment 4 Sankarshan Mukhopadhyay 2007-11-15 08:05:22 UTC
(In reply to comment #3)
> Created an attachment (id=259601) [edit]
> ls -ZR /dev/ in case it helps

I'll be trying out # yum --enablerepo=updates-testing update udev to check.
Thanks for the inputs.



Comment 5 Jesse Barnes 2007-11-18 19:52:36 UTC
I'm seeing this too, with udev rules from 11/18.

Comment 6 Sankarshan Mukhopadhyay 2007-11-24 04:33:35 UTC
Reverting back to 2.6.23.1-42.fc8 solves the issue for me. Is there a way I can
provide more information that can be of help ?

Comment 7 Hans Ulrich Niedermann 2007-11-27 20:15:22 UTC
Is it possible that https://bugzilla.redhat.com/show_bug.cgi?id=400491 is behind
this bug, and now is fixed?


Comment 8 Jindrich Novy 2007-11-28 13:22:05 UTC
Yup, marking as duplicate.

*** This bug has been marked as a duplicate of 400491 ***

Comment 9 Jindrich Novy 2007-11-30 06:33:03 UTC
You say in bug 400491 it doesn't work for you with the latest updated gphoto2.
Have tried it with the latest kernel? I think Chuck only applied the storage
class kernel fix only to F8 and F7 so that it might not work with rawhide kernel
yet.

Comment 10 Sankarshan Mukhopadhyay 2007-11-30 07:09:14 UTC
(In reply to comment #9)
> You say in bug 400491 it doesn't work for you with the latest updated gphoto2.
> Have tried it with the latest kernel? I think Chuck only applied the storage
> class kernel fix only to F8 and F7 so that it might not work with rawhide kernel
> yet.

I don't think I commented on 400491. Right now as stated above, I am using the
kernel where it was working and waiting a final push before upgrading/updating.
I am not right now in a position to install from updates-testing etc. Thanks.


Note You need to log in before you can comment on or make changes to this bug.