Bug 400491 - Gphoto2 cannot see camera, permission problem
Gphoto2 cannot see camera, permission problem
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
: 349691 376801 382271 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 21:27 EST by Philippe Troin
Modified: 2013-07-02 19:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: 2.4.0-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 06:44:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gphoto2 -L debug log (30.72 KB, text/plain)
2008-01-02 18:14 EST, Stephan Sachse
no flags Details

  None (edit)
Description Philippe Troin 2007-11-26 21:27:32 EST
Description of problem:
Connection a camera via USB does not work.

Version-Release number of selected component (if applicable):
gphoto2-2.4.0-3.fc8.i386

How reproducible:
Always.

Steps to Reproduce:
1. Plug a camera
2. Run "gphoto2 -L"
3. Get an error
4. Su to root
5. Run "gphoto2 -L"
6. It works as root.

Changing /usr/share/hal/fdi/information/20thirdparty/10-camera-libgphoto2.fdi as
follows makes it work:

--- /usr/share/hal/fdi/information/20thirdparty/10-camera-libgphoto2.fdi.orig
+++ /usr/share/hal/fdi/information/20thirdparty/10-camera-libgphoto2.fdi       
2007-09-18 22:34:09.000000000 -0700
@@ -8,7 +8,7 @@
  <device>
   <match key="info.bus" string="usb">
    <!-- skip USB Mass Storage Devices -->
-   <match key="usb.interface_class" compare_ne="8">
+   <match key="usb.interface.class" compare_ne="8">
     <match key="usb.vendor_id" int="1363">
      <match key="usb.product_id" int="514">
       <merge key="info.category" type="string">camera</merge>

Phil.
Comment 1 Jindrich Novy 2007-11-27 04:10:03 EST
Fixed in F8 and rawhide. It should occur shortly in testing updates.
Comment 2 Hans Ulrich Niedermann 2007-11-27 15:17:46 EST
I suspect that this bug and https://bugzilla.redhat.com/show_bug.cgi?id=382271
may be identical, and now both fixed with the
s/usb.interface_class/usb.interface.class/ change.
Comment 3 Jindrich Novy 2007-11-28 08:19:30 EST
*** Bug 376801 has been marked as a duplicate of this bug. ***
Comment 4 Jindrich Novy 2007-11-28 08:20:00 EST
*** Bug 349691 has been marked as a duplicate of this bug. ***
Comment 5 Jindrich Novy 2007-11-28 08:22:06 EST
*** Bug 382271 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2007-11-28 20:35:06 EST
gphoto2-2.4.0-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gphoto2'
Comment 7 Paul Vandenberg 2007-11-29 18:58:07 EST
The gphoto update didn't fix the problem for me. My bug, 376801, was marked as a
duplicate of this one. However, I don't think it is exactly the same. I have the
problem even when using root. This bug indicates that the import works as root.
Anyway, I bought a card reader to get around my problem.
Comment 8 Fedora Update System 2007-12-03 06:44:27 EST
gphoto2-2.4.0-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Stephan Sachse 2008-01-02 18:14:50 EST
Created attachment 290685 [details]
gphoto2 -L debug log

the problem still exists for me with my Canon PowerShot A60 (same as bug
376801)

/var/log/messages says

Jan  2 20:24:23 foobar kernel: usb 2-2: new full speed USB device using
uhci_hcd and address 17
Jan  2 20:24:23 foobar kernel: usb 2-2: configuration #1 chosen from 1 choice

-> here gthumb-import pop-up comes up

Jan  2 20:24:59 foobar kernel: usb 2-2: reset full speed USB device using
uhci_hcd and address 17
Jan  2 20:24:59 foobar kernel: usb 2-2: device firmware changed
Jan  2 20:24:59 foobar kernel: usb 2-2: USB disconnect, address 17
Jan  2 20:24:59 foobar kernel: usb 2-2: new full speed USB device using
uhci_hcd and address 18
Jan  2 20:24:59 foobar kernel: usb 2-2: configuration #1 chosen from 1 choice
-> a new gthumb-import pop-up comes up
Comment 10 Nathaniel Daw 2008-01-06 16:16:24 EST
I also found this is still broken due to permissions problems on the USB device.
The solution to bug #424331 (commenting out a udev rule), which is about
permissions problems with USB printers, also fixed this for me.
Comment 11 Steven Dake 2008-05-18 17:06:56 EDT
*** Bug 430296 has been marked as a duplicate of this bug. ***
Comment 12 Hans Ulrich Niedermann 2008-05-18 17:22:06 EDT
Could you elaborate on how Bug 430296 ("RHEL5 cmirror tracker: recovered cluster
node deadlocks during volume activation") is a duplicate of this-here bug 400491
on a gphoto2 permission problem?
Comment 13 Corey Marthaler 2008-05-19 11:33:51 EDT
He meant 400941. I'll change it.

Note You need to log in before you can comment on or make changes to this bug.