This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 382681 - system-config-network corrupts /etc/hosts
system-config-network corrupts /etc/hosts
Status: CLOSED DUPLICATE of bug 367521
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 10:53 EST by David Wood
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 11:47:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A cut down version of my /etc/hosts file (798 bytes, text/plain)
2007-11-14 10:53 EST, David Wood
no flags Details

  None (edit)
Description David Wood 2007-11-14 10:53:46 EST
My /etc/hosts file is being corrupted when I select the hosts tab in
system-config-network and save the configuration (even if I don't change
anything).  Furthermore, the list of hosts isn't being correctly displayed.  I
just get the local host repeated for each line.

Version-Release number of selected component (if applicable):
system-config-network-1.4.3-1.fc8

How reproducible: Always.

Steps to Reproduce:
Open the attached /etc/hosts file with system-config-network.  Don't change
anything. Save changes on exit.
  
Actual results:
Extra meaningless host lines, tabs added all over the place.

Expected results:
An unchanged /etc/hosts file.
Comment 1 David Wood 2007-11-14 10:53:46 EST
Created attachment 258191 [details]
A cut down version of my /etc/hosts file
Comment 2 Jiri Moskovcak 2007-11-14 11:47:36 EST

*** This bug has been marked as a duplicate of 367521 ***

Note You need to log in before you can comment on or make changes to this bug.