Bug 38312 - xchat does not save userlist buttons correctly (or at all)
Summary: xchat does not save userlist buttons correctly (or at all)
Status: CLOSED DUPLICATE of bug 37331
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xchat   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-29 16:27 UTC by Carlos Rodrigues
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 18:33:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carlos Rodrigues 2001-04-29 16:27:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)


After making changes (eg. adding a button) to the userlist buttons in xchat
and saving the changes, the buttons appear ok, but after restarting xchat
they are missing. I've noticed that it isn't saving the changes to
~/.chat/buttons.conf but to ~/.xchat/<some garbage>. The only workaround
I've found is to edit buttons.conf by hand :(.

Reproducible: Always
Steps to Reproduce:
1. Launch xchat
2. Settings->Userlist buttons...
3. Add new
4. Edit the button's name and command
5. Save
6. Exit xchat
7. Launch xterm
8. ls ~/.xchat
9. Launch xchat


Actual Results:  In ~/.xchat there was a file with some garbage characters
as the name.
The button previously added was missing.

Expected Results:  The button should have been saved.

Comment 1 Carlos Rodrigues 2001-04-29 17:02:21 UTC
The problem doesn't appear after rebuilding the xchat package with the 
japanese patches disabled.

Comment 2 Havoc Pennington 2001-07-12 18:33:35 UTC
I believe we have this bug in here twice and the other copy has a patch attached. 
Need to merge dups and get the fix in.

Comment 3 Havoc Pennington 2001-07-16 20:46:06 UTC
Found the duplicate bug now

*** This bug has been marked as a duplicate of 37331 ***


Note You need to log in before you can comment on or make changes to this bug.